Звіт PowerProtect Data Manager не показує даних

Summary: Звіт PowerProtect Data Manager не показує жодних даних, але двигун звіту перебуває у статусі Готовий.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ця проблема спостерігається у PowerProtect Data Manager 19.14 та 19.15.

Звіт PowerProtect Data Manager не показує жодних даних.

У движку звітування виявлено наступну помилку у /var/log/dellemc/agent/dpaagent.log (Або в пакеті підтримки PowerProtect Data Manager: \var\log\reporting\logs\agent\dpaagent.log):

INFO     3345.3484     20240219:150901 com.emc.dpa.agent.mo - authenticate(): Attempting CREDS token, as the certificate based token generation is failed.
WARN     3345.3484     20240219:150902 com.emc.dpa.agent.mo - obtainAccessToken(): Failed to login to xxx.xxx.com with user admin: HTTP post status: 423
INFO     3345.3490     20240219:151406 com.emc.dpa.agent.mo - authenticate(): Certificates are being setup...
INFO     3345.3490     20240219:151511 com.emc.dpa.agent.mo - authenticate(): Using authType CERT
INFO     3345.3490     20240219:151511 com.emc.dpa.agent.mo - authenticate(): Attempting CREDS token, as the certificate based token generation is failed.
WARN     3345.3490     20240219:151511 com.emc.dpa.agent.mo - obtainAccessToken(): Failed to login to xxx.xxx.com with user admin: HTTP post status: 401

Cause

Повідомлення про білий список IP-адреси могли закінчитися (за замовчуванням встановлено 365 днів). Щоб це підтвердити, виконайте наступну команду в CLI PowerProtect Data Manager разом із адміністратором:

./ppcp rest --uri whitelist 

Якщо IP-адреса вузла звітування не відображається у виході наведеної вище команди, це означає, що IP-адреса звіту не внесена до білого списку. Наступний вихід є прикладом для reporting IP is currently not whitelisted:

admin@ppdm:~/bin> ./ppcp rest --uri whitelist
===========================================================
PPCP  :  0.44
PPDM  :  19.14.0-20
Date  :  18 Dec 2023 10:41 CST
===========================================================
URL :  GET https://localhost:8443/api/v2/whitelist?page=1&pageSize=100 [localhost]
{
 "content": [],
 "page":
{   "number": 1,   "size": 0,   "totalElements": 0,   "totalPages": 0  }
}

Resolution

Крок 1: Виконайте таку команду. Замінити 10.xxx.xxx.xxx з клієнтами, які повідомляють IP вузла, і збирають expiresAt цінність.

./ppcp rest https://10.xxx.xxx.xx:8443 --uri whitelist

Крок 2: Створіть файл, викликаний payload.txt використовуючи клієнтський PowerProtect Data Manager за адресою /home/admin Використовуючи наступну команду:

vi payload.txt

Скопіюйте наступний матеріал у payload.txt Справу. На цьому етапі оновіть expiresAt значення як 3 роки з дати закінчення терміну придатності та IP-адреси як клієнт, який повідомляє IP, і зберігає файл.

{
            "expiresAt": "2027-02-27T12:57:10.389Z",
            "ip": "10.xxx.xxx.xxx",
            "roleId": "2bc98750-7675-0136-29e9-5bbd3ce729b0",
            "state": "APPROVED"
}

Крок 3: Запустіть наступне ppcp команду з IP-адресою, що звітує вузлом. 

./ppcp rest --method POST https://10.xxx.xxx.xxx:8443 --uri whitelist --input payload.txt

Після виконання вищезазначених кроків відновіть сертифікати на вузлі звітності. Щоб зробити те саме, виконайте наступні кроки:

Step 01: Make sure a single entry in crontab is present to generate certificates.

crontab -l

crontab -e

Step 02: remove old certificates from /opt/emc/dpa/agent/data/ppdm/rs directory.

rm -rf /opt/emc/dpa/agent/data/ppdm/rs

Step 03: DPA agent restart regenerate the certificates.

/opt/emc/dpa/services/bin/dpa.sh agent restart

Step 04: run below command

/opt/emc/dpa/services/bin/dpa.sh svc restart

Affected Products

PowerProtect Software
Article Properties
Article Number: 000222608
Article Type: Solution
Last Modified: 11 Dec 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.