PowerProtect Data Manager 보고서에 데이터가 표시되지 않음
Summary: PowerProtect Data Manager 보고서에 갑자기 데이터가 표시되지 않습니다. 하지만 엔진이 Ready 상태인 것으로 보고되었습니다.
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Symptoms
이 문제는 PowerProtect Data Manager 19.14 및 19.15에서 나타납니다.
PowerProtect Data Manager 보고서에 데이터가 표시되지 않습니다.
보고 엔진의 /var/log/dellemc/agent/dpaagent.log(또는 PowerProtect Data Manager support bundle:\var\log\reporting\logs\agent\dpaagent.log)에서 아래 오류를 찾을 수 있습니다.
PowerProtect Data Manager 보고서에 데이터가 표시되지 않습니다.
보고 엔진의 /var/log/dellemc/agent/dpaagent.log(또는 PowerProtect Data Manager support bundle:\var\log\reporting\logs\agent\dpaagent.log)에서 아래 오류를 찾을 수 있습니다.
INFO 3345.3484 20240219:150901 com.emc.dpa.agent.mo - authenticate(): Attempting CREDS token, as the certificate based token generation is failed. WARN 3345.3484 20240219:150902 com.emc.dpa.agent.mo - obtainAccessToken(): Failed to login to xxx.xxx.com with user admin: HTTP post status: 423 INFO 3345.3490 20240219:151406 com.emc.dpa.agent.mo - authenticate(): Certificates are being setup... INFO 3345.3490 20240219:151511 com.emc.dpa.agent.mo - authenticate(): Using authType CERT INFO 3345.3490 20240219:151511 com.emc.dpa.agent.mo - authenticate(): Attempting CREDS token, as the certificate based token generation is failed. WARN 3345.3490 20240219:151511 com.emc.dpa.agent.mo - obtainAccessToken(): Failed to login to xxx.xxx.com with user admin: HTTP post status: 401
Cause
보고 IP 허용 목록이 만료되었을 수 있습니다(기본값은 365일로 설정됨). 이를 확인하려면 고객 PowerProtect Data Manager CLI에서 admin 사용자로 아래 명령을 실행합니다.
./ppcp rest --uri whitelist
위 명령의 출력에서 보고 노드 IP가 표시되지 않으면 보고 IP가 현재 허용 목록에 없는 것입니다.
아래 출력은 "보고 IP가 현재 허용 목록에 없음"에 대한 예이며 해결 부분의 단계를 따라야 합니다.
admin@ppdm:~/bin> ./ppcp rest --uri whitelist
===========================================================
PPCP : 0.44
PPDM : 19.14.0-20
Date : 18 Dec 2023 10:41 CST
===========================================================
URL : GET https://localhost:8443/api/v2/whitelist?page=1&pageSize=100 [localhost]
{
"content": [],
"page":
{ "number": 1, "size": 0, "totalElements": 0, "totalPages": 0 }
}
Resolution
1단계: 아래 명령을 실행하고 노드 IP를 보고하는 고객으로 10.xxx.xxx.xxx 교체하고 "expiresAt" 값을 수집합니다.
./ppcp rest https://10.xxx.xxx.xx:8443 --uri whitelist
2단계:
아래 명령을 사용하여 /home/admin에서 고객 PowerProtect Data Manager에서 payload.txt using이라는 파일을 생성합니다.
vi payload.txt
payload.txt 파일의 아래 내용을 복사하십시오. 이 단계에서는 expiresAt 값을 만료 날짜로부터 3년으로 업데이트하고 IP 주소를 고객이 IP를 보고하는 것으로 업데이트하고 파일을 저장합니다.
{
"expiresAt": "2027-02-27T12:57:10.389Z",
"ip": "10.xxx.xxx.xxx",
"roleId": "2bc98750-7675-0136-29e9-5bbd3ce729b0",
"state": "APPROVED"
}
3단계:
보고 노드 IP를 사용하여 아래 ppcp 명령을 실행합니다.
./ppcp rest --method POST https://10.xxx.xxx.xxx:8443 --uri whitelist --input payload.txt
위의 단계를 수행한 후에는 보고 노드에서 인증서를 다시 생성해야 합니다. 동일한 작업을 수행하려면 다음 단계를 따르세요.
Step 01: Make sure a single entry in crontab is present to generate certificates. crontab -l crontab -e Step 02: remove old certificates from /opt/emc/dpa/agent/data/ppdm/rs directory. rm -rf /opt/emc/dpa/agent/data/ppdm/rs Step 03: DPA agent restart regenerate the certificates. /opt/emc/dpa/services/bin/dpa.sh agent restart Step 04: run below command /opt/emc/dpa/services/bin/dpa.sh svc restart
Affected Products
PowerProtect SoftwareArticle Properties
Article Number: 000222608
Article Type: Solution
Last Modified: 11 Dec 2025
Version: 3
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