Der Mauszeiger ist auf dem weißen Hintergrund der Texteditoren in der Citrix-Remotesitzung nicht sichtbar
Summary: Dieser Artikel enthält Schritte zum Beheben der Tatsache, dass der Mauszeiger nicht sichtbar ist, wenn er über ein Texteditorfenster (z. B. Notepad, Outlook, Word oder Windows 10-Suchleiste) bewegt wird, während eine Citrix-Remotesitzung besteht. ...
Symptoms
Betroffene Produkte:
- Citrix Workspace-App für Linux
Betroffene Betriebssysteme:
- Dell ThinOS
Wenn Sie in einer Citrix-Remotesitzung mit dem Mauszeiger über Texteditorfenster wie die Windows-Suchleiste oder den Editor fahren, ist die Maus weiß auf einem weißen Hintergrund, wodurch sie unsichtbar ist.
Cause
Citrix VDA 2203 CU2 und höher verwendet den Citrix Indirect Display (IDD)-Displayadapter anstelle des Citrix Display Only (DOD), der in den vorherigen Versionen verwendet wurde. Dies kann bestätigt werden, indem Sie den Befehl dxdiag utility auf dem VDA und überprüfen Sie die Registerkarte Anzeige:

Der Cursor der Citrix Workspace-App für Linux (CWA) weist in diesem Szenario eine Einschränkung auf und kann die Farbe auf einem weißen Hintergrund nicht umkehren.
Resolution
Dieses Problem wurde in Linux CWA 2308 behoben.
Als Problemumgehung ist es möglich, den VDA zur Verwendung des Citrix Display Only-Adapters zu zwingen, indem Sie den folgenden Registrierungsschlüssel hinzufügen:
- Sichern Sie die Registrierung, bevor Sie fortfahren. Weitere Informationen finden Sie unter Sichern und Wiederherstellen der Registrierung in Windows
.
- Das Bearbeiten der Registrierung kann dazu führen, dass der Computer beim nächsten Neustart nicht mehr reagiert.
- Wenden Sie sich an den technischen Support von Dell, wenn Sie Unterstützung bei diesem Schritt benötigen.
- Öffnen Sie den Windows-Registrierungs-Editor auf dem VDA, indem Sie regedit in das Fenster Ausführen eingeben und OK auswählen.
- Geben Sie regedit ein.

- Fügen Sie den folgenden Registrierungsschlüssel hinzu:
Path: HKLM\Software\Citrix\Graphics Key: AdapterMerits [DWORD]: CitrixDoD [value]: 3

- Starten Sie den VDA neu.
Hinweis: Beachten Sie, dass bei nicht persistenten Citrix-Katalogen die Änderungen dem Basis-Image hinzugefügt und veröffentlicht werden müssen.