ECS:Dial Home - EKMServerConnectionStatus - 症狀代碼:1369 和 1370

Summary: 這是用來偵測 EKMServerConnectionStatus 警示的 Dial Home。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

ECS 已撥打 home,並顯示下列警示:
症狀代碼 重要性
1369
1370 ERROR
<?xml version="1.0" encoding="UTF-8"?>
<ConnectHome SchemaVersion="1.0.8"
    xsi:schemaLocation="/opt/connectemc/schema/ema_ConnectHome108.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <TransType>10</TransType>
    <TransTypeDesc>EventXML</TransTypeDesc>
    <TransID>0</TransID>
    <Node Status="Unknown" State="Unknown" ID="ECSQE00079">
        <Identifier>
            <DeviceState>1</DeviceState>
            <DeviceStatus>1</DeviceStatus>
            <ClarifyID>ECSQE00079</ClarifyID>
            <SiteName>UNKNOWN</SiteName>
            <Vendor>EMC</Vendor>
            <DeviceType>ElasticCloudStorageApp</DeviceType>
            <Model>ElasticCloudStorage</Model>
            <SerialNumber>ECSQE00079</SerialNumber>
            <WWN>ECSQE00079</WWN>
            <Platform>platform</Platform>
            <OS>SLES</OS>
            <OS_VER>12.3</OS_VER>
            <UcodeVer>3.3.0.0-4349.d0de882</UcodeVer>
            <EmbedLevel>2</EmbedLevel>
            <InternalMaxSize>512800</InternalMaxSize>
            <Comment>Object Alert</Comment>
        </Identifier>
        <Connection>
            <ConnectType>ESRS</ConnectType>
            <IPName>xxxxx-yyyyyy.ecs.lab.fqdn.com</IPName>
            <ConnectNum>xx.xxx.xxx.xx</ConnectNum>
            <Port>22</Port>
        </Connection>
        <HeartBeat>
            <HBStatus></HBStatus>
            <HBState></HBState>
        </HeartBeat>
        <InternalData>
            <FileList/>
            <EventList>
                <Event>
                    <SymptomCode>1370</SymptomCode>
                    <Category>Configuration</Category>
                    <Severity>Error</Severity>
                    <Status>Unknown</Status>
                    <Component>Object</Component>
                    <ComponentID></ComponentID>
                    <SubComponent>EKM Server Connection Status</SubComponent>
                    <SubComponentID></SubComponentID>
                    <CallHome>true</CallHome>
                    <FirstTime>2022-01-29T07:32:09.718Z</FirstTime>
                    <LastTime>2022-01-29T07:32:09.718Z</LastTime>
                    <Count>0</Count>
                    <EventData><![CDATA[]]></EventData>
                    <Description><![CDATA[The EKM Server: ecs-test-keysecure-xx.xxx.xxx.xxx is not responding. Please ensure that the server is connected.  [Ref_ID : EKMServerConnectionStatus]]]></Description>
                </Event>
            </EventList>
        </InternalData>
        <ExternalFiles/>
    </Node>
</ConnectHome>

Cause

可延伸金鑰管理 (EKM) 伺服器沒有回應。確定伺服器已經連線。

Resolution

確認狀態

命令: 
svc_rest_cmd -i `hostname -i` /vdc/sensor/status/EKMServerConnectionStatus
範例:
# svc_rest_cmd -i `hostname -i` /vdc/sensor/status/EKMServerConnectionStatus
svc_rest_cmd 1.0.10

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<SensorStatusList>
  <SensorId>KMServerConnectionStatus</SensorId>
  <ListSensorStatus>
    <SensorStatusRestRep>
      <ContextId>EKMServerConnectionStatus</ContextId>
      <CurrentState>OK</CurrentState>
      <NodeId>1f4368c3-37cd-467f-9efc-289264806ea0</NodeId>
      <PreviousState>OK</PreviousState>
      <Time>1551118064264</Time>
    </SensorStatusRestRep>
  </ListSensorStatus>
如上所述尋找目前狀態,如果設為「確定」,則可以忽略錯誤。如果狀態不正常 (警告或錯誤),請繼續執行下列故障診斷步驟。

故障診斷

找到收到的警示訊息中指出的伺服器,並嘗試 ping 它:
Description><![CDATA[The EKM Server: ecs-dev-keysecure-xx.xxx.xx.xxx is not responding. Please ensure that the server is connected. [Ref_ID : EKMServerConnectionStatus]]]></Description>
檢查resourcesvc.log是否有關於問題訊息 EKM 伺服器:
命令:
grep /opt/emc/caspian/fabric/agent/services/object/main/log/<EKM Server Name> resourcesvc.log
範例:
The command will return output in the following format:
There was some error verifying connection to EKMServer {will have failed server name} in cluster. {will have failure detail}
這些錯誤表示環境中可能存在網路問題。ECS 與 EKM 伺服器之間的通信可能被阻止,或者 EKM 伺服器本身可能無法使用。查驗 ECS 可以 ping EKM 伺服器,並建議使用者驗證 EKM 伺服器是否正常運作。

如果無法解決問題,請向 ECS 支援開立服務要求,以協助處理以上收集的資訊。

Affected Products

ECS, ECS Appliance, ECS Software, Elastic Cloud Storage
Article Properties
Article Number: 000038620
Article Type: Solution
Last Modified: 17 Dec 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.