Avamar : Impossible d’enregistrer le cluster Windows en raison du réseau de « sauvegarde »

Summary: L’enregistrement du client de cluster à l’aide de l’outil de configuration de cluster Avamar peut échouer dans les environnements où plusieurs cartes réseau existent, et seul le réseau de sauvegarde peut acheminer le trafic vers la grille Avamar. Cet article de la base de connaissances fournit des solutions de contournement pour résoudre le problème. ...

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Symptoms

Lorsque vous tentez d’enregistrer un client de cluster Windows à l’aide de l’outil de configuration de cluster Avamar dans la grille Avamar, le message d’erreur suivant peut s’afficher : 

"Error: Could not find cid.bin in var folder path (Example: O:\Avamar_logs\var\cid.bin). Please check avagent.log file to see if there are problems with client registration!  Tip: This error can occur if provided details for Avamar server are incorrect."

Les erreurs suivantes dans le avagent.log fichier : 

avagent Error <5365>: Cannot connect to 10.x.xxx.xxx:28001.
avagent Error <6210>: Unable to register '/DELL\Cluster_client' with MCS at xxxxx.xxxx.lab.emc.com:28001
avagent Error <7500>: Registration error: NULL message received
Les clients de cluster fédérés (DAG Exchange, Hyper-V CSV) peuvent également ne pas s’afficher dans la console Avamar, même si l’Assistant Cluster s’est terminé avec succès.

Cause

L’enregistrement du client de cluster peut échouer dans les cas suivants :

  • Les nœuds de cluster disposent de plusieurs cartes réseau.
  • Seule la carte NIC désignée comme réseau de sauvegarde peut acheminer le trafic vers la grille Avamar.
  • Par défaut, l’agent de cluster se lie à l’adresse IP de production, qui peut ne pas disposer d’une passerelle ou d’une connectivité par défaut à la grille Avamar.

Resolution

Configurez l’agent de sauvegarde pour <<le service Nom>> du cluster afin qu’il se lie à l’adresse IP pouvant communiquer avec la grille Avamar.

  1. Ouvrez l’outil de gestion du cluster de basculement à partir du système d’exploitation Windows.
  2. Accédez à Nom du cluster ->Service et applications. 
  3. Recherchez Backup Agent Service pour <<Cluster Name>>, cliquez avec le bouton droit de la souris et sélectionnez Properties.
  4. Accédez à l’onglet Général , puis copiez le contenu existant du champ Paramètres de démarrage dans le Bloc-notes.
  5. Apportez les modifications suivantes aux paramètres de démarrage
    1. Edit --netbind=<<IP address of Backup network>>, that is --netbind=10.xx.xx.x
      Remove the --disablegui=true flag
  6. Enregistrez la modification.
    1. Mettez la ressource Backup Agent hors ligne.
    2. Mettez en ligne la ressource Backup Agent.
Pour les clients de cluster, vérifiez que la carte réseau liée à l’adresse IP désignée dispose d’une passerelle par défaut ou qu’elle peut accéder à la grille Avamar. Si ce n’est pas le cas, choisissez une autre adresse IP disponible qui peut être liée à une interface de carte réseau existante ayant accès à la grille Avamar.

Test de connectivité :
Utiliser ping avec l’adresse IP source :

ping -S <source IP address> <Avamar grid IP>

Exemple :

ping -S 10.x.x.x 192.xxx.x.x

Si vous voyez :

PING: transmit failed. General failure.

L’adresse IP sélectionnée ne parvient pas à accéder à la grille. Ajustez la configuration réseau ou choisissez une autre adresse IP.

Additional Information

  • S’applique aux clusters Windows et aux clients de cluster fédérés (Exchange, DAG, Hyper-V, CSV)
  • Si l’enregistrement échoue toujours, passez en revue le routage réseau et les règles de pare-feu
  • Dans la mise en réseau TCP/IP, une passerelle par défaut est requise pour acheminer les paquets IP vers un sous-réseau IP qui ne figure pas dans sa table de routage

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000039560
Article Type: Solution
Last Modified: 05 Dec 2025
Version:  6
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