Dell Unity. Сервер CAVA переходил в автономный режим и периодически восстанавливался

Summary: Сервер CAVA переходил в автономный режим и периодически восстанавливался: «Сервер антивирусной проверки xx.xx.xx.xx обнаружил ошибку и больше не работает. (Ошибка: ERROR_AUTH 64)" :: Категория=Пользовательский компонент=DART_VC «Сервер антивирусной проверки xx.xx.xx.xx находится в режиме онлайн». :: Категория=Пользовательский компонент=DART_VC. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Проблема возникла в Unity code 4.4.0.1536311042 и Windows Server 2016.

Описание проблемы

  1. При настройке CAVA заказчиком периодически возникала ошибка, из-за которой сервер CAVA переходил в автономный режим и возвращался в режим онлайн через несколько секунд.
    В EMCSystemLogFile.log отображаются следующие журналы ошибок:

    "2018-12-28T02:18:22.331Z" "n1988006_spa" "Kittyhawk_safe" "26056" "unix/spa/root" "ERROR" "13:10510021" :: "The virus checker server xx.xx.xx.xx has encountered an error and is no longer operational.(Error: ERROR_AUTH 64)" :: Category=User Component=DART_VC
    "2018-12-28T02:18:41.486Z" "n1988006_spa" "Kittyhawk_safe" "26056" "unix/spa/root" "NOTICE" "13:1051001d" :: "Virus checker server xx.xx.xx.xx is online." :: Category=User Component=DART_VC
    "2018-12-28T02:35:42.361Z" "n1988006_spa" "Kittyhawk_safe" "26056" "unix/spa/root" "ERROR" "13:10510021" :: "The virus checker server xx.xx.xx.xx has encountered an error and is no longer operational.(Error: ERROR_AUTH 64)" :: Category=User Component=DART_VC
    "2018-12-28T02:35:51.678Z" "n1988006_spa" "Kittyhawk_safe" "26056" "unix/spa/root" "NOTICE" "13:1051001d" :: "Virus checker server xx.xx.xx.xx is online." :: Category=User

    Те же сообщения об ошибках также были зарегистрированы в c4_safe_ktrace.log например:

    2018/12/28-21:32:25.865594 115K     7F86FEB3E709     sade:VC: 3:33:[Rick]  The virus checker server 160.46.85.196 has encountered an error and is no longer operational.(Error: ERROR_AUT
    2018/12/28-21:32:25.865596    0     7F86FEB3E709     sade:VC: 3:33:[Rick]  H 64)
    2018/12/28-21:32:25.865617   19     7F8790D83702     sade:SOCK_STREAM: 3:[core]  T_DISCON_REQ: (fd=0x1a0, NS=0) ShutdownStream() request UNSUPPORTED!
    2018/12/28-21:32:25.865622    4     7F8790D83702     sade:SOCK_STREAM: 3:[core]  T_DISCON_REQ: (fd=0x1a0, NS=0)  Handling as DisconnectCloseStream()!
    --
    2018/12/28-21:32:53.272520    0     7FC1D8ADC70A      std:PSMSYS:PSMSYS:psmDataAreaClose(1:13): PENDED...
    2018/12/28-21:32:55.127022 1.8M     7F86FEB3E702     sade:VC: 5:29:[Rick]  Virus checker server 160.46.85.196 is online.
    2018/12/28-21:32:55.128201 1177     7F8790DC7704     sade:SOCK_STREAM: 3:[core]  T_DISCON_REQ: (fd=0x1cb, NS=0) ShutdownStream() request UNSUPPORTED!
    2018/12/28-21:32:55.128206    3     7F8790DC7704     sade:SOCK_STREAM: 3:[core]  T_DISCON_REQ: (fd=0x1cb, NS=0)  Handling as DisconnectCloseStream()!
  2. Ошибка произошла случайным образом без какой-либо определенной закономерности. По-видимому, сервис CAVA не затронут.

  3. Мы выполнили дальнейшие действия по сбору KB#462457, но мы не обнаружили разницы во времени между сервером CAVA/Unity/сервером Windows DC.

  4. Трассировка сети показывает, что сервер CAVA отправил FSCTL_VALIDATE_NEGOTIATE_INFO запрос Ioctl, но Unity не ответил и разорвал TCP-соединение.
    Когда возникла проблема, сервер CAVA отправил запрос FSCTL_VALIDATE_NEGOTIATE_INFO Ioctl, но Unity не ответил и разорвал подключение.

    # Хороший пример

    5817    0.433916    CAVA_IP    CIFS_IP    SMB2    156    Tree Connect Request Tree: \\rick\CHECK$
    5820    0.433983    CIFS_IP     CAVA_IP    SMB2    138    Tree Connect Response
    5823    0.434164    CAVA_IP    CIFS_IP    SMB2    212    Ioctl Request FSCTL_VALIDATE_NEGOTIATE_INFO
    5826    0.434217    CIFS_IP     CAVA_IP    SMB2    194    Ioctl Response FSCTL_VALIDATE_NEGOTIATE_INFO  <=========== good case

    # Пример плохого случая

    1806    0.096779    CAVA_IP    CIFS_IP    SMB2    156    Tree Connect Request Tree: \\rick\CHECK$
    1807    0.096854    CIFS_IP     CAVA_IP    SMB2    138    Tree Connect Response
    1818    0.097124    CAVA_IP    CIFS_IP    SMB2    212    Ioctl Request FSCTL_VALIDATE_NEGOTIATE_INFO
    1820    0.097200    CIFS_IP     CAVA_IP    TCP    54    445   52006 [FIN, ACK] Seq=85 Ack=261 Win=304 Len=0   <=========== bad case
  5. Эта проблема может повлиять на копирование данных CIFS, как при использовании emcopy для попытки переноса данных из VNX в Unity.
    Они выполняют несколько копий одновременно, и время от времени разные копии каждый раз выходят из строя с ошибкой.

    Client OS : Microsoft (build 9200)
    TH000 : 02:28:08 : ERROR (53) : unable get server info from \\cifsserver.exmaple.net

 

Cause

Это проблема, так как Unity должна проверять информацию при первоначальном подключении, а не при привязанном соединении. И это действительно вызывает проблемы у клиентов.

 

Resolution

Эта проблема возникает только в случае SMB версии 3.0.2, даже если они переключаются на 3.1 или 2.1, это работает. И даже в версии 3.0.2 у них есть обходной путь.

Временное решение. Отключение многоканальности на сервере Windows или сервере CAVA

Запустите PowerShell от имени администратора, а затем:

PS C:\windows\system32> Get-SmbClientConfiguration


ConnectionCountPerRssNetworkInterface : 4
DirectoryCacheEntriesMax              : 16
DirectoryCacheEntrySizeMax            : 65536
DirectoryCacheLifetime                : 10
DormantFileLimit                      : 1023
EnableBandwidthThrottling             : True
EnableByteRangeLockingOnReadOnlyFiles : True
EnableInsecureGuestLogons             : False
EnableLargeMtu                        : True
EnableLoadBalanceScaleOut             : True
EnableMultiChannel                    : True
EnableSecuritySignature               : True
ExtendedSessionTimeout                : 1000
FileInfoCacheEntriesMax               : 64
FileInfoCacheLifetime                 : 10
FileNotFoundCacheEntriesMax           : 128
FileNotFoundCacheLifetime             : 5
KeepConn                              : 600
MaxCmds                               : 50
MaximumConnectionCountPerServer       : 32
OplocksDisabled                       : False
RequireSecuritySignature              : False
SessionTimeout                        : 60
UseOpportunisticLocking               : True
WindowSizeThreshold                   : 8

PS C:\windows\system32> Set-SmbClientConfiguration -EnableMultiChannel $false

Confirm
Are you sure you want to perform this action?
Performing operation 'Modify' on Target 'SMB Client Configuration'.
[Y] Yes  [A] Yes to All  [N] No  [L] No to All  [S] Suspend  [?] Help (default is "Y"): yes
PS C:\windows\system32> Get-SmbClientConfiguration


ConnectionCountPerRssNetworkInterface : 4
DirectoryCacheEntriesMax              : 16
DirectoryCacheEntrySizeMax            : 65536
DirectoryCacheLifetime                : 10
DormantFileLimit                      : 1023
EnableBandwidthThrottling             : True
EnableByteRangeLockingOnReadOnlyFiles : True
EnableInsecureGuestLogons             : False
EnableLargeMtu                        : True
EnableLoadBalanceScaleOut             : True
EnableMultiChannel                    : False
EnableSecuritySignature               : True
ExtendedSessionTimeout                : 1000
FileInfoCacheEntriesMax               : 64
FileInfoCacheLifetime                 : 10
FileNotFoundCacheEntriesMax           : 128
FileNotFoundCacheLifetime             : 5
KeepConn                              : 600
MaxCmds                               : 50
MaximumConnectionCountPerServer       : 32
OplocksDisabled                       : False
RequireSecuritySignature              : False
SessionTimeout                        : 60
UseOpportunisticLocking               : True
WindowSizeThreshold                   : 8

 

Affected Products

Dell EMC Unity Family

Products

Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid
Article Properties
Article Number: 000050509
Article Type: Solution
Last Modified: 07 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.