[PowerScale] Узлы SED не загружаются с ошибками SED после модернизации до OneFS 9.5 с версии, более ранней, чем 9.2
Summary: Когда узлы SED модернизются непосредственно до OneFS 9.5 с версии OneFS выше 9.2, узлы не могут полностью загрузиться, а накопители отображаются в SED_ERROR состоянии.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Когда узлы SED модернизются непосредственно до OneFS 9.5 с версии OneFS выше 9.2, узлы не могут полностью загрузиться, а накопители отображаются в SED_ERROR состоянии. isi_sed показывает сбой аутентификации диска:
пример 1. /usr/bin/isi_hwtools/isi_sed da3
ОШИБКА: Ошибка диспетчера ключей: error=1=ISI_KM_INIT_FAILED
ПРЕДУПРЕЖДЕНИЕ: Не удается открыть подключение к диспетчеру ключей: Нет подключения к диспетчеру ключей
ОШИБКА: Ошибка диспетчера ключей: Ключ 5000C500CB360D98.current: error=34=SED_RESULT_NO_KM_CONNECTION
ПРЕДУПРЕЖДЕНИЕ: Попытка получить текущий ключ диска возвращается Нет подключения к диспетчеру ключей
ОШИБКА: Ошибка диспетчера ключей: Ключ 5000C500CB360D98.future: error=34=SED_RESULT_NO_KM_CONNECTION
ПРЕДУПРЕЖДЕНИЕ: Попытка получить будущий ключ диска возвращается Нет подключения к диспетчеру ключей
ОШИБКА: Ошибка диспетчера ключей: Ключ 5000C500CB360D98.change: error=34=SED_RESULT_NO_KM_CONNECTION
ПРЕДУПРЕЖДЕНИЕ: Попытка получения ключа изменения накопителя возвращается Нет подключения к диспетчеру ключей
Состояние накопителя: Отсек A0: WWN 5000c500cb360d98
Модель накопителя SEAGATE STMFSKF2CLAR4000, SN ZC0A00A0
Соответствие стандарту FIPS. FIPS 140-2 (0x32), уровень 2 (0x32), оборудование: STMFSKF2CLAR4000, микропрограмма: BV01, модуль: Модуль FiPS 140 с самошифруемыми дисками Seagate Secure TCG Enterprise SSC
Накопитель с ключом MSID
Exists Works Works Status (Состояние состояния «Exists Works»)
======= ======= ======= =============== ===============
Ошибка «Unknown No AUTH_FAILED AUTH_FAILED
Принадлежит другому узлу
Примечание: Будущий ключ существует: Ошибка, работает: Неизвестный
Примечание: Существует ключ изменения: Ошибка, работает: Неизвестный
Отсек A0: Dev da3, SEAGATE STMFSKF2CLAR4000, SN ZC1E03Y3, WWN 5000c500cb360d98: drive_display:
Success в isi_km_d.log отображаются ошибки sqlite:
023-05-05T12:22:20.188716-05:00 example-7(id7) isi_km_d[36798]: [0x803309000]key_mgr: [SEDS] сбой initprovider с ошибкой sqlite: Ошибка Sqlite: Ошибка логики SQL (1) — «Failed to prepare statement: «SELECT version, passphrase_mode, kmip_uid, kmip_index, kmip_host, kmip_port, kmip_meta, kmip_cacert, kmip_clientcert FROM seds_config WHERE id = ?».
Cause
Изменения для поддержки функции km Rekey в OneFS 9.5.0 предполагают наличие таблицы базы данных хранилища ключей, которая была добавлена в версии 9.2.0. Если кластер модернизирован с версии, более ранней, чем OneFS 9.2, непосредственно до OneFS 9.5, диспетчер ключей не может правильно считывать базу данных хранилища ключей, так как указанная таблица отсутствует.
Resolution
Чтобы предотвратить эту проблему, заказчикам, которые выполняют модернизацию до Версии OneFS 9.5 до более ранней версии, чем 9.2, необходимо сначала выполнить модернизацию до промежуточной версии OneFS 9.2 или 9.4. После завершения этой модернизации кластер можно безопасно обновить до OneFS 9.5.
Если проблема уже возникла и кластер находится в состоянии, описанном в разделе «Признаки», необходимо немедленно обратиться в службу поддержки и обратиться в эту статью.
Если проблема уже возникла и кластер находится в состоянии, описанном в разделе «Признаки», необходимо немедленно обратиться в службу поддержки и обратиться в эту статью.
Affected Products
Isilon A200, Isilon A2000, Isilon F800, Isilon F810, Isilon H400, Isilon H500, Isilon H5600, Isilon H600, Isilon HD400, Isilon NL410, Isilon S210, Isilon X210, Isilon X410, PowerScale Archive A300, PowerScale Archive A3000, PowerScale F200
, PowerScale F600, PowerScale F900, PowerScale Hybrid H700, PowerScale Hybrid H7000
...
Article Properties
Article Number: 000213188
Article Type: Solution
Last Modified: 22 Jun 2023
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.