Avamar: File System and Windows VSS Backups Fail with "INTERNAL ERROR" | Folder Redirection

Summary: Windows File System and VSS backups may fail in Avamar with internal errors when folder redirection is configured on the client system. This article outlines the symptoms, cause, and a recommended workaround. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Backups targeting the C:\Users or C:\Documents and Settings directories fail with errors similar to the following:

avtar Warning <6772>: Unable to set uevent object - 'code 6: The handle is invalid'
avtar Warning <6777>: Cannot translate path '' to full path, proceeding with original path
INTERNAL ERROR: <0001> assert error (mtPath.numelems() > 0), upath_win.cpp line 704
avtar Error <5137>: Unable to open "" for backup (code 0: success)
avtar FATAL <0000>: Backup not sealed due to previous errors
avtar FATAL <5155>: Backup aborted due to earlier errors. No backup created on the server.

If debugging is enabled (using the dataset or avtar.cmd in C:\Program Files\avs\var), additional messages may appear: 

2022/03/16-15:57:08.82100 [avtar] upath_win::translate_path translating 'C:\Users\ADM-DELLEMC\.AppData\.Data\.Data'
2022/03/16-15:57:08.82100 [avtar] GetReparsePointInfo(C:\Users\ADM-DELLEMC\.AppData\.Data\.Data) called
2022/03/16-15:57:08.82100 [avtar] upath_win::DoTransPathPrepWork detected reparse-point, using lookup path: \\Avamar.com\documents$
2022/03/16-15:57:08.82100 [avtar] upath_win::translate_path looking for translation for '\\test.Avamar.com\documents$\'
2022/03/16-15:57:08.82100 [avtar] upath_win::translate_path WARN mtpath lookup failed (\\test.Avamar.com\documents$)

Cause

The affected folders are configured with folder redirection, which causes Avamar to encounter reparse points that it cannot resolve during backup operations. 

Example:

Example of folder redirection in windows 
 

Resolution

To work around this issue:

  1. Log in to the redirected target system using either:

    • A Domain Admin account, or
    • A user account whose profile is affected by folder redirection.
  2. Investigate folder redirection settings:

    • Review Group Policy Objects (GPOs) or local policies that apply folder redirection.
    • Check the security permissions on the redirected folders to ensure that the backup agent has access.
  3. Adjust backup dataset (if applicable):

    • Exclude redirected folders from the backup dataset if they are not required.
    • Alternatively, configure the dataset to explicitly include the redirected path.

Affected Products

Avamar Client for Windows, Avamar Server
Article Properties
Article Number: 000198896
Article Type: Solution
Last Modified: 29 Oct 2025
Version:  3
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