NetWorker: Se genera el siguiente error: "Un intento de conexión falló porque la parte conectada no respondió correctamente después de un período"

Summary: La adición de un nuevo cliente o el respaldo de un cliente existente falla con el mensaje "Un intento de conexión falló porque la parte conectada no respondió correctamente después de un período". Este error es reproducible durante cualquier problema de conexión entre los procesos de NetWorker en dos hosts separados. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Cuando se intenta agregar nuevos clientes a NetWorker, se produce el siguiente error:
kA2f1000000X4t9CAC_3_0
Error al conectarse al host-client-name: Error del sistema remoto: un intento de conexión falló porque la parte conectada no respondió correctamente después de un período, o la conexión establecida falló porque el host conectado no respondió.
 
NOTA: Este error no se limita a la creación del cliente, también puede aparecer como una falla de respaldo, en cuyo caso aún se aplican los siguientes procedimientos de resolución.

Cause

Este problema aparece cuando el servicio nsrd del servidor de NetWorker no se puede comunicar con el servicio nsrexecd de los clientes de NetWorker

Resolution

1) Asegúrese de que los servicios de NetWorker se estén ejecutando en el cliente de NetWorker:
Windows: tasklist | findstr nsr
Linux: ps -ef | grep nsr

NOTA: El servicio de cliente de NetWorker es <b>nsrexecd</b> (NetWorker Remote Exec Service).

Si no se está ejecutando, intente iniciar el proceso:
Windows: net start nsrexecd
Linux: /etc/init.d/networker start 

2) Asegúrese de que el servidor y el cliente de NetWorker puedan comunicarse y resolver los nombres de host/IP de los demás. Utilice los comandos ping y nslookup en el cliente y el servidor de NetWorker.
 
NOTA: Confirme que el nombre de dominio calificado (FQDN), el nombre corto y la IP se devuelven correctamente con nslookup. Si una respuesta falla, se deben crear entradas de archivo de host para el host que no se pudo resolver mediante DNS. Cualquier problema de resolución de red/nombre debe ser resuelto por el administrador de dominio/red.

3) Confirme que los puertos de conexión/servicio de NetWorker no estén bloqueados por el sistema operativo o los firewalls de la red.
Puertos de servicio: 7937-9936
Puertos de conexión: 0-0

Consulte la Guía de configuración de seguridad de NetWorker para conocer su versión de NetWorker a fin de obtener más información sobre los ajustes de firewall y puertos. Estos documentos se pueden encontrar en https://www.dell.com/support/home/product-support/product/networker/docs

4) Confirme si el servidor puede ver los puertos del cliente mediante nsrrpcinfo:
nsrrpcinfo -p nombre-cliente

Ejemplo:
[root@lnx-nwserv]:~# nsrrpcinfo -p lnx-client01.amer.lan
PROGRAM VERSION PROTOCOL PORT SERVICE
100000  2       tcp      7938 nsrportmapper  Port Mapper
100000  2       udp      7938 nsrportmapper  Port Mapper
390436  1       tcp      8070 nsrexecd       GSS Authentication
390435  1       tcp      9049 nsrexecd       Resource Mirror
390113  1       tcp      7937 nsrexecd       Remote Execution
390440  1       tcp      9426 nsrexecd_nsrfa Remote File Access

Este comando se puede ejecutar en el cliente de NetWorker de vuelta a NetWorker Server si se instaló el paquete "Extended NetWorker Client" en el host del cliente:

Linux: rpm -qa | grep lgtoxtd
Windows:

image.png

Si el paquete del cliente extendido no está instalado, el cliente no tendrá instalado el comando nsrrpcinfo .


Una vez que se haya confirmado lo anterior, debería poder conectarse de manera remota al cliente de NetWorker desde NetWorker Server (y viceversa) mediante la ejecución del siguiente comando:
nsradmin -p nsrexec -s nombre-cliente
Este comando abre una conexión remota al servicio nsrexecd en el otro host (cliente/servidor)
[root@lnx-nwserv]:~# nsradmin -p nsrexec -s lnx-client01.amer.lan
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> q
[root@lnx-nwserv]:~# nsradmin -p nsrexec -s win-client01.amer.lan
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> q
[root@lnx-nwserv]:~#
 
NOTA: Si aparece el símbolo del sistema nsradmin , la conexión se ha realizado. Ingrese quit (o q)  para salir del indicador.
 

Additional Information

Es posible que también se deba borrar la información de pares entre NetWorker Server y client:
NetWorker: Cómo borrar automáticamente las discrepancias de información de par NSR mediante nsradmin -C

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000052219
Article Type: Solution
Last Modified: 17 Mar 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.