NetWorker: Näyttöön tulee seuraava virheilmoitus: "Yhteysyritys epäonnistui, koska liitetty osapuoli ei vastannut oikein tietyn ajan kuluttua"
Summary: Uuden työaseman lisääminen tai aiemmin luodun asiakasohjelman varmuuskopiointi epäonnistuu sanomalla "Yhteysyritys epäonnistui, koska liitetty osapuoli ei vastannut oikein tietyn ajan kuluttua". Tämä virhe toistuu, kun NetWorker-prosessien välillä on yhteysongelmia kahdessa erillisessä isännässä. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Kun NetWorkeriin yritetään lisätä uusia asiakkaita, ilmenee seuraava virhe:
Yhteyden muodostaminen isäntäasiakkaan nimeen epäonnistui: Etäjärjestelmävirhe - Yhteysyritys epäonnistui, koska yhdistetty osapuoli ei vastannut oikein tietyn ajan kuluttua tai yhteyden muodostaminen epäonnistui, koska yhdistetty isäntä ei ole vastannut.
HUOMAUTUS: Tämä virhe ei rajoitu asiakkaan luontiin, vaan se voi ilmetä myös varmuuskopiointivirheenä, jolloin seuraavat ratkaisumenettelyt ovat edelleen voimassa.
Cause
Ongelma ilmenee, kun NetWorker-palvelimen nsrd-palvelu ei saa yhteyttä NetWorker-asiakkaiden nsrexecd-palveluun
Resolution
1) Varmista, että NetWorker-palvelut ovat käynnissä NetWorker-asiakasohjelmassa:
HUOMAUTUS: NetWorker-asiakaspalvelu on <b>nsrexecd</b> (NetWorker Remote Exec Service).
Jos se ei ole käynnissä, yritä käynnistää prosessi:
2) Varmistaa, että NetWorker-palvelin ja asiakas voivat kommunikoida ja selvittää toistensa isäntänimet/IP-osoitteet käyttämällä ping- ja nslookup-komentoja NetWorker-palvelimessa ja -asiakkaassa.
3) Varmista, että käyttöjärjestelmän tai verkon palomuurit eivät estä NetWorkerin palvelu-/yhteysportteja.
4) Varmista, että palvelin näkee asiakasportit nsrrpcinfo-komennolla:
Kun edellä mainittu on vahvistettu, sinun pitäisi pystyä muodostamaan etäyhteys NetWorker-asiakasohjelmaan NetWorker-palvelimesta (ja päinvastoin) suorittamalla seuraava komento:
Windows: tehtäväluettelo | findstr nsr
Linux: ps -ef | grep nsr
Linux: ps -ef | grep nsr
HUOMAUTUS: NetWorker-asiakaspalvelu on <b>nsrexecd</b> (NetWorker Remote Exec Service).
Jos se ei ole käynnissä, yritä käynnistää prosessi:
Windows: net start nsrexecd
Linux: /etc/init.d/networker start
Linux: /etc/init.d/networker start
2) Varmistaa, että NetWorker-palvelin ja asiakas voivat kommunikoida ja selvittää toistensa isäntänimet/IP-osoitteet käyttämällä ping- ja nslookup-komentoja NetWorker-palvelimessa ja -asiakkaassa.
HUOMAUTUS: Varmista nslookupin avulla, että täydellinen toimialuenimi (FQDN), lyhyt nimi ja IP-osoite palautetaan oikein. Jos vastaus epäonnistuu, isäntätiedostomerkinnät on luotava isännälle, jonka ongelma epäonnistui DNS:n avulla. Kaikki verkon/nimen selvitysongelmat on ratkaistava toimialueen/verkon järjestelmänvalvojan toimesta.
3) Varmista, että käyttöjärjestelmän tai verkon palomuurit eivät estä NetWorkerin palvelu-/yhteysportteja.
Palveluportit: 7937-9936
Liitäntäportit: 0-0
Katso lisätietoja palomuurista ja porttiasetuksista NetWorker-versiosi NetWorker Security Configuration Guide -oppaasta. Nämä asiakirjat löytyvät osoitteesta https://www.dell.com/support/home/product-support/product/networker/docs
Katso lisätietoja palomuurista ja porttiasetuksista NetWorker-versiosi NetWorker Security Configuration Guide -oppaasta. Nämä asiakirjat löytyvät osoitteesta https://www.dell.com/support/home/product-support/product/networker/docs
4) Varmista, että palvelin näkee asiakasportit nsrrpcinfo-komennolla:
nsrrpcinfo -p asiakasnimi
Esimerkki:
Esimerkki:
[root@lnx-nwserv]:~# nsrrpcinfo -p lnx-client01.amer.lan
PROGRAM VERSION PROTOCOL PORT SERVICE
100000 2 tcp 7938 nsrportmapper Port Mapper
100000 2 udp 7938 nsrportmapper Port Mapper
390436 1 tcp 8070 nsrexecd GSS Authentication
390435 1 tcp 9049 nsrexecd Resource Mirror
390113 1 tcp 7937 nsrexecd Remote Execution
390440 1 tcp 9426 nsrexecd_nsrfa Remote File Access
Tämän komennon voi suorittaa NetWorker-asiakasohjelmassa takaisin NetWorker-palvelimeen, jos asiakkaan isäntään on asennettu Extended NetWorker client -paketti:
Linux: rpm -qa | grep lgtoxtd
Windows:

Jos laajennettua työasemapakettia ei ole asennettu, asiakkaaseen ei ole asennettu nsrrpinfo-komentoa .
Kun edellä mainittu on vahvistettu, sinun pitäisi pystyä muodostamaan etäyhteys NetWorker-asiakasohjelmaan NetWorker-palvelimesta (ja päinvastoin) suorittamalla seuraava komento:
nsradmin -p nsrexec -s client-name
Tämä komento avaa etäyhteyden nsrexecd-palveluun toisessa (asiakas/palvelin) isännässä
Tämä komento avaa etäyhteyden nsrexecd-palveluun toisessa (asiakas/palvelin) isännässä
[root@lnx-nwserv]:~# nsradmin -p nsrexec -s lnx-client01.amer.lan
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> q
[root@lnx-nwserv]:~# nsradmin -p nsrexec -s win-client01.amer.lan
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> q
[root@lnx-nwserv]:~#
HUOMAUTUS: Jos nsradmin-kehote tulee näkyviin, yhteys on muodostettu. Sulje kehote kirjoittamalla lopeta (tai q).
Additional Information
Myös vertaistiedot on ehkä tyhjennettävä NetWorker-palvelimen ja client:
NetWorkerin välillä: NSR-vertaistietojen ristiriitojen korjaaminen automaattisesti komennolla nsradmin -C
NetWorkerin välillä: NSR-vertaistietojen ristiriitojen korjaaminen automaattisesti komennolla nsradmin -C
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000052219
Article Type: Solution
Last Modified: 17 Mar 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.