NetWorker : L’erreur suivante s’affiche : « Une tentative de connexion a échoué car la partie connectée n’a pas répondu correctement après un certain temps »
Summary: L’ajout d’un nouveau client ou la sauvegarde d’un client existant échoue avec le message « Une tentative de connexion a échoué car la partie connectée n’a pas répondu correctement après un certain temps ». Cette erreur est reproductible lors de tout problème de connexion entre les processus NetWorker sur deux hôtes distincts. ...
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Symptoms
Lorsque vous tentez d’ajouter de nouveaux clients à NetWorker, l’erreur suivante se produit :
Échec de la connexion à l’hôte client-name : Erreur du système distant : une tentative de connexion a échoué car la partie connectée n’a pas répondu correctement après un certain temps, ou la connexion établie a échoué car l’hôte connecté n’a pas répondu.
Remarque : Cette erreur ne se limite pas à la création du client. Elle peut également apparaître comme un échec de sauvegarde, auquel cas les procédures de résolution suivantes s’appliquent toujours.
Cause
Ce problème se produit lorsque le service nsrd du NetWorker Server ne parvient pas à communiquer avec le service nsrexecd des clients NetWorker
Resolution
1) Assurez-vous que les services NetWorker sont en cours d’exécution sur le client NetWorker :
Remarque : Le service client NetWorker est <b>nsrexecd</b> (NetWorker Remote Exec Service).
S’il n’est pas en cours d’exécution, essayez de démarrer le processus :
2) Assurez-vous que le serveur et le client NetWorker peuvent communiquer et résoudre les noms d’hôte/adresses IP l’un de l’autre, utilisez les commandes ping et nslookup sur le serveur et le client NetWorker.
3) Vérifiez que les ports de service/connexion NetWorker ne sont pas bloqués par le système d’exploitation ou les pare-feu réseau.
4) Vérifiez si le serveur peut voir les ports client à l’aide de nsrrpcinfo :
Une fois les conditions ci-dessus confirmées, vous devriez être en mesure de vous connecter à distance au NetWorker Client à partir du serveur NetWorker (et inversement) en exécutant la commande suivante :
Windows : tasklist | findstr nsr
Linux : ps -ef | grep nsr
Linux : ps -ef | grep nsr
Remarque : Le service client NetWorker est <b>nsrexecd</b> (NetWorker Remote Exec Service).
S’il n’est pas en cours d’exécution, essayez de démarrer le processus :
Windows : net start nsrexecd
Linux : /etc/init.d/networker start
Linux : /etc/init.d/networker start
2) Assurez-vous que le serveur et le client NetWorker peuvent communiquer et résoudre les noms d’hôte/adresses IP l’un de l’autre, utilisez les commandes ping et nslookup sur le serveur et le client NetWorker.
Remarque : Vérifiez que le nom de domaine complet (FQDN), le nom abrégé et l’adresse IP sont tous renvoyés correctement avec nslookup. Si une réponse échoue, des entrées de fichier hôte doivent être créées pour l’hôte qui n’a pas pu être résolu à l’aide du DNS. Tout problème de résolution de réseau/nom doit être résolu par votre administrateur de domaine/réseau.
3) Vérifiez que les ports de service/connexion NetWorker ne sont pas bloqués par le système d’exploitation ou les pare-feu réseau.
Ports de service : 7937-9936
Ports de connexion : 0-0
Pour plus d’informations sur les paramètres de pare-feu et de port, reportez-vous au Guide de configuration de la sécurité de NetWorker correspondant à votre version de NetWorker. Ces documents sont disponibles à l’adresse https://www.dell.com/support/home/product-support/product/networker/docs
Pour plus d’informations sur les paramètres de pare-feu et de port, reportez-vous au Guide de configuration de la sécurité de NetWorker correspondant à votre version de NetWorker. Ces documents sont disponibles à l’adresse https://www.dell.com/support/home/product-support/product/networker/docs
4) Vérifiez si le serveur peut voir les ports client à l’aide de nsrrpcinfo :
nsrrpcinfo -p nom
_clientExemple:
_clientExemple:
[root@lnx-nwserv]:~# nsrrpcinfo -p lnx-client01.amer.lan
PROGRAM VERSION PROTOCOL PORT SERVICE
100000 2 tcp 7938 nsrportmapper Port Mapper
100000 2 udp 7938 nsrportmapper Port Mapper
390436 1 tcp 8070 nsrexecd GSS Authentication
390435 1 tcp 9049 nsrexecd Resource Mirror
390113 1 tcp 7937 nsrexecd Remote Execution
390440 1 tcp 9426 nsrexecd_nsrfa Remote File Access
Cette commande peut être exécutée sur le NetWorker Client sur le NetWorker Server si le package « Extended NetWorker Client » a été installé sur l’hôte client :
Linux : rpm -qa | grep lgtoxtd
Windows :

Si le package client étendu n’est pas installé, la commande nsrrpcinfo ne sera pas installée sur le client.
Une fois les conditions ci-dessus confirmées, vous devriez être en mesure de vous connecter à distance au NetWorker Client à partir du serveur NetWorker (et inversement) en exécutant la commande suivante :
nsradmin -p nsrexec -s client-name
Cette commande ouvre une connexion distante au service nsrexecd sur l’autre hôte (client/serveur)
Cette commande ouvre une connexion distante au service nsrexecd sur l’autre hôte (client/serveur)
[root@lnx-nwserv]:~# nsradmin -p nsrexec -s lnx-client01.amer.lan
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> q
[root@lnx-nwserv]:~# nsradmin -p nsrexec -s win-client01.amer.lan
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> q
[root@lnx-nwserv]:~#
Remarque : Si l’invite nsradmin s’affiche, cela signifie que la connexion a été établie. Saisissez quit (ou q) pour quitter l’invite.
Additional Information
Il peut également être nécessaire d’effacer les informations homologues entre le NetWorker Server et le client :
NetWorker : comment effacer automatiquement les ressources NSR peer information incohérentes en utilisant nsradmin -C
NetWorker : comment effacer automatiquement les ressources NSR peer information incohérentes en utilisant nsradmin -C
Affected Products
NetWorkerProducts
NetWorkerArticle Properties
Article Number: 000052219
Article Type: Solution
Last Modified: 17 Mar 2025
Version: 4
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