NVP vProxy: El proceso de restablecimiento del saveset de la VM no avanza

Summary: Un saveset de VM que reside en un dispositivo que no es DDboost (AFTD, cinta, CloudBoost) se está resucitando (clonando) a un dispositivo Data Domain para su restauración. El proceso de restablecimiento no está progresando y no se están clonando datos en el dispositivo dd de almacenamiento provisional. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Se inició una restauración de restablecimiento de máquina virtual (VM) desde NetWorker Management Console (NMC) o NetWorker Web User Interface (NWUI).

NOTA: Una restauración de restablecimiento es un proceso automático que se produce cuando el saveset seleccionado para la restauración reside en un dispositivo que no es Data Domain (AFTD, cinta, CloudBoost). Cuando se selecciona el saveset de origen, se proporciona una opción para seleccionar un pool de "almacenamiento provisional", donde se configura un dispositivo clon de Data Domain. El proceso de restablecimiento clona el saveset nuevamente en el pool de almacenamiento provisional de DD y, a continuación, inicia la restauración.

El proceso de restablecimiento se inició, pero no se observa ninguna transferencia de datos:

Sesión de recuperación

La ventana Alertas de NMC muestra "esperando un volumen con capacidad de escritura" en el pool de almacenamiento provisional seleccionado. 

Alertas de NMC

El pool de almacenamiento provisional tiene un dispositivo montado:

image.png

Cause

Ya hay una copia del mismo saveset presente en el volumen del dispositivo de almacenamiento provisional.

1. Confirme el SSID de la sesión de recuperación:

Sesión de recuperación

3. Utilice mminfo para confirmar si el saveset aparece en el dispositivo de almacenamiento provisional:
 

mminfo -kot -q ssid=SSID

Ejemplo:

nve:~ # mminfo -kot -q ssid=2891939064
 volume        type   vm_name         date     time         size ssid      fl backup_size
AFTDVMClone.001 adv_file lnx-client01  06/04/24 16:45:43  104 GB 2891939064 cr 104 GB
ddvestaging.001 Data Domain lnx-client01 06/04/24 16:45:43 104 GB 2891939064 cr 104 GB

Esto es por diseño. No puede crear varias copias del mismo saveset en la misma ubicación de destino. En la Guía de integración de VMware con NetWorker, se indica lo siguiente: Asegúrese de que el pool seleccionado no contenga copias para este respaldo. Si el origen primario está presente y selecciona un clon desde el cual recuperar utilizando el mismo pool de almacenamiento provisional que contiene la copia existente, es posible que la recuperación deje de responder.

Resolution

Compruebe la marca de saveset de la copia en el volumen de almacenamiento provisional:

nve:~ # mminfo -kot -q volume=ddvestaging.001
 volume        type   vm_name         date     time         size ssid      fl backup_size
ddvestaging.001 Data Domain lnx-client01 06/04/24 16:45:43 104 GB 2891939064 cr 104 GB

En algunos casos, es posible que el restablecimiento anterior se haya completado, pero una falla de nsrclone puede haber causado que el saveset se marque como abortado (ca) o sospechoso (s). Esto haría que la restauración fallara, el saveset no sería elegible para la restauración. Hay dos opciones en función de si la copia es válida.

Saveset válido en el dispositivo de almacenamiento provisional.

1. En la pestaña Recuperar , haga clic con el botón secundario en la sesión de recuperación y, a continuación, haga clic en Detener.
2. Vuelva a iniciar la recuperación y seleccione el saveset que se clonó nuevamente a DD. Debe mostrar una copia en las columnas "Data Domain Copies" y "Other Media Copies":

Savesets disponibles

3. Una vez que se encuentre en la página Select Alternate Recovery Sources, seleccione la copia desde el dispositivo de clonación de Data Domain:
Dispositivo clon Data Domain

4. Realice la restauración.

El saveset no es válido

Si el saveset no es válido; ya sea abortado (CA) o sospechoso (s). Debe eliminar el saveset y reiniciar la restablecimiento nuevamente.

1. Obtenga el SSID y el ID de clon del saveset que reside en el dispositivo de almacenamiento provisional.
mminfo -kot -q volume=VOLUME_NAME -r vmname,savetime,sumflags,ssid,cloneid
Ejemplo:
nve:~ # mminfo -kot -q volume=ddvestaging.001 -r vmname,savetime,sumflags,ssid,cloneid
 vm_name    date   fl ssid          clone id
lnx-client01 06/04/24 ca 2891939064 1718033764
 
2. Mediante el uso de ssid/cloneid. Elimine el saveset:
nsrmm -d -S SSID/CLONEID
Ejemplo:
nve:~ # nsrmm -d -S 2891939064/1718033764

The following clones will be deleted:
2891939064/1718033764

Continue? y
Processing the clone list.
Deleting clones.
ADVERTENCIA: Es importante especificar el SSID/CLONEID. Si especifica solo el SSID, puede eliminar todas las copias de ese saveset del MM, incluido el origen.

3. Reinicie la restauración de restablecimiento y seleccione el saveset con solo "Other Media Copy". Seleccione el pool de almacenamiento provisional y comience la restauración. El saveset se clonará en el pool de almacenamiento provisional y el proceso de restauración comenzará una vez que se complete la clonación.

Additional Information

Si observa un problema en el cual el clon no se completa o se completa, pero no parece ser válido. Elimine el saveset anulado (ca) o sospechoso (s) no válido como se detalló anteriormente. Clone manualmente el saveset mediante el comando nsrclone y revise la salida de nsrclone para obtener más información:
nsrclone -vvv [{optional} -D[1-7]] -b STAGING_POOL_NAME -S SSID/CLONEID

Donde SSID/CLONEID es el SSID y el CloneId del saveset que reside en el dispositivo que no es DD. La salida se puede redirigir a un archivo; opcionalmente, se puede agregar la depuración con los niveles -D del 1 al 7. 

Consulte: NVP vProxy: ¿Cómo clonar manualmente un saveset de VM desde un dispositivo que no es Data Domain a un dispositivo clon de Data Domain?

Es posible que se necesite un análisis del sfs-dump y del registro de ddfs.info de Data Domain de destino.

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000225923
Article Type: Solution
Last Modified: 22 May 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.