Avamar: Avagent-logfiler viser "CR_ERROR" under registrering eller under sikkerhedskopiering

Summary: Avagent-logfiler viser fejlen "CR_ERROR"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Scenarie 1 - Klientregistrering mislykkes:

avagent.log:

2018/02/20-07:42:30.26300 [agent_main]  agent_message::lowrecv() Unable to recv message size!

2018/02/20-07:42:30.26300 [agent_main]  agent_message::recvcapsule capsule: server_avail:1, ret.size=0
2018/02/20-07:42:30.26300 [agent_main]  agent_message::receive_message after recv
2018-02-20 13:12:30 avagent Error <5061>: No response to message
2018/02/20-07:42:30.26300 [agent_main]  agent_message::hangup closing socket
2018/02/20-07:42:30.26300 [agent_main]  agent_message::hangup closed connection
2018/02/20-07:42:30.26399 [agent_main]  agent_commands::check_mc_response received an bad status code 'CR_ERROR'
2018/02/20-07:42:30.26399 [agent_main]  agent_commands::check_mc_response ret=9. 
 

--Eller--

2019-01-28 12:52:53 avagent Info <6601>: Hostnamelist: client1.avamar.com,171.16.100.200,client1.avamar.com,127.0.0.1
2019-01-28 12:52:54 avagent Info <5472>: Registering with the MCS (10.18.100.200)
2019-01-28 12:52:54 avagent Error <5320>: Received from MCS#100003:client certificate verification failed 100.168.100.20.
2019-01-28 12:52:54 avagent Error <5061>: No response to message
2019-01-28 12:52:54 avagent Error <6210>: Unable to register '/clients\client1' with MCS at 10.18.100.200:30001
2019-01-28 12:52:54 avagent Error <6164>: Registration error: Client ID(CID) missing from response. (< msgver="1" />
2019-01-28 12:52:54 avagent Error <5036>: Unable to register CR_ERROR
 

Scenarie 2 - Registreringen fuldføres, men sikkerhedskopieringerne sidder fast i "Waiting client" eller "Timed-Out End" uden dataoverførsel:

avagent.log:

2017/06/14-15:17:43.99699 [agent_main]  agent_message::receive_message message sent, recv ack, timeout 300
2017/06/14-15:18:02.95099 [agent_main]  agent_message::lowrecv() Unable to recv message size!
2017/06/14-15:18:02.95099 [agent_main]  agent_message::recvcapsule capsule: server_avail:1, ret.size=0
2017/06/14-15:18:02.95099 [agent_main]  agent_message::receive_message after recv
2017-06-14 08:18:02 avagent Error <5061>: No response to message
2017/06/14-15:18:02.95099 [agent_main]  agent_message::hangup closing socket
2017/06/14-15:18:02.95099 [agent_main]  agent_message::hangup closed connection
2017-06-14 08:18:02 avagent Error <5038>: Error sending message CR_ERROR    
 

--Eller--

avagent Info <7502>: Registration of client /Data_Center1/SharePoint2013/prod_ext/client2.emc.local with MCS avamar-01emc.local:28001 successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3015 VSS successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3023 update successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3001 Windows successful.
2017-06-14 18:41:57 avagent Info <5619>: Registration of client and plugins complete.
2017-06-14 18:41:57 avagent Info <5964>: Requesting work from avamar-01.emc.local
2017-06-14 18:42:16 avagent Error <5061>: No response to message 2017-06-14 18:42:16 avagent Error <5038>: Error sending message CR_ERROR

Cause

Hvis ikonet avagent Log rapporter "No response to message" eller "CR_ERROR Under det første håndtryk er der et kommunikationsproblem, der blokerer send/ack meddelelser mellem Avamar-nettet og klienten.

Bemærk: Alle fejl i begge scenarier indikerer netværks- eller firewallrelaterede problemer i kundens miljø.

Resolution

Følgende trin kan bruges til at hjælpe med at finde flaskehalse:

1. Kontroller, at alle de nødvendige Avamar-porte er åbne i firewallen og kan sende og modtage data.
(Avamar-server til klient og klient til Avamar-server)

2. Kontroller, om der er nogen antivirus- eller malwaredetekteringssoftware, der blokerer dataene på Avamar-porte.

3. Hvis klienten står bag en NAT, skal du kontrollere, at rutetabellerne er konfigureret korrekt.

4. Hvis den samme fejl ses på alle klienter, skal du sørge for, at der ikke blev foretaget ændringer i Avamar-netværket.

5. Kontakt netværksteamet for at spore netværkstrafikken fra den fejlbehæftede klient til Avamar-nettet, og kontrollér, om der er pakkeudfald i netværket.

6. Hvis der ikke kan findes nogen problemer, skal du indsamle tcpdump og Wireshark eller Netmon oplysninger og oprette en serviceanmodning.

Additional Information

Wireshark Ressourcer:
 
TCPDump-ressourcer:
  •    https://linuxtechlab.com/learn-use-tcpdump-command-examples(Eksternt link)

Affected Products

Avamar, Avamar Client
Article Properties
Article Number: 000040936
Article Type: Solution
Last Modified: 24 Sept 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.