Avamar: Avagent günlükleri, kayıt sırasında veya yedekleme sırasında "CR_ERROR" gösteriyor

Summary: Avagent günlükleri "CR_ERROR" hatası gösteriyor

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Senaryo 1 - İstemci kaydı başarısız oluyor:

avagent.log:

2018/02/20-07:42:30.26300 [agent_main]  agent_message::lowrecv() Unable to recv message size!

2018/02/20-07:42:30.26300 [agent_main]  agent_message::recvcapsule capsule: server_avail:1, ret.size=0
2018/02/20-07:42:30.26300 [agent_main]  agent_message::receive_message after recv
2018-02-20 13:12:30 avagent Error <5061>: No response to message
2018/02/20-07:42:30.26300 [agent_main]  agent_message::hangup closing socket
2018/02/20-07:42:30.26300 [agent_main]  agent_message::hangup closed connection
2018/02/20-07:42:30.26399 [agent_main]  agent_commands::check_mc_response received an bad status code 'CR_ERROR'
2018/02/20-07:42:30.26399 [agent_main]  agent_commands::check_mc_response ret=9. 
 

--Veya--

2019-01-28 12:52:53 avagent Info <6601>: Hostnamelist: client1.avamar.com,171.16.100.200,client1.avamar.com,127.0.0.1
2019-01-28 12:52:54 avagent Info <5472>: Registering with the MCS (10.18.100.200)
2019-01-28 12:52:54 avagent Error <5320>: Received from MCS#100003:client certificate verification failed 100.168.100.20.
2019-01-28 12:52:54 avagent Error <5061>: No response to message
2019-01-28 12:52:54 avagent Error <6210>: Unable to register '/clients\client1' with MCS at 10.18.100.200:30001
2019-01-28 12:52:54 avagent Error <6164>: Registration error: Client ID(CID) missing from response. (< msgver="1" />
2019-01-28 12:52:54 avagent Error <5036>: Unable to register CR_ERROR
 

Senaryo 2: Kayıt tamamlanır ancak yedeklemeler, veri aktarımı olmadan "Waiting client" veya "Timed-Out End" sırasında takılı kalır:

avagent.log:

2017/06/14-15:17:43.99699 [agent_main]  agent_message::receive_message message sent, recv ack, timeout 300
2017/06/14-15:18:02.95099 [agent_main]  agent_message::lowrecv() Unable to recv message size!
2017/06/14-15:18:02.95099 [agent_main]  agent_message::recvcapsule capsule: server_avail:1, ret.size=0
2017/06/14-15:18:02.95099 [agent_main]  agent_message::receive_message after recv
2017-06-14 08:18:02 avagent Error <5061>: No response to message
2017/06/14-15:18:02.95099 [agent_main]  agent_message::hangup closing socket
2017/06/14-15:18:02.95099 [agent_main]  agent_message::hangup closed connection
2017-06-14 08:18:02 avagent Error <5038>: Error sending message CR_ERROR    
 

--Veya--

avagent Info <7502>: Registration of client /Data_Center1/SharePoint2013/prod_ext/client2.emc.local with MCS avamar-01emc.local:28001 successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3015 VSS successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3023 update successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3001 Windows successful.
2017-06-14 18:41:57 avagent Info <5619>: Registration of client and plugins complete.
2017-06-14 18:41:57 avagent Info <5964>: Requesting work from avamar-01.emc.local
2017-06-14 18:42:16 avagent Error <5061>: No response to message 2017-06-14 18:42:16 avagent Error <5038>: Error sending message CR_ERROR

Cause

Eğer avagent Günlük raporları "No response to message" veya "CR_ERROR İlk el sıkışma sırasında, send/acAvamar ızgarası ile istemci arasındaki k mesajları.

Not: Her iki senaryodaki tüm hatalar, müşterinin ortamındaki ağ veya güvenlik duvarı ile ilgili sorunları gösterir.

Resolution

Aşağıdaki adımlar, performans sorunlarını bulmaya yardımcı olmak için kullanılabilir:

1. Gerekli tüm Avamar bağlantı noktalarının güvenlik duvarında açık olduğundan ve veri gönderip alabildiğinden emin olun.
(Avamar sunucusundan istemciye ve istemciden Avamar sunucusuna)

2. Avamar bağlantı noktalarındaki verileri engelleyen herhangi bir antivirüs veya kötü amaçlı yazılım tespit yazılımı olup olmadığını kontrol edin.

3. İstemci bir NAT'nin arkasındaysa yol tablolarının doğru ayarlandığından emin olun.

4. Tüm istemcilerde aynı hata görülüyorsa Avamar ağında herhangi bir değişiklik yapılmadığından emin olun.

5. Hata veren istemciden Avamar ızgarasına ağ trafiğini takip etmek ve ağdaki paket düşüşlerini kontrol etmek için ağ ekibiyle iletişime geçin.

6. Herhangi bir sorun bulunamazsa collecting tcpdump ve Wireshark veya Netmon bilgilerine erişin ve Servis İsteği Oluşturun.

Additional Information

Wireshark Kaynakları:
 
TCPDump Kaynakları:
  •    https://linuxtechlab.com/learn-use-tcpdump-command-examples(Harici bağlantı)

Affected Products

Avamar, Avamar Client
Article Properties
Article Number: 000040936
Article Type: Solution
Last Modified: 24 Sept 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.