Avamar:Avagent 記錄在註冊或備份期間顯示「CR_ERROR」

Summary: Avagent 記錄顯示錯誤「CR_ERROR」

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

案例 1 - 用戶端註冊失敗:

avagent.log:

2018/02/20-07:42:30.26300 [agent_main]  agent_message::lowrecv() Unable to recv message size!

2018/02/20-07:42:30.26300 [agent_main]  agent_message::recvcapsule capsule: server_avail:1, ret.size=0
2018/02/20-07:42:30.26300 [agent_main]  agent_message::receive_message after recv
2018-02-20 13:12:30 avagent Error <5061>: No response to message
2018/02/20-07:42:30.26300 [agent_main]  agent_message::hangup closing socket
2018/02/20-07:42:30.26300 [agent_main]  agent_message::hangup closed connection
2018/02/20-07:42:30.26399 [agent_main]  agent_commands::check_mc_response received an bad status code 'CR_ERROR'
2018/02/20-07:42:30.26399 [agent_main]  agent_commands::check_mc_response ret=9. 
 

-- 或 --

2019-01-28 12:52:53 avagent Info <6601>: Hostnamelist: client1.avamar.com,171.16.100.200,client1.avamar.com,127.0.0.1
2019-01-28 12:52:54 avagent Info <5472>: Registering with the MCS (10.18.100.200)
2019-01-28 12:52:54 avagent Error <5320>: Received from MCS#100003:client certificate verification failed 100.168.100.20.
2019-01-28 12:52:54 avagent Error <5061>: No response to message
2019-01-28 12:52:54 avagent Error <6210>: Unable to register '/clients\client1' with MCS at 10.18.100.200:30001
2019-01-28 12:52:54 avagent Error <6164>: Registration error: Client ID(CID) missing from response. (< msgver="1" />
2019-01-28 12:52:54 avagent Error <5036>: Unable to register CR_ERROR
 

案例 2 - 註冊完成,但備份卡在「等待用戶端」或「逾時結束」,且無資料傳輸:

avagent.log:

2017/06/14-15:17:43.99699 [agent_main]  agent_message::receive_message message sent, recv ack, timeout 300
2017/06/14-15:18:02.95099 [agent_main]  agent_message::lowrecv() Unable to recv message size!
2017/06/14-15:18:02.95099 [agent_main]  agent_message::recvcapsule capsule: server_avail:1, ret.size=0
2017/06/14-15:18:02.95099 [agent_main]  agent_message::receive_message after recv
2017-06-14 08:18:02 avagent Error <5061>: No response to message
2017/06/14-15:18:02.95099 [agent_main]  agent_message::hangup closing socket
2017/06/14-15:18:02.95099 [agent_main]  agent_message::hangup closed connection
2017-06-14 08:18:02 avagent Error <5038>: Error sending message CR_ERROR    
 

-- 或 --

avagent Info <7502>: Registration of client /Data_Center1/SharePoint2013/prod_ext/client2.emc.local with MCS avamar-01emc.local:28001 successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3015 VSS successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3023 update successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3001 Windows successful.
2017-06-14 18:41:57 avagent Info <5619>: Registration of client and plugins complete.
2017-06-14 18:41:57 avagent Info <5964>: Requesting work from avamar-01.emc.local
2017-06-14 18:42:16 avagent Error <5061>: No response to message 2017-06-14 18:42:16 avagent Error <5038>: Error sending message CR_ERROR

Cause

如果 avagent 記錄報告」No response to message或”CR_ERROR 在初始交握期間,發生通訊問題封鎖 send/acAvamar 格線和用戶端之間的 k 則訊息。

注意:這兩種情況下的所有錯誤都表示客戶環境中存在網路或防火牆相關問題。

Resolution

以下步驟可用於説明查找瓶頸:

1.檢查防火牆中是否已開啟所有必要的 Avamar 連接埠,且可收發資料。
(Avamar 伺服器到用戶端和用戶端到 Avamar 伺服器)

2.檢查是否有任何防毒或惡意軟體偵測軟體封鎖 Avamar 連接埠上的資料。

3.如果客戶端位於 NAT 後面,請驗證是否正確設置了路由表。

4.如果所有用戶端上都出現相同的錯誤,請確定並未對 Avamar 網路進行任何變更。

5.與網路團隊接洽,追蹤從故障用戶端到 Avamar 格線的網路流量,並檢查網路中的封包掉落。

6.如果找不到任何問題,請收集 tcpdumpWireshark Netmon 資訊,並 建立服務要求。

Additional Information

Wireshark 資源:
 
TCPDump 資源:
  •   https://linuxtechlab.com/learn-use-tcpdump-command-examples(外部連結)

Affected Products

Avamar, Avamar Client
Article Properties
Article Number: 000040936
Article Type: Solution
Last Modified: 24 Sept 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.