Avamar: Isilon NDMP-back-up mislukt met "NDMP: Kan snapshot niet maken" en "Bewerking niet toegestaan"

Summary: Isilon NDMP-back-ups mislukken met de foutmelding "Failed to create snapshot: Bewerking niet toegestaan" omdat de Snapshot-service is uitgeschakeld in OneFS. Het probleem kan worden opgelost door de Snapshot-service en gerelateerde instellingen in te schakelen. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • NDMP-back-uptaken mislukken en worden niet voltooid.
  • Het maken van een snapshot voor de opgegeven map mislukt met "Operation not permitted".
  • NDMP-context kan niet worden gemaakt, waardoor een interne NDMP-fout stopt.
  • De back-upgegevensstroom stopt; Er worden geen data overgedragen (het aantal lees- en geschreven bytes is nul).

Voorbeeld van logboekvermeldingen

2020-12-07 03:59:35 avndmp Error <0000>: [snapup- /ifs/FOLDER1/] NDMP: Failed to create snapshot for /ifs/FOLDER1/: Operation not permitted
2020-12-07 03:59:35 avndmp Error <0000>: [snapup- /ifs/FOLDER1/] NDMP: Failed to create context
2020-12-07 03:59:35 avndmp Warning <9655>: [snapup- /ifs/FOLDER1/] NDMP Data Halted, reason : NDMP_DATA_HALT_INTERNAL_ERROR
2020-12-07 03:59:35 avndmp Info <18443>: [ndmp2avtar- /ifs/FOLDER1/] NDMP stream bytes read = 0, bytes written = 0 

Cause

De snapshotservice in OneFS is uitgeschakeld. NDMP vereist snapshots om een consistente datastatus vast te leggen tijdens het maken van een back-up. Wanneer de service niet actief is, mislukt het maken van snapshots en kunnen NDMP-bewerkingen niet worden voortgezet.

Belangrijkste indicatoren:

  • Fout: "Kan geen snapshot maken voor <mappad>: Operatie niet toegestaan."
  • Het maken van NDMP-context mislukt, gevolgd door een interne onderbreking van de fout.

 Onderliggende aandoeningen

  • De Snapshot-service in OneFS is uitgeschakeld, waardoor er geen snapshotbewerkingen meer kunnen worden uitgevoerd.
  • NDMP is afhankelijk van het maken van snapshots om een consistente datastatus vast te leggen; Zonder dit kan de back-up niet worden voortgezet.
  • Er worden geen extra omgevingsfactoren (zoals netwerkproblemen) aangegeven in de logboeken.

Resolution

Oplossingsstappen - Via de OneFS Web-UI

Meld u aan bij de OneFS-webinterface als de hoofdgebruiker.
Ga naar Data Protection > SnapshotIQ > Settings.
Vink het vakje Enable snapshot service aan.

  • Vink onder het nieuw ingeschakelde gedeelte ook aan:
    • Automatische snapshots maken
    • Snapshots automatisch verwijderen
  • Blader naar het gedeelte Wereldwijde zichtbaarheid en toegang en schakel het in.
  • Schakel voor elk protocol (NFS, SMB, Lokaal) de bijbehorende zichtbaarheids- en toegangsopties in.
  • Klik op de knop Wijzigingen opslaan om de nieuwe configuratie toe te passen.

 


Alternatieve oplossing - via de opdrachtregelinterface (CLI)

Als de webinterface niet beschikbaar is, kan de snapshotservice worden ingeschakeld met behulp van SSH:

# Log in as root
ssh root@[ISILON_CLUSTER_IP]

# Enable the snapshot service
isi snapshot service enable

# Enable auto‑creation and auto‑deletion of snapshots
isi snapshot policy modify --auto-create true --auto-delete true

# Enable global visibility for NFS, SMB, and local access
isi snapshot visibility modify --global true --protocol nfs, smb, local

# Verify the changes
isi snapshot service list

Controle

  • Voer een NDMP-back-uptaak uit en controleer of de fout niet langer wordt weergegeven in avndmp-logboeken .
  • Controleer de SnapshotIQ UI om er zeker van te zijn dat er snapshots worden gemaakt voor beveiligde mappen.
  • Evalueer het clusterstoragegebruik om het verwachte ruimtegebruik voor snapshots te bevestigen.

Opmerking: Na het inschakelen van de snapshotservice kan het enkele minuten duren voordat de wijzigingen zijn doorgevoerd op alle knooppunten.
Waarschuwing: Onjuiste snapshot-instellingen kunnen van invloed zijn op het databeschermingsbeleid. Als u twijfelt over de configuratie, neem dan contact op met Dell Support voordat u verdergaat.
Let op: Als u snapshots inschakelt, verhoogt u het storageverbruik. Controleer of het cluster voldoende vrije ruimte heeft om te voorkomen dat er te weinig ruimte is.

Additional Information

Stappen voor probleemoplossing:
  1. SSH naar NDMP-versneller als rootgebruiker

2. Verander de directory in de Isilon-clientdirectory:

cd /usr/local/avamar/var/<ISILON_CLIENT>

  3. Voer een Isilon socketverbindingstest uit met behulp van het ndmp.cfg-bestand:     

avndmp --browse `cat ndmp.cfg`

Als bladeren is geslaagd, wordt een uitvoer weergegeven die vergelijkbaar is met de onderstaande uitvoer:
     
  4. Ga met SSH naar Isilon als rootgebruiker.

  5. Controleer of er een SNAPSHOTIQ-licentie is geïnstalleerd in Isilon -> In de statuskolom wordt "Licensed" weergegeven

isi license list | grep -i snapshot

  6. Controleer of de rol SystemAdmin alle juiste machtigingen heeft.  Zie de Isilon beheerhandleiding voor een lijst met machtigingen.

isi auth roles view SystemAdmin

  7. Controleer in het isi_snapshot_d.log-bestand de status van de snapshotbewerking -> komt overeen met de fout uit Avamar NDMP-logboeken:

ISI-EMC-LAB-1# isi_for_array cat /var/log/isi_snapshot_d.log  | grep 2020-12-09
ISI-EMC-LAB-1: 2020-12-09T15:40:55-05:00 <31.6> ISI-EMC-LAB-1 isi_ndmp_d[75632]: Failed to create snapshot        
"ndmp_backup_15bf7e9b1d2430d7a10c73396b55bc17_1607546455_1", snapid: 0 with error Operation not permitted

  8. Maak een testmap met de naam "TEST" onder de directory "/ifs/".  Als de map is gemaakt, is er geen probleem met het Isilon-bestandssysteem:

cd /ifs/ && mkdir TEST && pwd && ls -l

  9. Maak een handmatige snapshot vanuit Isilon CLI:

 isi snapshot create /ifs/TEST --name=TEST-SNAPSHOT

Als snapshot mislukt met "snapshot create failed: Bewerking niet toegestaan", dan is er een probleem met het Isilon Snapshot aanmaakmechanisme.
  
  10 Volg de stappen in het gedeelte Oplossing van deze KB.

  11 Voer een on-demand back-up uit voor de Isilon client in Avamar -> Als er data worden uitgevoerd en opgenomen, is het probleem opgelost.

  12 Ruim de directory "TEST" in Isilon op:

rm -rf /ifs/TEST




     

Affected Products

Avamar
Article Properties
Article Number: 000180692
Article Type: Solution
Last Modified: 10 Dec 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.