Авамар: Резервне копіювання Isilon NDMP не працює з "NDMP: Не вдалося створити знімок» та «Операція не дозволена»

Summary: Резервні копії Isilon NDMP не справляються з помилкою «Не вдалося створити знімок: Експлуатація не дозволена», оскільки сервіс Snapshot вимкнений у OneFS. Увімкнення сервісу Snapshot та супутніх налаштувань вирішує проблему. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Резервні завдання NDMP провалюють і не завершуються успішно.
  • Створення знімка для вказаного каталогу не спрацьовує з написом «Операція не дозволена».
  • Контекст NDMP не може бути створений, що призводить до внутрішньої зупинки помилки NDMP.
  • Резервне копування потоку даних зупиняється; Дані не передаються (кількість прочитаних і записаних байтів дорівнює нулю).

Приклади записів у журналі

2020-12-07 03:59:35 avndmp Error <0000>: [snapup- /ifs/FOLDER1/] NDMP: Failed to create snapshot for /ifs/FOLDER1/: Operation not permitted
2020-12-07 03:59:35 avndmp Error <0000>: [snapup- /ifs/FOLDER1/] NDMP: Failed to create context
2020-12-07 03:59:35 avndmp Warning <9655>: [snapup- /ifs/FOLDER1/] NDMP Data Halted, reason : NDMP_DATA_HALT_INTERNAL_ERROR
2020-12-07 03:59:35 avndmp Info <18443>: [ndmp2avtar- /ifs/FOLDER1/] NDMP stream bytes read = 0, bytes written = 0 

Cause

Сервіс Snapshot у OneFS вимкнений. NDMP вимагає знімків для фіксації стабільного стану даних під час резервного копіювання. Коли сервіс неактивний, створення знімків не спрацьовує, і операції NDMP не можуть продовжуватися.

Ключові показники:

  • Помилка: "Не вдалося створити знімок для <шляху> до каталогу: Операція не дозволена.»
  • Створення контексту NDMP не зазнає, після чого відбувається зупинка внутрішньої помилки.

 Основні умови

  • Сервіс Snapshot у OneFS вимкнений, що запобігає будь-яким операціям знімків.
  • NDMP покладається на створення знімків для фіксації узгодженого стану даних; без неї резервне копіювання не зможе продовжити роботу.
  • У журналах не зазначено додаткових екологічних факторів (наприклад, проблеми з мережею).

Resolution

Кроки вирішення — використання веб-інтерфейсу OneFS

Увійдіть у веб-інтерфейс OneFS як root-користувач
.Перейдіть до > Data Protection SnapshotIQ > Settings.
Поставте галочку з позначкою «Увімкнути сервіс знімків».

  • У розділі «Новий увімкнений» також перевірте:
    • Автоматичне створення знімків
    • Автоматичне видалення знімків
  • Прокрутіть до глобальної області видимості та доступу та увімкніть її.
  • Для кожного протоколу (NFS, SMB, Local) увімкніть відповідні опції видимості та доступу.
  • Натисніть кнопку «Зберегти зміни», щоб застосувати нову конфігурацію.

 


Альтернативна роздільна здатність — використання інтерфейсу командного рядка (CLI)

Якщо веб-інтерфейс недоступний, сервіс знімків можна увімкнути за допомогою SSH:

# Log in as root
ssh root@[ISILON_CLUSTER_IP]

# Enable the snapshot service
isi snapshot service enable

# Enable auto‑creation and auto‑deletion of snapshots
isi snapshot policy modify --auto-create true --auto-delete true

# Enable global visibility for NFS, SMB, and local access
isi snapshot visibility modify --global true --protocol nfs, smb, local

# Verify the changes
isi snapshot service list

Верифікація

  • Запустіть резервне копіювання NDMP і переконайтеся, що помилка більше не з'являється в журналах avndmp .
  • Перевірте інтерфейс SnapshotIQ, щоб переконатися, що знімки створені для захищених каталогів.
  • Перевірте використання кластерної пам'яті, щоб підтвердити очікуване використання місця знімків.

Примітка: Після активації сервісу знімків зміни можуть поширитися на всі вузли через кілька хвилин.
Увага: Неправильні налаштування знімків можуть впливати на політику захисту даних. Якщо ви не впевнені у конфігурації, зверніться до служби підтримки Dell перед тим, як рухатися далі.
Увага: Активація знімків збільшить споживання сховища. Перевірте, чи має кластер достатньо вільного простору, щоб уникнути позапросторових умов.

Additional Information

Кроки усунення несправностей:
  1. Прискорювач SSH до NDMP як користувач

root 2. Змініть директорію на директорію клієнта Isilon:

cd /usr/local/avamar/var/<ISILON_CLIENT>

  3. Запустіть тест підключення до сокета Isilon, використовуючи файл ndmp.cfg:     

avndmp --browse `cat ndmp.cfg`

Якщо перегляд пройшов успішно, буде показано виведення, подібне до наведеного нижче:
     
  4. SSH до Isilon як користувач root.

  5. Переконайтеся, що в Isilon встановлена ліцензія SNAPSHOTIQ -> Стовпець статусу показує "Ліцензовано"

isi license list | grep -i snapshot

  6. Переконайтеся, що роль SystemAdmin має всі правильні дозволи.  Перегляньте Посібник з адміністрування Isilon для отримання списку дозволів.

isi auth roles view SystemAdmin

  7. Перевірте у файлі isi_snapshot_d.log статус операції знімка -> Збігається з помилкою з журналів Avamar NDMP:

ISI-EMC-LAB-1# isi_for_array cat /var/log/isi_snapshot_d.log  | grep 2020-12-09
ISI-EMC-LAB-1: 2020-12-09T15:40:55-05:00 <31.6> ISI-EMC-LAB-1 isi_ndmp_d[75632]: Failed to create snapshot        
"ndmp_backup_15bf7e9b1d2430d7a10c73396b55bc17_1607546455_1", snapid: 0 with error Operation not permitted

  8. Створіть тестовий каталог з іменем "TEST" у каталозі "/ifs/".  Якщо каталог успішно створено, то проблема не в файловій системі Isilon:

cd /ifs/ && mkdir TEST && pwd && ls -l

  9. Створіть знімок вручну з Isilon CLI:

 isi snapshot create /ifs/TEST --name=TEST-SNAPSHOT

Якщо не вдалося зробити знімок за допомогою "snapshot create failed: Операція не дозволена», то проблема полягає в механізмі створення знімка Isilon.
  
  10 Дотримуйтесь інструкцій, наведених у розділі «Роздільна здатність» цієї бази знань.

  11 Запустіть резервну копію на вимогу для клієнта Isilon в Avamar -> Якщо запущено та проковтнуто дані, то проблему вирішено.

  12 Очистіть директорію "TEST" в Isilon:

rm -rf /ifs/TEST




     

Affected Products

Avamar
Article Properties
Article Number: 000180692
Article Type: Solution
Last Modified: 10 Dec 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.