Errori del dispositivo SDS PowerFlex crittografati da CloudLink dopo il riavvio a causa del servizio SDS avviato prima che l'agent CloudLink sblocchi le unità
Summary: Quando i dispositivi SDS PowerFlex vengono crittografati tramite CloudLink, i nomi dei mapper possono cambiare dopo un riavvio. In questo modo i dispositivi SDS vengono riordinati e vengono visualizzati come guasti nell'interfaccia utente di PowerFlex. ...
Symptoms
Prodotti interessati: La combinazione specifica che include:
- PowerFlex 3.6
- Collegamento cloud 7.1
- RHEL 8.x
- Dispositivi SDS crittografati da CloudLink
Dopo un riavvio, i dispositivi SDS crittografati da CloudLink possono essere visualizzati come guasti nell'interfaccia utente di PowerFlex a causa del riordino del mapper dei dispositivi.
Il mapping logico del dispositivo di avvio può essere scambiato tra la prima e l'ultima lettera del dispositivo.
Gli errori SDS possono verificarsi anche dopo il riavvio se il servizio SDS si avvia prima che CloudLink abbia sbloccato le unità. Questo problema verrà risolto nella versione 7.0.2 di CloudLink.
Cause
- Il mapper CloudLink crittografato utilizza la lettera dell'unità come identificatore. (ad esempio, /dev/mapper/svm_sdb)
- Quando la lettera dell'unità cambia, cambia anche il nome del mapper
- Durante il riavvio, la lettera dell'unità può cambiare a seconda che l'unità di avvio o le unità SDS vengano rilevate per prime.
- Ciò può verificarsi anche se il servizio SDS viene avviato prima che l'agent CloudLink abbia sbloccato le unità.
Resolution
Soluzione alternativa per la modifica della lettera dell'unità:
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Opzione 1:
- Arrestare il servizio SDS sul nodo PowerFlex (/opt/emc/scaleio/sds/bin/delete_service.sh).
- Cancellare tutti gli avvisi SDS. In questo modo PowerFlex dovrebbe attivare una nuova scansione del sistema per cercare i nuovi nomi dei dispositivi e iniziare a utilizzarli. (disponibile nei dispositivi server > di presentazione).
- Riavviare il servizio SDS dopo (/opt/emc/scaleio/sds/bin/create_service.sh).
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Opzione 2: Rimuovere le unità SDS da PowerFlex e riaggiungerle. (disponibile nei dispositivi server > di presentazione)
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Opzione 3: Riavviare il nodo PowerFlex. L'ordine dei dischi potrebbe tornare al mapping originale.
Se i riavvii successivi utilizzano il nuovo formato della lettera dell'unità, gli errori SDS continuano a verificarsi durante i riavvii. Per modificare le lettere dell'unità PowerFlex in modo che non si verifichino errori SDS, eseguire i seguenti comandi scli:
Individuare il sds_id del nodo SDS in cui si sono verificati gli errori:
Scli --query_all_sds
Eseguire l'aggiornamento con le nuove lettere dell'unità:
Scli --update_sds_original_paths -sds_id <id>
Ritardare l'avvio di PowerFlex fino a quando CloudLink non sblocca le unità:
Gli aggiornamenti di CloudLink alle versioni 7.0x, 7.1, 7.1.1 e 7.1.2 rimuoveranno un timer di sospensione di 60 secondi in /opt/emc/extra/pre_run.sh sui nodi SDS. Ciò causerà errori SDS dopo un riavvio perché PowerFlex inizia a utilizzare le unità prima che vengano sbloccate da CloudLink. Per evitare errori SDS al riavvio, aggiungere nuovamente il ritardo di 60 secondi in /opt/emc/extra/pre_run.sh sui nodi SDS dopo un aggiornamento dell'agent CloudLink. Ciò ritarda l'avvio del servizio SDS fino a quando le unità crittografate non vengono sbloccate da CloudLink.
Un esempio che mostra il ritardo di 60 secondi aggiunto a pre_run.sh:
#!/bin/bash -f if [ -f /sbin/svm ]; then echo svm is installed $(date) >> /var/log/svm-sds /sbin/svmd -l /var/log/svmd.log -p /var/run/svmd.pid & end=$((SECONDS+300)) while [ $SECONDS -lt $end ]; do /sbin/svm unlocked > /dev/null && break sleep 5 done fi sleep 60 echo pre_run returned...$(date) >> /var/log/svm-sds
Correzione permanente:
- Nuovi deployment : installazione di CloudLink 7.1.2 e PowerFlex 3.6.0.2
- Sistemi esistenti: Upgrade a CloudLink 7.1.2 e PowerFlex 3.6.0.2
CloudLink 7.1.2 e PowerFlex 3.6.0.2 utilizzeranno /dev/disk/by-id/.... E quindi usa i nomi /dev/mapper/svm_wwn-XXXX rispetto al logico /dev/svm_sdXXX.