Avamar: Hyper-V 페더레이션된 백업이 "원격 클라이언트에 연결할 수 없음", 오류 코드: 2. 원격 백업 에이전트가 실행 중인지 확인합니다."
Summary: 원격 연결 실패로 인한 Hyper-V 백업 실패에 대한 솔루션을 제공하는 KB(Knowledge Base) 문서입니다.
Symptoms
Hyper-V 클러스터 백업이 실패하고 아래와 유사한 오류가 발생합니다.
avhypervvss Error <0000>: Unable to connect to the remote client '192.168.1.1', result code: 2. Please ensure that the remote backup agent is running. avhypervvss Error <19328>: [AVA1] is unable to forward CTL sub-workorder to remote client [AVA1].
Cause
운영 클러스터 노드는 포트 28002 또는 30002를 사용하는 백업 에이전트 통신 간 서비스를 사용하여 보조 노드로 작업 순서를 보낼 수 없습니다. 몇 가지 가능한 근본 원인은 다음과 같습니다.
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보조 노드의 백업 에이전트(Avagent) 서비스가 시작되지 않았습니다.
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보조 노드의 포트 28002 또는 30002가 차단됩니다.
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기본 노드가 보조 노드의 잘못된 IP 주소로 하위 작업 오더를 전송하려고 합니다. 이 IP 주소는 라우팅이 불가능하거나 Avamar 그리드에 액세스할 수 없습니다.
Resolution
원인에 따라 해결 방법은 다음과 같습니다.
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services.msc 콘솔을 사용하여 Hyper-V 클러스터의 보조 노드에서 Backup Agent 서비스를 시작합니다.
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각 클러스터 노드의 Windows Defender 방화벽 소프트웨어에 인바운드 규칙을 추가하여 보조 노드에서 포트 28002 또는 30002를 엽니다. 일부 고객 환경에서는 시스템 관리자에게 문의하여 방화벽 또는 라우터 애플리케이션에서 필요한 포트를 여십시오.
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편집
avhypervvss.cmd파일을 열고 "--cluster node" 플래그를 각 클러스터 노드의 IP 주소로 바꿉니다.-
페더레이션된 Hyper-V 클러스터 백업의 경우
avhypervvss.cmd파일은 'ClusterStorage' 디렉토리에 있습니다(예:C:\ClusterStorage\Volume1\Avamar\var)을 사용합니다.--clusternode=<<NODENAME>>(IP Address) --clusternode=<<NODENAME>>(IP Address)
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프록시 백업의 경우
avhypervvss.cmd파일은 'C:\Program Files\avs\var' 디렉토리입니다.--clusternode=<<NODENAME>>(IP Address) --clusternode=<<NODENAME>>(IP Address)
예:
--clusternode=HYPERVNODE1(192.168.1.10)
--clusternode=HYPERVNODE2(192.168.1.11)
--clusternode=HYPERVNODE3(192.168.1.12)
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Additional Information
Backup Agent 서비스는 Avamar Server에서 세션 보안이 활성화된 경우 포트 30002를 사용합니다.