Rocky Linux : Erreur « propriété inconnue » lors de la tentative de modification des propriétés de l’interface réseau

Summary: Cet article fournit des informations de dépannage pour l’erreur « Impossible d’enregistrer la connexion : connexion. Autoconnect-ports : unknown property" lors de la modification des propriétés de l’interface réseau. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Lorsque l’administrateur tente de modifier les propriétés de l’interface réseau à l’aide de nmtui, le message d’erreur suivant s’affiche :

"Unable to save connection: connection.autoconnect-ports: unknown property"

Erreur NMTUI

Vous trouverez ci-dessous un exemple d’erreurs observées lors de la tentative de configuration de l’interface à l’aide de nmcli:

[root@localhost pcap]# nmcli connection modify BCM57414-IntNIC1-P1-25Gb 802-3-ethernet.mtu 1500
Warning: nmcli (1.46.0) and NetworkManager (1.44.0) versions don't match. Restarting NetworkManager is advised.
Error: Failed to modify connection 'BCM57414-IntNIC1-P1-25Gb': connection.autoconnect-ports: unknown property

[root@localhost pcap]# nmcli connection modify BCM57414-IntNIC1-P1-25Gb 802-3-ethernet.mtu 9000
Warning: nmcli (1.46.0) and NetworkManager (1.44.0) versions don't match. Restarting NetworkManager is advised.
Error: Failed to modify connection 'BCM57414-IntNIC1-P1-25Gb': connection.autoconnect-ports: unknown property

Dans cet exemple, l’administrateur a tenté de modifier la MTU de l’interface, mais la même erreur se produit lors de la tentative de modification d’une autre propriété.

Cause

La cause n’est pas claire. Pour une raison quelconque, Network Manager indique une incompatibilité de version.

Resolution

  1. Check (Vérifier) NetworkManager et nmcli Versions: Vérifiez si l’option NetworkManager et nmcli Les versions correspondent. Dans l’exemple ci-dessous, les versions correspondaient :
    [root@localhost pcap]# rpm -qa | grep NetworkManager
    NetworkManager-libnm-1.46.0-4.el9_4.x86_64
    NetworkManager-1.46.0-4.el9_4.x86_64
    NetworkManager-wwan-1.46.0-4.el9_4.x86_64
    NetworkManager-team-1.46.0-4.el9_4.x86_64
    NetworkManager-wifi-1.46.0-4.el9_4.x86_64
    NetworkManager-bluetooth-1.46.0-4.el9_4.x86_64
    NetworkManager-adsl-1.46.0-4.el9_4.x86_64
    NetworkManager-tui-1.46.0-4.el9_4.x86_64
    NetworkManager-config-server-1.46.0-4.el9_4.noarch
  2. Redémarrer NetworkManager: Redémarrage de NetworkManager Le Service peut résoudre le problème :
    [root@localhost pcap]# systemctl restart NetworkManager
  3. Vérifiez les paramètres : Après le redémarrage, vérifiez si les paramètres modifiés ont été appliqués correctement :
    [root@localhost pcap]# nmcli connection show BCM57414-IntNIC1-P1-25Gb | grep 802-3-ethernet.mtu
    802-3-ethernet.mtu:                     9000
    [root@localhost pcap]# nmcli connection show BCM57414-IntNIC1-P2-25Gb | grep 802-3-ethernet.mtu
    802-3-ethernet.mtu:                     9000
  4. Abaissez et soulevez les ports pour appliquer la nouvelle configuration :
    [root@localhost pcap]# nmcli con down BCM57414-IntNIC1-P1-25Gb && nmcli con up BCM57414-IntNIC1-P1-25Gb
    Connection 'BCM57414-IntNIC1-P1-25Gb' successfully deactivated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/2)
    Connection successfully activated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/17)
    
    [root@localhost pcap]# nmcli con down BCM57414-IntNIC1-P2-25Gb && nmcli con up BCM57414-IntNIC1-P2-25Gb
    Connection 'BCM57414-IntNIC1-P2-25Gb' successfully deactivated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/3)
    Connection successfully activated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/18)
  5. Tester la connectivité : Dans cet exemple, l’administrateur a modifié le paramètre MTU et a exécuté un test ping pour vérifier la connectivité et l’application correcte de la MTU :
    [root@localhost pcap]# ping 192.168.15.10 -s8972 -c4
    PING 192.168.15.10 (192.168.15.10) 8972(9000) bytes of data.
    8980 bytes from 192.168.15.10: icmp_seq=1 ttl=64 time=0.287 ms
    8980 bytes from 192.168.15.10: icmp_seq=2 ttl=64 time=0.136 ms
    8980 bytes from 192.168.15.10: icmp_seq=3 ttl=64 time=0.125 ms
    8980 bytes from 192.168.15.10: icmp_seq=4 ttl=64 time=0.135 ms

Pour plus d’informations sur la configuration réseau, consultez la documentation officielle de Rocky Linux : Configuration réseau - DocumentationCe lien hypertexte renvoie à un site Web extérieur à Dell Technologies.

Affected Products

Red Hat Enterprise Linux Version 7, Red Hat Enterprise Linux Version 9, Red Hat Enterprise Linux Version 8
Article Properties
Article Number: 000284281
Article Type: Solution
Last Modified: 08 Nov 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.