Connectrix B-Serie: Anleitung zum Troubleshooting eines SSH-Fehlers beim Versuch, einen Supportsave durchzuführen
Summary: Supportsave schlägt mit der Meldung "Fehler ist in SSH aufgetreten" fehl.
Symptoms
A supportsave schlägt fehl während SSH Authentifizierung.
admin> supportsave This command collects RASLOG, TRACE, supportShow, core file, and then transfer them to a FTP/SCP/SFTP server or a USB dev This operation can take several minutes. OK to proceed? (yes, y, no, n) : [no] y Host IP or Host Name: 10.xx.xx.10 User Name: admin Remote Directory: / Protocol (ftp | scp | sftp): sftp SCP/SFTP Server Port Number [22] : Do you want to continue with CRA (Y/N): [N] Password: Saving support information: SLOT SWITCH MODULE CLI SIZE CLI TIME MODULE TIME LOAD AVERAGE Error occurred in SSH. Summary worker: 2, cpu load: 3 upload size: 0 KB, time: 1 load:0.3/0.1/0.1 SupportSave completed (upload failure)
Beides SCP und SFTP sich verlassen auf SSH für die Authentifizierung. SCP verwendet im Wesentlichen SSH unter der Haube, um eine sichere Verbindung zwischen Client (Switch) und Server (z.B. SANnav oder SFTP Server) für Dateiübertragungen.
Wenn Sie eine SCP übertragen werden, gibt es zwei Authentifizierungsschritte:
- Serverauthentifizierung:
SSHVerwendet Hostschlüssel zur Authentifizierung des Servers. - Nutzerauthentifizierung: In
SSHruft der Client die Authentifizierung beim Server mit einem Kennwort, einem Schlüsselpaar oder anderen Methoden vor.
Cause
Unter der Annahme, dass Ihre Anmeldedaten korrekt sind, wird das Problem wahrscheinlich durch einen Fehler während der Serverauthentifizierung verursacht.
Der Switch (SSH Client) vergleicht den Hostschlüssel, der von der SSH Server (10.xx.xx.10) gegen die Schlüssel, die in seiner known_hosts zu verwenden. Wenn eine Nichtübereinstimmung vorliegt, schlägt die Authentifizierung fehl.
Resolution
Die Lösung besteht darin, den fehlerhaften Eintrag vom Switch zu löschen.
Gebrauchen sshutil delknownhost So löschen Sie das Fenster SSH (SCP/SFTP) Server-IP-Adresse oder Hostname aus der Tabelle der bekannten Hosts des Geräts. Nur Nutzer, denen Zugriff auf die Verwendung von SSH-verwandte Tools wie z.B. sshutil auf dem Brocade-Switch die folgende Aktion ausführen.
Verwenden Sie zur Bestätigung den folgenden Befehl:
sw7:FID128:admin> sshutil showuser
Sollte die SCP Die Serverkonnektivität kann über einen anderen Port als 22 erfolgen (Standardeinstellung) SSH), muss auch die Portnummer angegeben werden. Zum Beispiel: SSH/SFTP Server (10.xx.xx.10:22) verwenden Sie die folgende Syntax:
sw7:FID128:admin> sshutil delknownhost IP Address/Hostname to be deleted: 10.xx.xx.10
Beispiel: SANnav Server (10.xx.xx.10:6022) verwenden Sie die folgende Syntax:
sw7:FID128:admin> sshutil delknownhost IP Address/Hostname to be deleted: [10.xx.xx.10]:6022