Avamar : l’enregistrement du proxy de VM cesse de répondre

Summary: L’enregistrement du proxy de machine virtuelle cesse de répondre

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Mise à niveau d’Avamar Server vers la version 7.3

Après la mise à niveau d’Avamar Server vers Avamar v7.3, l’enregistrement du serveur proxy a cessé de fonctionner. Lors de la tentative de réinscription, il cesse de répondre à « UN-Registering with the MCS »

Du côté proxy, lorsque vous tentez d’exécuter initproxyappliance.sh d’enregistrer le proxy auprès de MCS. Le avagent.log affiche les informations suivantes. Il est passé en mode blocage.

2016/11/02-22:59:23.70883 [avagent]  Debug output redirected
2016-11-02 22:59:23 avagent Info <5008>: Logging to /usr/local/avamarclient/var/avagent.log
2016/11/02-22:59:23.70892 [avagent]  Config: VARDIR=/usr/local/avamarclient/var, HOMEDIR=/root
2016/11/02-22:59:23.70893 [avagent]  Looking for flag file "/usr/local/avamarclient/var/avamar.cmd"
2016/11/02-22:59:23.70895 [avagent]  Looking for flag file "/usr/local/avamarclient/var/avagent.cmd"
2016-11-02 22:59:23 avagent Info <5702>: Command Line: /usr/local/avamarclient/bin/avagent.bin --quiet --init --daemon=false --listenport=28009 --bindir="/usr/local/avamarclient/bin" --vardir="/usr/local/avamarclient/var" --sysdir="/usr/local/avamarclient/etc" --logfile="/usr/local/avamarclient/var/avagent.log" --logtimeformat=default --logtimezone=default --mcsaddr="AvamarHostName" --listenport=28009 --dpndomain="/Avamar_Proxies"
2016-11-02 22:59:23 avagent Info <5703>: Parsed Flags: /usr/local/avamarclient/bin/avagent.bin --quiet --initialize --service=false --acport=28009 --bindir=/usr/local/avamarclient/bin --vardir=/usr/local/avamarclient/var --sysdir=/usr/local/avamarclient/etc --logfile=/usr/local/avamarclient/var/avagent.log --logtimeformat=default --logtimezone=default --mcsaddr=AvamarHostName --acport=xxxx --dpndomain=/Avamar_Proxies
2016-11-02 22:59:23 avagent Info <6601>: Hostnamelist: 127.x.x.x,avamarproxy2.domainname,avamarproxy2,10.xxx.xx.67
2016-11-02 22:59:23 avagent Info <6609>: UN-Registering with the MCS (10.xxx.xx.63)

Côté serveur Avamar, le journal MCS affiche les erreurs suivantes :

root@avamar1:/usr/local/avamar/var/mc/server_log/#: grep '10.xxx.xx.67' mcserver.log.0

WARNING: Cl->MC 10.xxx.xx.67:47147: Can not process client request. Peer not authenticated
FINE: MC->Cl 10.xxx.xx.67:47147 <message  errno="100002" errdesc="SSL-related operations failed: Peer not authenticated" ack="no" type="response" sync="fg"  />
WARNING: thread :pool-7-thread-20 connection to 10.xxx.xx.67:47147 took 24140 mseconds
WARNING: Cl->MC 10.xxx.xx.67:47151: Can not process client request. Peer not authenticated
FINE: MC->Cl 10.xxx.xx.67:47151 <message  errno="100002" errdesc="SSL-related operations failed: Peer not authenticated" ack="no" type="response" sync="fg"  />
WARNING: Cl->MC 10.xxx.xx.67:47152: Can not process client request. Peer not authenticated
FINE: MC->Cl 10.xxx.xx.67:47152 <message  errno="100002" errdesc="SSL-related operations failed: Peer not authenticated" ack="no" type="response" sync="fg"  />
WARNING: thread :pool-7-thread-9 connection to 10.xxx.xx.67:47152 took 30029 mseconds
WARNING: Cl->MC 10.xxx.xx.67:47153: Can not process client request. Peer not authenticated
FINE: MC->Cl 10.xxx.xx.67:47153 <message  errno="100002" errdesc="SSL-related operations failed: Peer not authenticated" ack="no" type="response" sync="fg"  />
WARNING: Cl->MC 10.xxx.xx.67:47155: Can not process client request. Peer not authenticated
FINE: MC->Cl 10.xxx.xx.67:47155 <message  errno="100002" errdesc="SSL-related operations failed: Peer not authenticated" ack="no" type="response" sync="fg"  />
WARNING: thread :pool-7-thread-12 connection to 10.xxx.xx.67:47155 took 8766 mseconds

 

Cause

Avec la version 7.3.0.226, l’authentification client-serveur est activée par défaut.

Voici les deux raisons connues de ce problème :

  1. Certificat incorrect sur le client ou sur le système Data Domain
  2. L’heure du système Data Domain n’est pas synchronisée avec l’heure du serveur Avamar (environ >2 minutes)

 

Resolution

Reportez-vous à la 484773 de la base de connaissances pour obtenir une résolution (un compte de support Dell est requis pour afficher cet article)

 

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000063156
Article Type: Solution
Last Modified: 04 Mar 2026
Version:  4
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