Avamar: la registrazione proxy della macchina virtuale smette di rispondere
Summary: La registrazione proxy delle VM smette di rispondere
Symptoms
Eseguito l'upgrade di Avamar Server alla versione 7.3
Dopo l'upgrade di Avamar Server ad Avamar v7.3, la registrazione del server proxy ha smesso di funzionare. Quando tenta di ripetere la registrazione, smette di rispondere al messaggio "UN-Recording with the MCS"
Dal lato proxy, quando si tenta di eseguire initproxyappliance.sh registrare il proxy su MCS. Il avagent.log mostra le seguenti informazioni. È entrato in stato di impiccagione.
2016/11/02-22:59:23.70883 [avagent] Debug output redirected 2016-11-02 22:59:23 avagent Info <5008>: Logging to /usr/local/avamarclient/var/avagent.log 2016/11/02-22:59:23.70892 [avagent] Config: VARDIR=/usr/local/avamarclient/var, HOMEDIR=/root 2016/11/02-22:59:23.70893 [avagent] Looking for flag file "/usr/local/avamarclient/var/avamar.cmd" 2016/11/02-22:59:23.70895 [avagent] Looking for flag file "/usr/local/avamarclient/var/avagent.cmd" 2016-11-02 22:59:23 avagent Info <5702>: Command Line: /usr/local/avamarclient/bin/avagent.bin --quiet --init --daemon=false --listenport=28009 --bindir="/usr/local/avamarclient/bin" --vardir="/usr/local/avamarclient/var" --sysdir="/usr/local/avamarclient/etc" --logfile="/usr/local/avamarclient/var/avagent.log" --logtimeformat=default --logtimezone=default --mcsaddr="AvamarHostName" --listenport=28009 --dpndomain="/Avamar_Proxies" 2016-11-02 22:59:23 avagent Info <5703>: Parsed Flags: /usr/local/avamarclient/bin/avagent.bin --quiet --initialize --service=false --acport=28009 --bindir=/usr/local/avamarclient/bin --vardir=/usr/local/avamarclient/var --sysdir=/usr/local/avamarclient/etc --logfile=/usr/local/avamarclient/var/avagent.log --logtimeformat=default --logtimezone=default --mcsaddr=AvamarHostName --acport=xxxx --dpndomain=/Avamar_Proxies 2016-11-02 22:59:23 avagent Info <6601>: Hostnamelist: 127.x.x.x,avamarproxy2.domainname,avamarproxy2,10.xxx.xx.67 2016-11-02 22:59:23 avagent Info <6609>: UN-Registering with the MCS (10.xxx.xx.63)
Dal lato Avamar Server, il registro MCS mostra i seguenti errori:
root@avamar1:/usr/local/avamar/var/mc/server_log/#: grep '10.xxx.xx.67' mcserver.log.0 WARNING: Cl->MC 10.xxx.xx.67:47147: Can not process client request. Peer not authenticated FINE: MC->Cl 10.xxx.xx.67:47147 <message errno="100002" errdesc="SSL-related operations failed: Peer not authenticated" ack="no" type="response" sync="fg" /> WARNING: thread :pool-7-thread-20 connection to 10.xxx.xx.67:47147 took 24140 mseconds WARNING: Cl->MC 10.xxx.xx.67:47151: Can not process client request. Peer not authenticated FINE: MC->Cl 10.xxx.xx.67:47151 <message errno="100002" errdesc="SSL-related operations failed: Peer not authenticated" ack="no" type="response" sync="fg" /> WARNING: Cl->MC 10.xxx.xx.67:47152: Can not process client request. Peer not authenticated FINE: MC->Cl 10.xxx.xx.67:47152 <message errno="100002" errdesc="SSL-related operations failed: Peer not authenticated" ack="no" type="response" sync="fg" /> WARNING: thread :pool-7-thread-9 connection to 10.xxx.xx.67:47152 took 30029 mseconds WARNING: Cl->MC 10.xxx.xx.67:47153: Can not process client request. Peer not authenticated FINE: MC->Cl 10.xxx.xx.67:47153 <message errno="100002" errdesc="SSL-related operations failed: Peer not authenticated" ack="no" type="response" sync="fg" /> WARNING: Cl->MC 10.xxx.xx.67:47155: Can not process client request. Peer not authenticated FINE: MC->Cl 10.xxx.xx.67:47155 <message errno="100002" errdesc="SSL-related operations failed: Peer not authenticated" ack="no" type="response" sync="fg" /> WARNING: thread :pool-7-thread-12 connection to 10.xxx.xx.67:47155 took 8766 mseconds
Cause
Con la versione 7.3.0.226, l'autenticazione client-server è abilitata per impostazione predefinita.
Di seguito sono riportati i due motivi noti di questo problema:
- Certificato errato sul client o sul sistema Data Domain
- L'ora sul sistema Data Domain non è sincronizzata con l'ora sull'Avamar Server (circa >2 min)
Resolution
Fare riferimento all'484773 della KB per la risoluzione (per visualizzare questo articolo è necessario un account del supporto Dell)