Avamar SQLクラスターのバックアップが次のエラーで失敗します: リモート クライアントに接続できません

Summary: --clusternodeフラグを使用している場合でもSQLプラグインがセカンダリ レプリカに誤ったIPアドレスを使用する

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Symptoms

デュアルホームAlwaysONクラスターのAvamar SQLバックアップが失敗しています。

メインのavsqlプラグイン ログから、次の操作を実行します。

2017/01/26-11:46:01.41899 [avsql_assist]  avsql_iac_manager::forward_ctl_message() received response dequeued_ret    on queue remote
2017-01-26 12:46:01 avsql Error <0000>: Unable to connect to the remote client '10.x.x.22', error code: 2.
Please ensure that the remote backup agent is running.
2017/01/26-11:46:01.41899 [avsql_assist]  <=== avsql_iac_manager::forward_ctl_message
2017-01-26 12:46:01 avsql Error <12758>: [<Cluster-Client-name>] is unable to forward CTL sub-workorder to [<SQL-SRV-name\instance-name>].
2017/01/26-11:46:01.41899 [avsql_assist]  ===> avsql_iac_manager::update_client_status
2017-01-26 12:46:01 avsql Info <17370>: Remote client: <SQL-SRV-name\instance-name> (10.x.x.22), Status: FAILED
From remote client avagent log we don't see any sub-workorder as the IP in question (10.x.x.22) cannot be contacted from backup IP of AlwaysON listener (10.x.x.81):
initiator_agent_ip="10.x.x.81"
remote_agent_ip="10.x.x.22"

 

Cause

デュアルホームのAlwaysON SQLクラスター環境の場合、SQLノードの完全修飾ドメイン名(FQDN)は本番ネットワークからのIPアドレスに解決されます。このネットワークは、バックアップ ネットワークにアクセスできません。

 

この問題は、マルチNIC環境、または異なるvLANが関係する環境で発生する可能性があります。

 

Resolution

恒久的な解決策:
Avamar Serverをにアップグレードします。

  • 19.7.100-82以降
  • この修正は、Avamar 19.7以降のソフトウェア リリースに組み込まれています。
    • AlwaysON共有VARのavsql.cmdファイルの新しいフラグ:
      • --clusternode=<SQL_node_name>(<IP_ADDRESS>)

 

Affected Products

Avamar

Products

Avamar, Avamar Client, Avamar Plug-in for SQL
Article Properties
Article Number: 000070983
Article Type: Solution
Last Modified: 11 Jun 2024
Version:  6
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