Avamar: Impossibile sfogliare il file system del client NDMP durante la creazione di un dataset
Summary: Avamar non è in grado di sfogliare il file system client NDMP [Network Data Management Protocol].
Symptoms
Errore di visualizzazione del file system del client NDMP
Quando si crea un dataset e si accede al file system di un client NDMP, viene visualizzato un messaggio di errore dopo aver inserito le credenziali corrette.
Il messaggio di errore è: Browse Timeout. Il client non è stato in grado di completare la richiesta di esplorazione entro il limite di 10 secondi assegnato.
- L'errore può essere causato da una struttura di directory con un numero insolitamente elevato di sottoelementi.
- Può anche essere causato da una capacità della CPU disponibile insolitamente bassa nel client.
Se si clicca su Retry, viene restituito lo stesso errore di timeout.
Le condizioni degne di nota includono:
- La CPU sul client NAS non è sotto carico.
- La directory non dispone di molti file o sottodirectory.
- Diverse policy client configurate su questo accelerator node NDMP possono essere visualizzate senza alcun problema.
Cause
Root cause del problema
Per impostazione predefinita, il firewall Avamar sull'utility node consente la connessione all'accelerator node solo sulle porte da 28001 a 28011.
Se sull'accelerator node sono presenti processi avagent che utilizzano porte superiori a 28011, vengono bloccati dal firewall dell'utility node.
ps -eaf | grep avagent
Questo blocco è la root cause del problema, in quanto impedisce al client di completare la richiesta di ricerca entro il limite di tempo assegnato.
Resolution
Esistono diversi modi per aggiornare avfirewall.
Il modo preferito e consigliato è quello di utilizzare lo strumento goav.
Come ottenere lo strumento Goav.
Avamar: Strumento prodotto GoAV per la gestione e la risoluzione dei problemi
Come utilizzare Goav per configurare il firewall NDMP.
Avamar: Come utilizzare il menu
Goav Network Data Management Protocol FirewallIl modo seguente è il modo originale.
Lo svantaggio è che al momento dell'aggiornamento le modifiche non vengono mantenute.
Eventuali modifiche devono essere apportate nuovamente.
- Determinare quali porte utilizzano i processi avagent sull'accelerator node:
ps -eaf | grep avagent
- Nell'utility node eseguire un backup del file delle regole del firewall corrente:
sudo cp -p /etc/firewall.base /etc/firewall.base.<date>
- Aprire firewall.base per la modifica:
sudo vi /etc/firewall.base
- Modificare la riga seguente (ciò consente ad avagent di utilizzare fino alla porta 28051):
exec_rule -A OUTPUT -p tcp --dport 28001:28011 -j ACCEPT
exec_rule -A OUTPUT -p tcp --dport 28001:28051 -j ACCEPT
- Salvare e chiudere il file.
- Riavviare il firewall sull'utility node:
sudo service avfirewall restart
- Registrare nuovamente i client sull'accelerator node:
sudo avregister
- Assicurarsi che tutti siano stati registrati correttamente, quindi testare l'esplorazione del file system.