Avamar: Kan ikke bla gjennom NDMP-klientfilsystemet når du oppretter et datasett

Summary: Avamar kan ikke bla gjennom NDMP-klientfilsystemet [Network Data Management Protocol].

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 Feil ved NDMP-klientfilsystem

Når du oppretter et datasett og blar inn i filsystemet til en NDMP-klient, vises en feilmelding etter at du har angitt riktig legitimasjon.

Feilmeldingen lyder: Bla gjennom tidsavbrudd. Klienten var ikke i stand til å fullføre denne søkeforespørselen innenfor den tildelte grensen på 10 sekunder.

  • Feilen kan skyldes en katalogstruktur med et uvanlig stort antall underelementer.
  • Det kan også skyldes en uvanlig lav tilgjengelig CPU-kapasitet på klienten.

Hvis du klikker Prøv på nytt, får du samme tidsavbruddsfeil.

Bemerkelsesverdige forhold inkluderer:

  • CPU-en på NAS-klienten er ikke under belastning.
  • Katalogen har ikke mange filer eller underkataloger.
  • Flere klientpolicyer som er konfigurert på denne NDMP-akseleratornoden, kan bla gjennom uten problemer.

Cause

Rotårsaken til problemet

Avamar-brannmuren på verktøynoden tillater som standard bare tilkobling til akseleratornoden på portene 28001–28011.

Hvis det finnes avagensprosesser på akseleratornoden som bruker porter over 28011, blokkeres de av verktøynodens brannmur.

ps -eaf | grep avagent
 

Denne blokkeringen er årsaken til problemet, da det forhindrer klienten i å fullføre nettleserforespørselen innen den tildelte tidsfristen.

Resolution

Det er flere måter å oppdatere avbrannmuren på.
Den foretrukne og anbefalte måten er å bruke goav-verktøyet.

Hvordan få Goav-verktøyet.   
Avamar: GoAV-produktverktøy for administrasjon og feilsøking

Hvordan bruke Goav til å konfigurere NDMP-brannmuren.
Avamar: Slik bruker du Goav Network Data Management Protocol brannmurmeny

Følgende måte er den opprinnelige måten.
Ulempen er at endringene ikke beholdes ved oppgradering.
Eventuelle endringer må gjøres på nytt.
 

  1. Fastslå hvilke porter avagensprosessene bruker på akseleratornoden: 
ps -eaf | grep avagent

 

  1. Lag en sikkerhetskopi av gjeldende brannmurregelfil på verktøynoden:
sudo cp -p /etc/firewall.base /etc/firewall.base.<date>

 

  1. Åpne firewall.base for redigering:
sudo vi /etc/firewall.base

 

  1. Endre følgende linje (dette tillater avagent å bruke opp til port 28051):
Fra:
exec_rule -A OUTPUT -p tcp --dport 28001:28011 -j ACCEPT
 
til:
exec_rule -A OUTPUT -p tcp --dport 28001:28051 -j ACCEPT
 
  1. Lagre og avslutt filen.
  2. Start brannmuren på nytt på verktøynoden:
sudo service avfirewall restart

 

  1. Registrer klienter på nytt på akseleratornoden:
sudo avregister

 

  1. Forsikre deg om at alle ble registrert, og test deretter surfing på filsystemet. 

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000054146
Article Type: Solution
Last Modified: 27 Aug 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.