Avamar: Nie można przeglądać systemu plików klienta NDMP podczas tworzenia zestawu danych

Summary: Avamar nie może przeglądać systemu plików klienta NDMP (Network Data Management Protocol).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

 Błąd przeglądania systemu plików klienta NDMP

Podczas tworzenia zestawu danych i przeglądania systemu plików klienta NDMP po wprowadzeniu prawidłowych poświadczeń pojawia się komunikat o błędzie.

Komunikat o błędzie brzmi: Limit czasu przeglądania. Klient nie mógł ukończyć tego żądania przeglądania w wyznaczonym limicie 10 sekund.

  • Błąd może być spowodowany przez strukturę katalogów z niezwykle dużą liczbą podelementów.
  • Może to być również spowodowane niezwykle małą dostępną pojemnością procesora u klienta.

Kliknięcie przycisku Ponów próbę powoduje wyświetlenie tego samego błędu przekroczenia limitu czasu.

Godne uwagi warunki obejmują:

  • Procesor klienta NAS nie jest obciążony.
  • Katalog nie zawiera wielu plików ani podkatalogów.
  • Kilka zasad klienta skonfigurowanych w tym węźle przyśpieszającym NDMP może przeglądać bez żadnego problemu.

Cause

Główna przyczyna problemu

Zapora Avamar w węźle mediów domyślnie zezwala na połączenie z węzłem przyśpieszającym tylko na portach 28001–28011.

Jeśli w węźle przyśpieszającym znajdują się procesy avagent, które używają portów powyżej 28011, są one blokowane przez zaporę węzła narzędzia.

ps -eaf | grep avagent
 

Ta blokada jest główną przyczyną problemu, ponieważ uniemożliwia klientowi ukończenie żądania przeglądania w wyznaczonym limicie czasu.

Resolution

Istnieje kilka sposobów aktualizacji avfirewall.
Preferowanym i zalecanym sposobem jest użycie narzędzia goav.

Jak zdobyć narzędzie Goav.   
Avamar: Narzędzie GoAV do zarządzania i rozwiązywania problemów

Jak używać Goav do konfigurowania zapory NDMP.
Avamar: Jak korzystać z menu

zapory sieciowej protokołu zarządzania danymi GoavPoniższy sposób jest oryginalnym sposobem.
Wadą jest to, że po aktualizacji zmiany nie są zachowywane.
Wszelkie zmiany należy wprowadzić ponownie.
 

  1. Określ porty używane przez procesy avagent w węźle przyśpieszającym: 
ps -eaf | grep avagent

 

  1. W węźle mediów utwórz kopię zapasową bieżącego pliku reguły zapory:
sudo cp -p /etc/firewall.base /etc/firewall.base.<date>

 

  1. Otwórz firewall.base do edycji:
sudo vi /etc/firewall.base

 

  1. Zmień następujący wiersz (umożliwia to avagent użycie do portu 28051):
From:
exec_rule -A OUTPUT -p tcp --dport 28001:28011 -j ACCEPT
 
Do:
exec_rule -A OUTPUT -p tcp --dport 28001:28051 -j ACCEPT
 
  1. Zapisz i zamknij plik.
  2. Uruchom ponownie zaporę sieciową w węźle mediów:
sudo service avfirewall restart

 

  1. Ponownie zarejestruj klientów w węźle przyśpieszającym:
sudo avregister

 

  1. Upewnij się, że wszystkie zostały pomyślnie zarejestrowane, a następnie przetestuj przeglądanie systemu plików. 

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000054146
Article Type: Solution
Last Modified: 27 Aug 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.