Data Domain: Disco sconosciuto
Summary: Questo articolo spiega perché un disco può essere visualizzato come "Unknown" in un sistema Data Domain e fornisce la procedura per identificare e risolvere il problema.
Symptoms
Un disco visualizza lo stato "Unknown" in DD-CLI, DDSM o DDMC.
Il problema riguarda uno dei seguenti scenari:
- Un singolo disco nel controller (unità principale) o storage collegato
- Tutti i dischi in un enclosure appena aggiunto
- Un disco sostituito di recente dopo un guasto
Cause
Un disco può essere segnalato come "Unknown" per uno dei seguenti motivi:
- Il sistema non ha ancora riconosciuto un disco appena installato.
- Un disco è inaffidabile o guasto e segnala uno stato sconosciuto.
- Un enclosure appena aggiunto non è stato integrato nella configurazione RAID.
- Un disco sostitutivo non è stato inizializzato o trasferito a uno stato attivo.
Resolution
Attenersi alla seguente procedura in base allo scenario:
-
Controllare il modello Data Domain
Importante: La colonna
disk unfailnon è supportato sui sistemi con architettura pool di storage (ad esempio, DD6400). L'esecuzione di questo comando su questi modelli genera un errore.-
Identificare il modello del sistema:
system show modelno -
Utilizzare la procedura corretta:
DD6400 (architettura pool di storage):
- Utilizzare il comando
storage add. - Fare riferimento a: Data Domain DD6400: Aggiunta di un disco sostitutivo su DD6400
Tutti gli altri modelli Data Domain (architettura DD-RAID tradizionale):
- Continuare con i passaggi seguenti (
disk rescan,disk unfail).
- Utilizzare il comando
-
-
Verifica dello stato del disco
- Utilizzare il comando
disk show statecomando per identificare lo stato del disco. Fare riferimento a Data Domain: Descrizioni dello stato del disco a titolo indicativo
- Utilizzare il comando
-
Il disco singolo restituisce "Unknown" (e NON è un nuovo disco sostitutivo)
- Controllare gli avvisi di sistema attivi (
alerts show current) e lo stato del disco (disk show state). Se il disco viene segnalato come guasto ed è in uno stato "Unknown", sostituirlo. - Se il disco "Unknown" è un disco appena installato (sostitutivo), vedere il passaggio 5.
- Controllare gli avvisi di sistema attivi (
-
Tutti i dischi in un nuovo enclosure segnalano "Unknown"
- Si tratta di un comportamento previsto per un alloggiamento appena aggiunto.
- Seguire la relativa Guida all hardware per aggiungere i dischi "sconosciuti" alla capacità di storage.
- Panoramica dei passaggi necessari per aggiungere uno scaffale:
- Applicazione delle licenze
- Aggiungere storage al tier corretto (attivo o cloud)
- Espansione del file system
- Panoramica dei passaggi necessari per aggiungere uno scaffale:
- Seguire la relativa Guida all hardware per aggiungere i dischi "sconosciuti" alla capacità di storage.
- Si tratta di un comportamento previsto per un alloggiamento appena aggiunto.
-
Un singolo disco riporta "Unknown" dopo la sostituzione
- Tentare una nuova scansione delle unità. Da DD-CLI (ssh), eseguire il comando
# disk rescan - Verifica dello stato dell'unità da DD-CLI
# disk show state- Se il disco è diventato "In-use" e l'avviso non è stato cancellato, cancellarlo manualmente utilizzando DD-CLI
# alerts clear alert-id <alert-id> - Se il disco rimane 'unknown', eseguire il comando #
disk unfail <encl.disc> commandper passare il disco a uno stato di riserva.
- Se il disco è diventato "In-use" e l'avviso non è stato cancellato, cancellarlo manualmente utilizzando DD-CLI
- Tentare una nuova scansione delle unità. Da DD-CLI (ssh), eseguire il comando
-
Necessitano di ulteriore assistenza
Contattare il fornitore di supporto a contratto e inviare una Service Request se il problema rimane irrisolto.
Additional Information
Best Practice: Due minuti di attesa durante la sostituzione del disco
- Quando si sostituisce fisicamente un unità disco, attendere almeno 2 minuti dopo aver rimosso il disco guasto prima di inserire il nuovo disco.
- Ciò consente al firmware del controller di annullare correttamente la registrazione dell'unità precedente, riducendo notevolmente la possibilità di un problema di hotplug in cui la nuova unità non viene riconosciuta correttamente (visualizzata come "sconosciuta").
Sequenza consigliata:
- Rimuovere il disco guasto dallo slot.
- Attendere due minuti.
- Inserire il nuovo disco sostitutivo.