Avamar: Os backups agendados não são iniciados enquanto os backups iniciados manualmente funcionam
Summary: Este artigo aborda um problema raro em que os backups agendados não iniciam, enquanto os backups iniciados manualmente funcionam sem problemas devido a um arquivo de hosts configurado incorretamente. ...
Symptoms
Os backups agendados não são executados.
O agendador de backup está em execução:
dpnctl status sched
Identity added: /home/admin/.ssh/admin_key (/home/admin/.ssh/admin_key)
dpnctl: INFO: Backup scheduler status: up.
Os backups iniciados manualmente foram concluídos com sucesso.
O log (/usr/local/avamar/var/mc/server_log/mcserver.log*) mostra o seguinte:
07/30-22:25:31.00645 [OtherMessageEventHandler#235] com.avamar.mc.security.AvmgrLoginModule.login
FINE: AvmgrLoginModule Product: MCS Remote client: customer.com.mx/127.0.0.1 Host address: /IPv6 address b%eth0 Host address: /10.xx.xx.11
07/30-22:25:31.00645 [OtherMessageEventHandler#235] com.avamar.mc.security.spring.MCSpringJaasSecurityModule.authenticateLoginPrincipal
SEVERE: Authentication failed: Login Failure: all modules ignored
org.springframework.security.authentication.AuthenticationServiceException: Login Failure: all modules ignored
at org.springframework.security.authentication.jaas.DefaultLoginExceptionResolver.resolveException(DefaultLoginExceptionResolver.java:33)
...
at java.lang.Thread.run(Unknown Source)
Caused by: javax.security.auth.login.LoginException: Login Failure: all modules ignored
at javax.security.auth.login.LoginContext.invoke(Unknown Source)
at javax.security.auth.login.LoginContext.access$000(Unknown Source)
...
Um teste de ping para o nome de domínio totalmente qualificado (FQDN) customer.com.mx recebeu uma resposta do endereço do host local 127.0.0.1.
Cause
A coluna localhost entrada no /etc/hosts O arquivo não foi configurado corretamente.
Resolution
1. Faça login como administrador.
2. Eleve para o privilégio root.
3. Analise o arquivo hosts:
cat /etc/hosts
127.0.0.1 customer.com.mx localhost
::1 customer.com.mx localhost
10.xx.xx.11 cusotmer.com.mx customer
Esse resultado mostra um arquivo de hosts configurado incorretamente.
A configuração correta para localhost em /etc/hosts é:
127.0.0.1 localhost
::1 localhost
4. Atualize e corrija o arquivo hosts.
5. Analise o arquivo hosts atualizado:
cat /etc/hosts
127.0.0.1 localhost
::1 localhost
10.xx.xx.11 cusotmer.com.mx customer
6. Reinicie o Management Console Server (MCS) por Avamar: Como reiniciar o Management Console Server
7. Monitore a grade e verifique se os backups agendados são executados.