Avamar: Proxy Deployment Manager-fejl – ugyldigt domæne

Summary: Proxy Deployment Manager mislykkes i registreringen med fejlen "kunne ikke registrere proxy: ugyldigt domæne"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Når du forsøger at implementere proxy af Proxy Deployment Manager, mislykkedes det altid med fejl kunne ikke registrere proxy: invalid domain 

Proxy Deployment Manager-grænseflade 

MCS-loggen viser, at Avamar Server allerede har denne klient
 
mcserver.log.43:FINE: Cl->MC 10.100.1.201:32876<client isclientos="0" type="init" ack="yes" fqhostname="usivnavmp001.sus.local" msgver="1" os_type="Linux" hostname="usivnavmp001.sus.lcal" client_type="VPROXY_GUEST" mcsaddr="10.100.1.200" uuid="4206c9d11fc2d8ef735d2c816c90712c" dpndomain="/" cid="0" version="7.4.101-58" secure-st-version="2"><DNSname>127.0.0.2</DNSame><DNSname>usivnavmp001.sus.local</DNSname><DNSname>usivnavmp001</DNSname><DNSname>10.100.1.201</DNSname></client>
mcserver.log.43:FINE: client connection called id indicates:10.100.1.201
mcserver.log.43:FINE: Paging will be disabled on client connecting from 10.100.1.201 because the client did not provide a paging address when connecting
mcserver.log.43:FINE: MC->Cl 10.100.1.201:32876 <message  errno="202" errdesc="Proxy client already exists as a client for image backup." msgver="5" ack="no" type="response" sync="fg"hfsaddr="10.100.1.200"  />

 

deploymanager.log in /usr/local/avamar/var/log/vcs shows the below error:
 

avagent.d Info: Stopping Avamar Client Agent (avagent)...
avagent.d Info: Client Agent stopped.
avagent Info <5008>: Logging to /usr/local/avamarclient/var/avagent.log
avagent Error <7531>: Unable to register /deab/proxy01.av.local with Administrator 192.167.191.29:28001
'Proxy client already exists as a client for image backup.' (202)
avagent.d Info: Client activation error.
avagent Info <5008>: Logging to /usr/local/avamarclient/var/avagent.log
avagent Info <5417>: daemonized as process id 14474
avagent.d Info: Client Agent started.

Cause

Problemet opstår af 2 grunde:

årsag 1:

På den berørte Avamar Server var der en regel, der var konfigureret til automatisk at føje VM'er til Avamar Server. Under proxyimplementering oprettes VM'en i vCenter og føjes automatisk til Avamar Server som regel før selvaktivering. Derfor er fejlen "Proxy client already exists as a client for image backup" blev logget af MCS, når proxy forsøger at registrere sig selv senere.

Årsag 2:

Der er en dynamisk beholder indstillet på Avamar, hvilket betyder, at enhver ny klient, der oprettes på vCenter, vil blive tilføjet under den og dermed blive tilføjet som en VM, der forårsager fejlen "Proxy client already exists as a client for image backup"

Eksempel på en container tilføjet som ESXi med proxy tilføjet under den som VM-sikkerhedskopieringsklient:

ESXi som beholder

a { text-decoration: none; color: #464feb; } tr th, tr td { border: 1px solid #e6e6e6; } tr th { background-color: #f5f5f5; }

Resolution

Af grund 1:

1. Åbn Avamar GUI, klik på Funktioner –> vælg Administrer regler
2. Kontrollér den konfigurerede regel, og sørg for, at den nye implementerede proxy ikke føjes til Avamar automatisk

Af årsag 2:

1. Åbn Avamar GUI, klik på fanen Politik -> vælg Klienter (udover grupper) fra venstre rude
2. Klik på containeren (ESXi i følgende eksempel), klik på Rediger, og find derefter flaget Dynamisk tilstand:

Skærmbilledet Rediger klient 

3. Fjern markeringen af Dynamisk tilstand, og kør proxyinstallationsmanageropgaven igen:

Skærmbilledet Rediger klient 

Bemærk: Hvis dynamisk tilstand er nødvendig, kan du aktivere den igen, og den anvendte proxy vil gå under containerklienterne, men vil fungere normalt og deaktivere den, når du implementerer en ny proxy

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000065122
Article Type: Solution
Last Modified: 14 Apr 2026
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.