Data Protection Advisor (DPA): DPA agenta se nepodařilo zaregistrovat na aplikační server s chybou exception.name_conflict

Summary: DPA agenta se nepodaří zaregistrovat na aplikační server s chybou exception.name_conflict

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Registrace nového nainstalovaného agenta DPA na aplikační server DPA se nezdařila. V rámci dpaagent. log signalizuje následující chyba, že registrace selhala kvůli konfliktům názvů:      
Chyba < >
< id > Exception.name_conflict </id >
< Zpráva > již existuje alias se stejným názvem. Zvolte jiný název </Message >
< položka Name = "typ" > alias </entry >
</Error >
Err 18330,18330 20210304:210609 agent. config – initAgentConfig (): Failed to register agent with the server. Čeká se na opakování...

Výše uvedená chyba však neposkytuje přesný název pro konflikt, a to i s nízkou úrovní ladění programu Agent.

Cause

Selhání registrace agenta je způsobeno konfliktem názvů, jak je uvedeno v protokolu dpaagent. Jakmile dojde k odstranění názvu hostitele, který způsobuje konflikt, je možné, že se agent úspěšně zaregistruje na aplikační server DPA.

Resolution

Název konfliktu nebyl nalezen v protokolu dpaagent, a to ani s nízkou úrovní ladění povoleno, protože aplikační server DPA tyto informace sleduje. Chcete-li zjistit název konfliktu a vyřešit problém, postupujte podle následujících kroků:      
  1. Přihlaste se k aplikačnímu serveru DPA a přejděte na server. log v části < DPA Install dir >/Services/Logs/.
  2. V nástroji Server. log vyhledejte položku "uzel již nalezen". Mělo by se zobrazit něco podobného jako v:      
2021-03-05 09:54: Chyba 53114 [com. EMC. Apollo. Command. Node. UpdateNodeCommandBean] (http-/0.0.0.0:9002-3) uzel se již našel pomocí New aliasu XXXXXX stávající název nodeElement: YYYYYY
09:54:53114 Error [org. JBoss. as. EJB3] (http-/0.0.0.0:9002-3) javax. EJB. EJBTransactionRolledbackException: Alias se stejným názvem již existuje. Zvolte jiný název (exception.name_conflict)
  1. Přejděte do DPA grafického rozhraní > Inventory > Library > Hosts a vyhledejte YYYYYY pro hostitele.
  2. Vyberte YYYYYY vlastnosti hostitele v části > aliasy a hledejte konflikt názvů XXXXXX.
  3. V případě problému si vytvořte kopii všech názvů aliasu.
  4. Vyberte možnost název zástupného názvu XXXXXX a klikněte na možnost Delete (odstranit).
  5. Klikněte na možnost Použít a poté na možnost OK.
  6. Restartujte agenta DPA, který se nepodařilo zaregistrovat, a měl by být schopen zaregistrovat se na DPA aplikační server.
Pokud se agent stále nedaří registrovat, prostudujte si aktualizovaný protokol agenta v podobě odlišné chyby nebo problému, k němuž se nyní může vstoupit. Je možné, že se může jednat o další chybu konfliktu názvů, kterou je třeba vyřešit pomocí výše uvedených kroků.

Další podrobnosti a informace vám sdělí tým technické podpory společnosti Dell EMC.

Affected Products

Data Protection Advisor
Article Properties
Article Number: 000183846
Article Type: Solution
Last Modified: 23 Jul 2021
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.