NetWorker : Les sauvegardes du client AIX échouent avec le message « not properly configured »

Summary: La sauvegarde du client NetWorker AIX avec pour se terminer avec un message d’erreur de configuration. NetWorker Management Console (NMC) affiche un nom d’hôte vide ou un caractère Unicode comme nom d’hôte. ...

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Symptoms

Le certificat NSRLA du client AIX affiche un nom vide ou un caractère Unicode «" (U+2592) pour le nom d’hôte dans /nsr/res/nsrladb.

Le journal de la session de sauvegarde affiche les éléments suivants :

DD/MM/YY HH:MM:SS lgto_parms failed: Client ' ' is not properly configured on the NetWorker Server
175297:save: Unable to set up the direct save with server '###.###.###': Client ' ' is not properly configured on the NetWorker Server
175024:save: Cannot open a save session with NetWorker server '###.###.###': Client ' ' is not properly configured on the NetWorker Server

Cause

Le client AIX /etc/hosts Il manque les détails locaux dans l’enregistrement de fichier ou un caractère Unicode invisible "" a ajouté. Le client AIX concerné utilise la commande /etc/hosts lors de la création du certificat de base de données NSRLADB et que l’entrée est à l’origine du problème.

Exemple d’entrée vide dans la base de données NSRLADB :

my-aixp8-1:/ # nsradmin -d /nsr/res/nsrladb
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> p nsrla
                        type: NSRLA;
               administrator: root, "user=root,host=";


Exemple de caractère Unicode dans la base de données NSRLADB :

my-aixp8-1:/ # nsradmin -d /nsr/res/nsrladb
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> p nsrla
                        type: NSRLA;
               administrator: root, "user=root,host=▒";

Resolution

Inclure le nom d’hôte et l’adresse IP du client AIX dans le fichier /etc/hosts pour remplir la base de données NSRLADB locale.

  1. Ouvrez une session SSH sur le client AIX.
  2. Effectuez une copie du fichier hosts existant : cp /etc/hosts /etc/hosts_orig
  3. Arrêtez les services NetWorker : nsr_shutdown
  4. Renommez le répertoire res NetWorker existant : mv /nsr/res /nsr/res_old
  5. Démarrez les services NetWorker : /etc/rs.nsr
  6. Validez le nom d’hôte dans la base de données NSRLADB en ligne : nsradmin -p nsrexec 
  7. Validez le nom d’hôte dans la base de données NSRLADB hors ligne : nsradmin -d /nsr/res/nsrladb
  8. Effacez les informations de l’homologue NSR sur NetWorker Server : NetWorker : Correction des informations d’homologue NSR incohérentes
  9. Exécutez une sauvegarde du client AIX concerné.

Additional Information

Si les dossiers /nsr/res, ou /nsr/res/nsrladb ne peut pas être renommé, procédez comme suit :

  1. Corrigez le nom dans le fichier nsrladb en tant que fichier texte pour l’appeler nsrladb_manually_fixed.
  2. Utilisez la commande nsradmin »-i" pour saisir et fusionner la base de données nsrladb :
# nsradmin -d /nsr/res/nsrladb -i /tmp/nsrladb_manually_fixed
  1. Arrêtez les services NetWorker : nsr_shutdown
  2. Démarrez les services NetWorker : /etc/rs.nsr

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000202546
Article Type: Solution
Last Modified: 15 May 2026
Version:  4
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