NetWorker: Falha nos backups do client AIX com a mensagem "não configurado corretamente"

Summary: O backup do client AIX do NetWorker com o para ser concluído com uma mensagem de erro de configuração. O NetWorker Management Console (NMC) mostra um hostname em branco ou o caractere Unicode como nome de host. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

O certificado NSRLA do cliente AIX mostra um nome em branco ou um caractere Unicode "" (U+2592) para o nome do host em /nsr/res/nsrladb.

O log da sessão de backup mostra:

DD/MM/YY HH:MM:SS lgto_parms failed: Client ' ' is not properly configured on the NetWorker Server
175297:save: Unable to set up the direct save with server '###.###.###': Client ' ' is not properly configured on the NetWorker Server
175024:save: Cannot open a save session with NetWorker server '###.###.###': Client ' ' is not properly configured on the NetWorker Server

Cause

O client AIX /etc/hosts registro de arquivo está faltando os detalhes locais ou um caractere Unicode invisível "", acrescentou. O client AIX afetado usa o /etc/hosts ao criar o certificado do banco de dados NSRLADB e a entrada está causando o problema.

Exemplo de entrada em branco no banco de dados do NSRLADB:

my-aixp8-1:/ # nsradmin -d /nsr/res/nsrladb
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> p nsrla
                        type: NSRLA;
               administrator: root, "user=root,host=";


Exemplo de caractere Unicode no banco de dados NSRLADB:

my-aixp8-1:/ # nsradmin -d /nsr/res/nsrladb
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> p nsrla
                        type: NSRLA;
               administrator: root, "user=root,host=▒";

Resolution

Inclua o hostname e o IP do client AIX no local /etc/hosts para preencher o banco de dados NSRLADB local.

  1. Abra uma sessão SSH para o client AIX.
  2. Faça uma cópia do arquivo de hosts existente: cp /etc/hosts /etc/hosts_orig
  3. Interrompa os serviços do NetWorker: nsr_shutdown
  4. Renomeie o diretório res existente do NetWorker: mv /nsr/res /nsr/res_old
  5. Inicie os serviços do NetWorker: /etc/rs.nsr
  6. Valide o nome do host no banco de dados NSRLADB on-line: nsradmin -p nsrexec 
  7. Valide o nome do host no banco de dados NSRLADB off-line: nsradmin -d /nsr/res/nsrladb
  8. Apague as informações de par do NSR sobre o servidor NetWorker: NetWorker: Corrigindo informações inconsistentes de pares do NSR
  9. Execute um backup do client AIX afetado.

Additional Information

Se as pastas /nsr/res, ou /nsr/res/nsrladb Não pode ser renomeado, execute o seguinte:

  1. Corrija o nome no campo nsrladb como arquivo de texto para chamá-lo nsrladb_manually_fixed.
  2. Use o comando nsradmin "-i" para inserir e mesclar o nsrladb:
# nsradmin -d /nsr/res/nsrladb -i /tmp/nsrladb_manually_fixed
  1. Interrompa os serviços do NetWorker: nsr_shutdown
  2. Inicie os serviços do NetWorker: /etc/rs.nsr

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000202546
Article Type: Solution
Last Modified: 15 May 2026
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.