VxRail: Nya VxRail-system saknar PSNT

Summary: PSNT-serienummer saknas på noder som levererades med VxRail-version 7.0.450 eller 8.0.100 vilket orsakar problem vid skapande av VxRail-kluster eller nodexpansion.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Det här problemet kan uppstå vid distribution av en ny nod eller när en ny nod läggs till där en PSNT som saknas på den nya värden orsakar distributionsfel.

 

Indikatorer på det här problemet kan vara något eller alla av följande:

 

  • PSNT saknas i DCUI
Skärmbild av konsolen som visar en PSNT som saknas.
  • Ett lokalt datastore-namn innehåller inte PSNT i sitt namn
  • PSNT "Chassis Extra" saknas i ipmitool-frågan

Om PSNT saknas visas det ungefär som i utdata nedan, där ingen "Chassis Extra"-rad med PSNT visas:

[root@node-01:~] /opt/vxrail/tools/ipmitool fru print 17
 Chassis Type          : Rack Mount Chassis
 Chassis Part Number   : VxRail V670F
 Chassis Serial        : XXXXXXX

Utdata saknar en rad som liknar den nedan.

[root@node-01:~] /opt/vxrail/tools/ipmitool fru print 17 
Chassis Type           : Rack Mount Chassis 
Chassis Part Number    : VxRail V670F 
Chassis Serial         : XXXXXXX
Chassis Extra          : DEXXXXXXXXXXXX

 

Obs!  AMD-baserade system har två "Chassis Extra"-rader. Problemet uppstår bara när PSNT saknas.

AMD-system med problemet ser ut ungefär som nedan.

[root@node-01:~] /opt/vxrail/tools/ipmitool fru print 17
 Chassis Type          : Rack Mount Chassis
 Chassis Part Number   : VxRail V670F
 Chassis Serial        : Diskgroup:8-SLOT,2-DG,1-Cache,3-Capacity

Giltiga utdata för AMD-plattformar ser ut ungefär som nedan.

[root@node-01:~] /opt/vxrail/tools/ipmitool fru print 17 
Chassis Type           : Rack Mount Chassis 
Chassis Part Number    : VxRail V670F 
Chassis Serial         : XXXXXXX
Chassis Extra          : DEXXXXXXXXXXXX
Chassis Extra          : Diskgroup:8-SLOT,2-DG,1-Cache,3-Capacity


Obs! Problemet gäller inte ogiltiga Service Tag-nummer eller saknade PSNT-nummer för VxRail VD-4000w-vittnesnoder.

Cause

Det beror på att ett VxRail-system levereras utan PSNT från fabriken.

Resolution

Dell Engineering har utvecklat ett verktyg för att lösa det här specifika problemet med saknad PSNT.

Lös problemet med saknad PSNT genom att ladda ner VxRail FRU17 Recovery Utility (bilaga, FRU17RecoveryTool_v1.0_csp.iso) och följa stegen nedan.  


Obs! Leta reda på och kopiera PSNT från systemets fysiska bagagetagg innan du fortsätter.

 

Steg 1

Montera och starta FRU17RecoveryTool.

  1. Öppna nodens virtuella konsol.
  2. Välj Virtuell media.
  3. Välj Anslut virtuell media.
  4. Välj Arkiv > FRU17RecoveryTool_vx.x_csp.iso.
  5. Karta enhet.

Skärmbild som visar den mappade enheten i konsolalternativen.

  1. Välj Stäng
  2. Välj virtuell CD/DVD/ISO FÖR START >

Skärmbild av nästa startuppsättning på virtuell cd/dvd/iso.

  1. Starta om systemet.


Använda återställningsverktyget FRU17

  1. Huvudmeny

Skärmbild av den första startskärmen när återställningsverktyget startas.

  1. Välj "G" och tryck på Enter

Skärmbild som visar hur du anger alternativ G vid prompten

  1. Välj "Y" och tryck på Enter

Skärmbild som visar hur du anger Y för att fortsätta.

  1. Välj "Y" för att automatiskt läsa in FRU17 efter att informationen har matats in i följande steg och tryck på Enter.

Skärmbild som visar hur man väljer Y för att automatiskt läsa in FRU17 efter generering.

  1. Ange {PSNT}-värdet för ett specifikt system. Fjorton tecken långt PSNT-värde finns på bagagetaggen. Tryck på retur när du har bekräftat att det angivna PSNT-värdet är korrekt. Obs! PSNT [] är tomt om PSNT inte finns på FRU17. Om ett värde rapporteras finns det redan ett PSNT-värde programmerat i FRU17. 

Skärmbild som visar PSNT-uppmaningen.

  1. Bekräfta {service tag} och tryck på Retur Obs! Service tag-numret läses automatiskt från system-BIOS. Ange det inte om det är korrekt, lämna det tomt och tryck på Enter

Skärmbild som visar service tag-alternativet. Om den visade taggen är korrekt behöver du inte ange den.

  1. FRU17 installeras automatiskt.  Utdata visar att det tidigare innehållet i FRU17 är inramat i gult nedan och det nyskrivna FRU17-innehållet är inramat i grönt nedanför.

Skärmdump som visar verktygets utdata med huvudavsnitten i rutor.

  1. Bekräfta att data är korrekta, om inte, tryck på Enter till huvudmenyn och upprepa steg 2-7.  Om uppgifterna är korrekta, tryck på Enter för att återgå till huvudmenyn, tryck på Q och tryck på Enter och bekräfta för att starta om systemet.

Skärmbild som visar hur man avslutar menyn och startar om systemet.

Steg 2

Åtgärda DCUI så att PSNT visas.

 

esxcli system welcomemsg get > /tmp/welcome.txt
vi /tmp/welcome.txt
  1. Lägg till rätt PSNT och spara filen
esxcli system welcomemsg set -m "$(cat /tmp/welcome.txt)"

Steg 3

Byt namn på datalagret så att det inkluderar PSNT

1. När klustret har skapats eller noderna har lagts till i ett kluster loggar du in på vCenter-användargränssnittet för att byta namn på det lokala datalagret:Skärmbild som visar värd-/klustervyn i vSphere efter inloggning. 
2. Klicka på noden och klicka sedan på Datalager:

Skärmbild som visar den valda noden och fliken datalager. 3. Högerklicka på det lokala datalagret, välj alternativet Byt namn och skriv det nya datalagernamnet:

Skärmbild som visar alternativ och format för byte av namn på datalagret. Ange psnt där X:en finns. 


Upprepa ovanstående process för alla andra noder som saknar ett PSNT.

 

Additional Information

Konfigurationer som PSNT, service tag-nummer, värdnamn och så vidare är exempel från labbmiljöer och bör inte användas. 

FRU17RecoveryTool_v1.0 MD5: eea49f5b0f50b53107afd39c94d7dbdf 

Affected Products

VxRail E660, VxRail E660F, VxRail E660N, VxRail E665, VxRail E665F, VxRail E665N, VxRail P670F, VxRail P670N, VxRail P675F, VxRail P675N, VxRail S670, VXRAIL V670F
Article Properties
Article Number: 000218616
Article Type: Solution
Last Modified: 24 Jan 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.