RecoverPoint: Image Access Fails When Accessing Older Images Without Pausing the CG

Summary: RecoverPoint and RecoverPoint for VMs: Attempting to access (Logged Access) older images may fail with one or more errors: "Requested snapshot is no longer available" or "Cannot enable image access to the specified image." ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

"Test a Copy" (Also known as Image Access) operation for an old image may fail.

The following events may show in the CLI or UI event logs: 

  Time:                 Thu Jan 11 13:23:21 2024
  Topic:                GROUP
  Scope:                DETAILED
  Level:                ERROR
  Event ID:             4003
  Cluster:              DR
  Global links:         None
  Groups:               [CG_NAME]
  Summary:              Group capabilities problem
  Details:              Copies are not linked - side defined as target.

RPA1:
Cluster Member = Yes
Journal (GlobalCopy(SiteUID(0x53760a1e65f116d9) 0) ) = PARTIAL - requested snapshot is no longer available. Site=DR.

Or

  Time:                 Thu Jan 11 13:32:51 2024
  Topic:                RPA
  Scope:                NORMAL
  Level:                ERROR
  Event ID:             12013
  Cluster:              DR
  Global links:         None
  Groups:               [CG_NAME]
  Summary:              Cannot enable image access
  More information:     Cannot enable image access to the specified image.

Cause

During Image Access operation, RecoverPoint pauses distribution of images, meaning new images are not written to the target device and remain in Journal lag (DO stream).

While the Consistency Group (CG) remains active, the DO stream in the target journal is still receiving new I/Os, and must create new images.

RecoverPoint tries to allow replication to continue while the user is testing images.

As RecoverPoint tries to find the old image that is being requested (Operation called "Enabling Image Access"), the new images require space that force RecoverPoint to delete old images, and the requested image may be lost.

Resolution

Dell engineering is investigating this issue. A permanent fix is still in progress. Contact Dell Support or your service representative for assistance and reference this solution ID.

Workaround:
For operations that require accessing the oldest images of the Journal, pausing the CG is recommended as it prevents new images and any rolling of the data.

Affected Products

RecoverPoint
Article Properties
Article Number: 000221514
Article Type: Solution
Last Modified: 14 Mar 2024
Version:  3
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