Connectrix MDS: Unable to SSH to Switch

Summary: Unable to SSH to switch

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Unable to SSH to the MDS switch, receive the following error:

"Remote Side unexpectedly closed network connection"

SSH from working switch to nonworking switch produces the following error:

"SSH_exchange_identification:read: Connection reset by peer"

Cause

Possible stuck SSH process

Resolution

Workaround:
  1. Remove and reenabling SSH to restart SSH services and recover connectivity.
  2. Connect to console port, run the following:
Disable SSH:
conf t
no feature ssh  (wait a few mins)

Re-enable SSH:
conf t
feature ssh
  1. Verify SSH connectivity to Mgmt0 over network or PuTTY.

If it is still failing to connect SSH, it may be necessary to remove and re-create RSA key.
  1. Connect to console port and run the following:
config t
no feature ssh
no ssh key rsa 1024    <-- wait a few minutes

Re-enable SSH:
config ssh key rsa 1024
feature ssh

Affected Products

Connectrix MDS-9132T

Products

Connectrix MDS-9132T
Article Properties
Article Number: 000055655
Article Type: Solution
Last Modified: 23 Oct 2025
Version:  5
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