NetWorker: nsr-Befehle schlagen fehl, wenn sie als Root- oder Administrator-Eingabeaufforderung protokolliert werden.

Summary: nsr-Befehle schlagen fehl, während sie als Root angemeldet sind oder wenn nsr-Befehle über eine Administrator-Eingabeaufforderung ausgeführt werden.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

nsr-Befehle schlagen fehl, während sie als Root angemeldet sind oder wenn nsr-Befehle über eine Administrator-Eingabeaufforderung ausgeführt werden.
nsr-Befehle nach der Anmeldung mit nsrlogin funktionieren einwandfrei.

Zum Beispiel:

nsraddadmin -H <authc server> -P 9090
134747:nsraddadmin: Bad resource file.

nsraddadmin -H <NetWorker server> -P 9090
88924:nsraddadmin: Cannot connect to resource database: Unable to set user privileges based on user token for root on <NetWorker server>: Failed to validate security token.

root> nsraddadmin -u <user@NetWorker server>
nsraddadmin: Cannot connect to resource database: Unable to set user privileges based on user token for root on <NetWorker server>: Failed to validate security token.

Cause

Dies kann dadurch verursacht werden, dass ein Nutzer nsrlogin zuvor ohne Ausführung von nsrlogout ausgegeben hat. Veraltete Token aus der vorherigen nsrlogin-Sitzung sind in /nsr/tmp/sec/tokens auf dem NetWorker-Server vorhanden.

Resolution

Führen Sie nsrlogout aus, um die Token zu löschen. Wenn Token vorhanden sind, verschieben Sie die Dateien entweder aus /nsr/tmp/sec/tokens in ein anderes Verzeichnis (z. B. /tmp) oder löschen Sie die Dateien.

 

Ein Neustart des NetWorker-Servers/der Services ist nicht erforderlich.

 

Führen Sie nach der Verwendung von nsrlogin für NetWorker-Aufgaben nsrlogout aus, wenn Sie fertig sind. Beim Ausführen von NetWorker-Befehlen als Root oder über eine Administratoraufforderung ist nsrlogin unnötig.

Affected Products

NetWorker Family, NetWorker
Article Properties
Article Number: 000224499
Article Type: Solution
Last Modified: 10 Oct 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.