NetWorker: los comandos nsr fallan cuando se registran como raíz o símbolo del sistema de administrador.

Summary: Los comandos nsr fallan mientras se registran como root o cuando se ejecutan comandos nsr desde un símbolo del sistema de administrador.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Los comandos nsr fallan mientras se registran como root o cuando se ejecutan comandos nsr desde un símbolo del sistema de administrador.
Los comandos nsr después de iniciar sesión con nsrlogin funcionan bien.

Por ejemplo:

nsraddadmin -H <authc server> -P 9090
134747:nsraddadmin: Bad resource file.

nsraddadmin -H <NetWorker server> -P 9090
88924:nsraddadmin: Cannot connect to resource database: Unable to set user privileges based on user token for root on <NetWorker server>: Failed to validate security token.

root> nsraddadmin -u <user@NetWorker server>
nsraddadmin: Cannot connect to resource database: Unable to set user privileges based on user token for root on <NetWorker server>: Failed to validate security token.

Cause

Esto puede deberse a que un usuario emitió nsrlogin anteriormente sin ejecutar nsrlogout. Los tokens obsoletos de la sesión nsrlogin anterior están presentes en /nsr/tmp/sec/tokens en NetWorker Server.

Resolution

Ejecute nsrlogout para borrar los tokens. Si quedan tokens, mueva los archivos de /nsr/tmp/sec/tokens a otro directorio (por ejemplo, /tmp) o elimínelos.

 

No es necesario reiniciar NetWorker Server/Services.

 

Después de usar nsrlogin para las tareas de NetWorker, ejecute nsrlogout cuando haya terminado. Cuando se ejecutan comandos de NetWorker como raíz o desde un símbolo del sistema del administrador, nsrlogin no es necesario.

Affected Products

NetWorker Family, NetWorker
Article Properties
Article Number: 000224499
Article Type: Solution
Last Modified: 10 Oct 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.