NetWorker: nsr-команди завершуються помилкою, якщо вони зареєстровані як root або командний рядок адміністратора.

Summary: Команди nsr завершуються помилкою, якщо їх зареєстровано як користувач root, або під час виконання команд nsr із командного рядка адміністратора.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Команди nsr завершуються помилкою, якщо їх зареєстровано як користувач root, або під час виконання команд nsr із командного рядка адміністратора.
Команди NSR після входу в систему за допомогою NSRLOGIN працюють нормально.

Наприклад:

nsraddadmin -H <authc server> -P 9090
134747:nsraddadmin: Bad resource file.

nsraddadmin -H <NetWorker server> -P 9090
88924:nsraddadmin: Cannot connect to resource database: Unable to set user privileges based on user token for root on <NetWorker server>: Failed to validate security token.

root> nsraddadmin -u <user@NetWorker server>
nsraddadmin: Cannot connect to resource database: Unable to set user privileges based on user token for root on <NetWorker server>: Failed to validate security token.

Cause

Це може бути спричинено тим, що користувач раніше випустив nsrlogin без запуску nsrlogout. Застарілі токени з попередньої сесії nsrlogin присутні в /nsr/tmp/sec/tokens на сервері NetWorker.

Resolution

Запустіть nsrlogout , щоб очистити токени. Якщо залишилися якісь токени, або перемістіть файли з /nsr/tmp/sec/tokens в іншу директорію (наприклад, /tmp), або видаліть файли.

 

Перезавантаження сервера/служб NetWorker не потрібне.

 

Після використання nsrlogin для завдань NetWorker запустіть nsrlogout , коли ви закінчите. При виконанні команд NetWorker від імені root або з рядка адміністратора, nsrlogin не потрібен.

Affected Products

NetWorker Family, NetWorker
Article Properties
Article Number: 000224499
Article Type: Solution
Last Modified: 10 Oct 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.