PowerProtect: IDPA: No Boot Device Available or Operating System Not Detected and Booting from Hard Drive C: Errors on IDPA 13G and 14G Systems

Summary: This knowledge article addresses the issue where the system stops responding during boot-up with the message "Booting from Hard drive C:", and no boot device or operating system is detected. This article focuses on the causes related to incorrect boot order and BIOS UEFI settings issues. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Errors you can get:

The system stops responding at "Booting from Hard drive C:"

No boot device available or Operating System detected


Boot error screen  

Cause

The issue of the system stopping at "Booting from Hard drive C:", with no boot device or operating system detected, can be attributed to the following causes:

Incorrect Boot Order: The BIOS or UEFI firmware might be configured to boot from an incorrect device instead of the hard drive where the operating system is installed.
BIOS or UEFI Settings Issue: There could be an issue with BIOS or UEFI settings, such as Secure Boot settings preventing the system from recognizing the bootable media correctly.
These issues can arise due to various factors, including incorrect configuration, system updates, or external factors that disrupt the boot processes. Sometimes, the operating system itself may be corrupted, making it unable to boot properly.

In this scenario, we focus on the Incorrect Boot Order and BIOS/UEFI Settings Issue. 

 
NOTE: Unless a reimage is required, the system should not be changed from UEFI boot mode to BIOS boot mode.

Resolution

WARNING: Ensure to maintain a backup of any critical data before applying changes to the system.
WARNING: Consult with support if you are not familiar with changing BIOS UEFI settings.
NOTE: There are no effects by changing to BIOS boot mode, as we are not doing a secure boot.

Process for 14G systems

Press "F2" to enter the System Setup (BIOS) menu.

system_setup 

Select "System BIOS" to enter the "System BIOS" menu.

boot_settings 

Select "Boot Settings" to enter the "Boot Settings" menu.

uefi_boot_mode_highlighted 

Select either "UEFI Boot Settings" or "BIOS Boot Settings" (If BIOS Boot Mode is enabled) to edit the boot device sequence.
 

UEFI Boot Settings Sequence.


uefi_boot_settings_correct 
 

Steps for Configuring UEFI Boot Mode:

  1. Enable UEFI Boot Mode:

    • From the "UEFI Boot Settings" sub-menu, ensure that UEFI Boot Mode is enabled.
  2. Verify UEFI Boot Sequence:

    • Ensure that "[AHCI Controller…]" is the first item in the "UEFI Boot Sequence" list.
    • Confirm that it is enabled under the "Boot Option Enable Disable" menu.
  3. Modify the Order of Lists (if needed):

    • Use the keyboard or console arrow keys to select the wanted list.
    • Press "Enter" to select the list.
  4. Adjust Item Positions:

    • Use the "-" key to move an item down in the list.
    • Use the "Shift+" key to move an item up in the list.
  5. Confirm Changes:

    • Press "Enter" to save and confirm any changes.

Press "Esc" to exit and save the configuration. Press "Esc" again to return to the System Setup (BIOS) menu. Confirm again to initiate reboot. The system should boot into ESXi.
 

BIOS Boot Settings Sequence.


bios_boot_settings_correct_with_nic_disabled 
 

Steps for Configuring BIOS Boot Mode:

  1. Enable BIOS Boot Mode:

    • From the "BIOS Boot Settings" sub-menu, ensure that BIOS Boot Mode is enabled.
  2. Verify Boot Sequence:

    • Ensure that "[Hard drive C:]" is the first item in the "Boot Sequence" list.
    • Confirm that it is enabled under the "Boot Option Enable Disable" menu.
  3. Check Hard-Disk Drive Sequence:

    • Ensure "[AHCI Controller…]" is listed as the first item under the "Hard-Disk Drive Sequence" list.
  4. Modify the Order of Lists (if needed):

    • Use the keyboard or console arrow keys to select the wanted list.
    • Press "Enter" to select the list.
  5. Adjust Item Positions:

    • Use the "-" key to move an item down in the list.
    • Use the "Shift+" key to move an item up in the list.
  6. Confirm Changes:

    • Press "Enter" to save and confirm any changes.

Press "Esc" to exit and save the configuration. Press "Esc" again to return to the System Setup (BIOS) menu. Confirm again to initiate reboot. The system should boot into ESXi.


Process for 13G systems

NOTE: This process is similar, but the OS is on the Internal SD (IDSDM).


The boot configuration and sequence should be the same as the below capture.

Ensure "[Integrated RAID…]" is listed as the first item under the "Hard-Disk Drive Sequence" list and the second "[Internal SD: IDSDM…]"

 The boot configuration 

For more information about 13G systems, see 000181982.

Affected Products

PowerProtect DP4400, PowerProtect DP5300, PowerProtect DP5800, PowerProtect DP8300, PowerProtect DP8800, PowerProtect Data Protection Hardware, PowerProtect DP5900, PowerProtect DP8400, PowerProtect DP8900
Article Properties
Article Number: 000228550
Article Type: Solution
Last Modified: 27 Mar 2025
Version:  4
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