Connectrix MDS: OnPrem Network Sync mislykkes "Fejl ved kontrol af tokenudløb-400 dårlig anmodning"

Summary: OnPrem Network-synkronisering mislykkes med "Fejl ved kontrol af Token Expiration-400 Bad Request"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SSM OnPrem-serverversion:  9-202507

OnPrem Network eller planlagt synkronisering mislykkes med fejl:

"Error When Checking for Token Expiration 784: unexpected token at '<html> <head><title>400 Bad Request<title><head> <body> <center>
400 Bad Request
<center> <hr><center>nginx/1.29.1<center> <body> <html> '"

Fejlmeddelelse på skærmen

Cause

Dette skyldes migrering af identitetsudbyder (IDP) fra Ping til Okta. 

Da de eksisterende tokens udstedes af IDP Ping, er disse tokens ikke gyldige i Okta-tjenesten, hvilket får synkroniseringen til at mislykkes. Hvis der oprettes nogen OnPrem-konti efter denne migrering, udsteder Okta tokens, og dette problem ses ikke. 

Dette er ikke et problem på OnPrem. Denne migrering til Okta påvirker alle OnPrem-servere. 

Resolution

Kår:
OnPrem-synkronisering udføres med netværk eller planlagt, og databasen har adgangstokens før Ping til Okta-migreringen.

Cisco-problem-id: CSCwr45134

Løsning 1:

  1. Opret en ny OnPrem-konto
Log på portalen >OnPrem Admin Workspace Gå til widgetten Konti.
Opret en ny OnPrem-konto, og godkend anmodningen ved at angive dine legitimationsoplysninger. Denne handling genererer et nyt token med Okta (vores nye IDP), hvilket muliggør fortsat funktionalitet. Når kontooprettelsen er fuldført, skal du udføre en fuld netværkssynkronisering på de mislykkede konti.
Husk, at du ikke udfører nogen handling med denne konto, ingen enhedsoverførsel eller registrering til CSSM. Det er kun for at opdatere det interne token, som alle OnPrem-konti bruger til at tale med skyen.
  1. Manuel synkronisering:
Som et alternativ til netværkssynkronisering kan du udføre en manuel synkronisering, som kun løser problemet for en engangsløsning. Dette er ikke en permanent løsning.
  1. Ikke konsekvent, men afventer tokenudløb er en anden mulighed
Problemet forventes at løse sig automatisk efter nogle dage (28, 160, 180 osv.), når det gamle Ping-token, der er cachelagret i vores beholder, udløber. Du kan vælge at vente på denne automatiske løsning.

Løsning 2:
Anvend scriptet til oprydning af tokens (vedhæftet artiklen).

  • Tag et VM-snapshot , og sikkerhedskopier onprem-console database_backup før du anvender løsningen.
  • Overfør de vedhæftede filer under var/files/patches ved hjælp af WinSCP
  • Kør nedenstående kommando:
Upgrade patches: sync_issue_token_cleanup.sh
  • Kør en netværkssynkronisering med CCO-administratorlegitimationsoplysninger.
 
Bemærk: Hvis SSM OnPrem ikke synkroniseres mindst hver 9. time (f.eks. inden udløbet af 10 timer), efter anvendelse af scriptet, begynder synkroniseringen at mislykkes igen. I sådanne tilfælde er den eneste løsning at genanvende scriptet og fortsætte synkroniseringen hver 9. time eller mindre.

Additional Information

Affected Products

Connectrix MDS-9148T
Article Properties
Article Number: 000376216
Article Type: Solution
Last Modified: 06 Nov 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.