Connectrix MDS: OnPrem Network Sync mislykkes "Fejl ved kontrol af tokenudløb-400 dårlig anmodning"
Summary: OnPrem Network-synkronisering mislykkes med "Fejl ved kontrol af Token Expiration-400 Bad Request"
Symptoms
SSM OnPrem-serverversion: 9-202507
OnPrem Network eller planlagt synkronisering mislykkes med fejl:
"Error When Checking for Token Expiration 784: unexpected token at '<html> <head><title>400 Bad Request<title><head> <body> <center> 400 Bad Request <center> <hr><center>nginx/1.29.1<center> <body> <html> '"

Cause
Dette skyldes migrering af identitetsudbyder (IDP) fra Ping til Okta.
Da de eksisterende tokens udstedes af IDP Ping, er disse tokens ikke gyldige i Okta-tjenesten, hvilket får synkroniseringen til at mislykkes. Hvis der oprettes nogen OnPrem-konti efter denne migrering, udsteder Okta tokens, og dette problem ses ikke.
Dette er ikke et problem på OnPrem. Denne migrering til Okta påvirker alle OnPrem-servere.
Resolution
Kår:
OnPrem-synkronisering udføres med netværk eller planlagt, og databasen har adgangstokens før Ping til Okta-migreringen.
Cisco-problem-id: CSCwr45134
Løsning 1:
- Opret en ny OnPrem-konto
Opret en ny OnPrem-konto, og godkend anmodningen ved at angive dine legitimationsoplysninger. Denne handling genererer et nyt token med Okta (vores nye IDP), hvilket muliggør fortsat funktionalitet. Når kontooprettelsen er fuldført, skal du udføre en fuld netværkssynkronisering på de mislykkede konti.
- Manuel synkronisering:
- Ikke konsekvent, men afventer tokenudløb er en anden mulighed
Løsning 2:
Anvend scriptet til oprydning af tokens (vedhæftet artiklen).
- Tag et VM-snapshot , og sikkerhedskopier
onprem-console database_backupfør du anvender løsningen. - Overfør de vedhæftede filer under
var/files/patchesved hjælp af WinSCP - Kør nedenstående kommando:
Upgrade patches: sync_issue_token_cleanup.sh
- Kør en netværkssynkronisering med CCO-administratorlegitimationsoplysninger.
Additional Information
Relateret Cisco-problem-id: https://bst.cloudapps.cisco.com/bugsearch/bug/CSCwr45134