Connectrix MDS: Сбой синхронизации локальной сети «Error Checking for Token Expiration-400 bad request»

Summary: Сбой синхронизации локальной сети с ошибкой «Ошибка при проверке истечения срока действия маркера — неверный запрос 400»

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Версия сервера SSM OnPrem:  9-202507

Сбой локальной сетевой или запланированной синхронизации с ошибкой:

"Error When Checking for Token Expiration 784: unexpected token at '<html> <head><title>400 Bad Request<title><head> <body> <center>
400 Bad Request
<center> <hr><center>nginx/1.29.1<center> <body> <html> '"

Сообщение об ошибке на экране

Cause

Это связано с переносом поставщика удостоверений (IDP) из Ping в Okta. 

Поскольку существующие маркеры были выданы методом проверки связи IDP, эти маркеры недействительны в сервисе Okta, что приводит к сбою синхронизации. Если после этого переноса будут созданы какие-либо учетные записи локальной среды, Okta выпустит токены, и эта проблема не будет обнаружена. 

В локальной среде это не проблема. Миграция в Okta затронет все локальные серверы. 

Resolution

Условия:
Выполняется синхронизация локальной среды с сетью или по расписанию, и база данных имеет маркеры доступа до переноса команды ping на Okta.

Идентификатор проблемы Cisco: CSCwr45134

Временное решение 1.

  1. Создайте новую локальную учетную запись
Войдите на портал >локального рабочего пространства администратора Перейдите к виджету Учетные записи.
Создайте новую локальную учетную запись и подтвердите запрос, указав свои учетные данные. Это действие создает новый токен с Okta (нашим новым IDP), обеспечивая непрерывную функциональность. После завершения создания учетной записи выполните полную сетевую синхронизацию для учетных записей, для которых произошел сбой.
Имейте в виду, что вы не выполняете никаких действий с этой учетной записью, никакого переноса устройства или регистрации в CSSM. Он нужен только для обновления внутреннего токена, который используется всеми учетными записями локальной среды для связи с облаком.
  1. Синхронизация вручную:
В качестве альтернативы синхронизации по сети можно выполнить синхронизацию вручную, которая устраняет проблему только однократно. Это не окончательное решение.
  1. Не согласовано, но ожидание истечения срока действия токена является другим вариантом
Ожидается, что проблема разрешится автоматически через несколько дней (28, 160, 180 и т. д.) после истечения срока действия старого маркера ping, кэшированного в нашем контейнере. Можно дождаться этого автоматического разрешения.

Временное решение 2.
Примените скрипт для очистки токенов (прилагается к статье).

  • Создание моментального снимка виртуальной машины и резервная копия onprem-console database_backup перед применением временного решения.
  • Перенесите вложенные файлы в каталог var/files/patches с помощью WinSCP
  • Выполните следующую команду:
Upgrade patches: sync_issue_token_cleanup.sh
  • Выполните синхронизацию сети с учетными данными администратора CCO.
 
Примечание. Если после применения сценария SSM OnPrem не синхронизируется по крайней мере каждые 9 часов (например, до истечения 10-часового срока), синхронизация снова начинает завершаться сбоем. В таких случаях единственным временным решением является повторное применение сценария и продолжение синхронизации каждые 9 часов или реже.

Additional Information

Связанный идентификатор проблемы Cisco: https://bst.cloudapps.cisco.com/bugsearch/bug/CSCwr45134 Эта гиперссылка позволяет перейти на сайт за пределами Dell Technologies.

Affected Products

Connectrix MDS-9148T
Article Properties
Article Number: 000376216
Article Type: Solution
Last Modified: 06 Nov 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.