Connectrix MDS:OnPrem 網路同步失敗「檢查權杖到期錯誤 - 400 錯誤要求」
Summary: OnPrem 網路同步失敗,並顯示「檢查權杖到期時發生錯誤 - 400 錯誤要求」
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
SSM OnPrem 伺服器版本: 9-202507
OnPrem 網路或排程同步失敗,並顯示錯誤:
"Error When Checking for Token Expiration 784: unexpected token at '<html> <head><title>400 Bad Request<title><head> <body> <center> 400 Bad Request <center> <hr><center>nginx/1.29.1<center> <body> <html> '"

Cause
這是因為身分識別提供者 (IDP) 從 Ping 遷移至 Okta。
由於現有令牌是由IDP Ping頒發的,因此這些令牌在Okta服務中無效,從而導致同步失敗。如果在此遷移後建立了任何 OnPrem 帳戶,Okta 會發出權杖,且不會出現此問題。
這不是 OnPrem 上的問題。遷移至 Okta 會影響所有 OnPrem 伺服器。
Resolution
景:
OnPrem 同步會使用網路或排程執行,且在 Ping 至 Okta 遷移之前,資料庫具有存取權杖。
Cisco 問題 ID: CSCwr45134
因應措施 1:
- 建立新的內部部署帳戶
登入 OnPrem Admin Workspace 入口網站 > 前往 帳戶小工具。
建立新的 OnPrem 帳戶,並提供您的登入資料以核准要求。此操作會使用 Okta(我們的新 IDP)生成一個新令牌,從而啟用持續功能。帳戶建立完成後,對失敗的帳戶執行完整的網路同步。
建立新的 OnPrem 帳戶,並提供您的登入資料以核准要求。此操作會使用 Okta(我們的新 IDP)生成一個新令牌,從而啟用持續功能。帳戶建立完成後,對失敗的帳戶執行完整的網路同步。
請記住,您不會使用此帳戶執行任何操作,也不會進行設備傳輸或向 CSSM 註冊。這僅會重新整理所有 OnPrem 帳戶用來與雲端對話的內部權杖。
- 手動同步:
作為網路同步的替代方法,您可以執行手動同步,這只能一次性解決問題。這不是永久修復。
- 不一致,但等待令牌過期是另一種選擇
一旦緩存在容器中的舊 Ping 令牌過期,預計此問題將在幾天后(28、160、180 等)自動解決。您可以選擇等待此自動解決。
因應措施 2:
應用用於清理令牌的腳本(附加到文章)。
- 拍攝 VM 快照 和備份
onprem-console database_backup在套用因應措施之前。 - 將附加的檔案傳輸 至
var/files/patches使用 WinSCP - 執行 以下命令:
Upgrade patches: sync_issue_token_cleanup.sh
- 使用 CCO 管理員認證執行網路同步。
注意:應用腳本后,如果 SSM OnPrem 未至少每 9 小時同步一次(例如,在 10 小時到期之前),同步將再次開始失敗。在這種情況下,唯一的解決方法是重新應用腳本並繼續每 9 小時或更短時間同步一次。
Additional Information
Affected Products
Connectrix MDS-9148TArticle Properties
Article Number: 000376216
Article Type: Solution
Last Modified: 06 Nov 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.