Connectrix MDS:本地网络同步失败并显示“Error checking for token expiration-400 bad request”(检查令牌过期时出错-400 错误请求)

Summary: 本地网络同步失败,并显示“Error When Checking for Token Expiration-400 Bad Request”(检查令牌过期时出错-400 错误请求)

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Symptoms

SSM 本地服务器版本:  9-202507

本地网络或计划同步失败,并显示错误:

"Error When Checking for Token Expiration 784: unexpected token at '<html> <head><title>400 Bad Request<title><head> <body> <center>
400 Bad Request
<center> <hr><center>nginx/1.29.1<center> <body> <html> '"

错误屏幕消息

Cause

这是由于身份提供商 (IDP) 从 Ping 迁移到 Okta。

由于现有令牌是由 IDP Ping 颁发的,因此这些令牌在 Okta 服务中无效,导致同步失败。如果在此迁移后创建了任何本地账户,则 Okta 会颁发令牌,并且不会出现此问题。

这不是本地的问题。此次迁移到 Okta 会影响所有本地服务器。 

Resolution

条件:
在 Ping 到 Okta 迁移之前,使用网络或计划执行了本地同步,并且数据库具有访问令牌。

Cisco 问题 ID: CSCwr45134

解决方法 1:

  1. 创建新的本地帐户
登录到 OnPrem Admin Workspace 门户 > ,转至 “帐户”小组件。
创建新的本地帐户,并通过提供凭据批准请求。此作将生成一个包含 Okta(我们的新 IDP)的新令牌,从而实现持续的功能。帐户创建完成后,对故障帐户执行完全网络同步。
请记住,您不会使用此帐户执行任何作,不会转移设备,也不会注册到 CSSM。它只是为了刷新所有本地帐户用于与云通信的内部令牌。
  1. 手动同步
作为网络同步的替代方法,您可以执行手动同步,这只能一次性解决问题。这不是永久修复。
  1. 不一致,但等待令牌到期是另一种选择
容器中缓存的旧 Ping 令牌过期后,预计问题将在几天后(28、160、180 等)自动解决。您可以选择等待此自动解决。

解决方法 2:
应用用于清除令牌的脚本(附在文章中)。

  • 拍摄虚拟机快照 和备份 onprem-console database_backup 应用解决方法之前。
  • 传输附件 var/files/patches 通过使用 WinSCP
  • 运行 以下命令:
Upgrade patches: sync_issue_token_cleanup.sh
  • 使用 CCO 管理员凭据运行网络同步
 
提醒:应用脚本后,如果 SSM OnPrem 未至少每 9 小时同步一次(例如,在 10 小时到期之前),同步将再次开始失败。在这种情况下,唯一的解决方法是重新应用脚本并继续每 9 小时或更短时间同步一次。

Additional Information

Affected Products

Connectrix MDS-9148T
Article Properties
Article Number: 000376216
Article Type: Solution
Last Modified: 06 Nov 2025
Version:  2
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