NVP-vProxy: 文件级恢复失败,并显示错误: Could not mount VMDKs ...ServerFaultCode:出现一般系统错误...
Summary: 文件级恢复失败,并显示错误:Could not mount VMDKs ...ServerFaultCode:A general system error occurred: vix error codes = (3016, 0)
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
基于 vProxy 的文件级恢复失败,并显示一条错误消息,指出一个或多个磁盘无法装载在目标虚拟机上:
159373:nsrvproxy_flr: vProxy Log: 2017/07/19 14:54:17 ERROR: [@(#) Build number: 160] Could not mount VMDKs [[FLR TMP Datastore name] Source_vm-MoREF##-disk-key-####.vmdk onto VM 'FLR Target VM Name' (Target vm-MoREF#) filesystems: ListProcesses() failed: ServerFaultCode: A general system error occurred: vix error codes = (3016, 0).
Cause
FLR 进程无法装载列出的磁盘,因为它无法联系目标虚拟机上的 VMWare 工具。 根据 VMWare Vixapi 编程指南,错误 3016 表示 VMWare 工具未运行:
https://www.vmware.com/support/developer/vix-api/vix17_reference/errors/errors.html
https://www.vmware.com/support/developer/vix-api/vix17_reference/errors/errors.html
3016 VIX_E_TOOLS_NOT_RUNNING Guest tools is not running.
出现此错误消息的原因有多种:
- VMware 工具已安装,但当前未在目标虚拟机上运行。
- VMware 工具已安装,但目标虚拟机上已过时。
- 目标虚拟机上的 VMware 工具超时,导致装载失败。
- VMware 工具报告目标虚拟机上出现错误,无法完成装载请求。
Resolution
要识别并解决问题,请检查以下内容:
- 检查您尝试将文件恢复到的目标虚拟机,并验证 VMware 工具是否: 已安装、最新且当前正在运行。
- 检查目标虚拟机上的日志中是否有来自 VMware 工具的任何错误或警告实例:
- 在 Windows VM 上,VMware 工具将记录到 Windows 事件日志
- 在 Linux VM 上,可以查看工具日志中是否有任何报告的问题。 日志的位置可在位于以下位置的 tools.conf 文件中找到: /etc/vmware-tools/tools.conf
- 在 Linux VM 上,可以查看工具日志中是否有任何报告的问题。 日志的位置可在位于以下位置的 tools.conf 文件中找到: /etc/vmware-tools/tools.conf
如果 VMware 工具超时或发布错误,请向 VMWare 技术支持部门创建支持案例以获得帮助。
说明: 增加了 vProxy FLR 计时,以允许 VMware 工具有更多时间在 FLR 恢复期间完成磁盘装载请求。
294105 vProxy 的错误 增加了在 FLR 装载期间虚拟机挂起的容错
对于 NetWorker 9.1.x - vProxy 版本 2.0.2-39 及更高版本
对于 NetWorker 9.2.x - vProxy 版本 2.1.1-44 及更高版本
解决方法:
- 您可以执行到另一个虚拟机的虚拟磁盘恢复,并手动将所需的文件复制到目标虚拟机。
- 您可以执行虚拟机恢复并将文件从恢复的虚拟机复制到目标虚拟机。
Affected Products
VMwareArticle Properties
Article Number: 000057457
Article Type: Solution
Last Modified: 23 Oct 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.