NVP-vProxy: La recuperación a nivel de archivos falla con el error: No se pudieron montar los VMDK... Código de falla del servidor: Se produjo un error general del sistema...
Summary: La recuperación a nivel de archivos falla con el error: No se pudieron montar los VMDK... Código de falla del servidor: Se produjo un error general del sistema: códigos de error vix = (3016, 0) ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
La recuperación en el nivel de archivos basada en vProxy falla con un error que indica que uno o más de los discos no se pudieron montar en la VM de destino:
159373:nsrvproxy_flr: vProxy Log: 2017/07/19 14:54:17 ERROR: [@(#) Build number: 160] Could not mount VMDKs [[FLR TMP Datastore name] Source_vm-MoREF##-disk-key-####.vmdk onto VM 'FLR Target VM Name' (Target vm-MoREF#) filesystems: ListProcesses() failed: ServerFaultCode: A general system error occurred: vix error codes = (3016, 0).
Cause
El proceso de FLR no puede montar los discos enumerados porque no puede comunicarse con las herramientas de VMware en la VM de destino. Según la guía de programación de VMware Vixapi, el error 3016 indica que las herramientas de VMware no se están ejecutando:
https://www.vmware.com/support/developer/vix-api/vix17_reference/errors/errors.html
https://www.vmware.com/support/developer/vix-api/vix17_reference/errors/errors.html
3016 VIX_E_TOOLS_NOT_RUNNING Guest tools is not running.
Este mensaje de error puede aparecer por varios motivos:
- Las herramientas de VMware están instaladas, pero no se están ejecutando actualmente en la VM de destino.
- Las herramientas de VMware están instaladas, pero están desactualizadas en la VM de destino.
- Se agota el tiempo de espera de las herramientas de VMware en la VM de destino, lo que provoca la falla de los montajes.
- Las herramientas de VMware informan un error en la VM de destino y no pueden completar las solicitudes de montaje.
Resolution
Para identificar y resolver el problema, compruebe lo siguiente:
- Compruebe la VM de destino en la que intenta recuperar archivos y verifique que las herramientas de VMware cumplan con lo siguiente: Están instalados, actualizados y en ejecución.
- Compruebe si hay instancias de errores o advertencias de VMware en la VM de destino en los registros de la VMware Tools:
- En las máquinas virtuales de Windows, las herramientas de VMware se registrarán en los registros de eventos de Windows: en las máquinas virtuales de Linux, puede revisar el registro de herramientas en busca de problemas informados
. La ubicación de los registros se puede encontrar en el archivo tools.conf ubicado en: /etc/vmware-tools/tools.conf
. La ubicación de los registros se puede encontrar en el archivo tools.conf ubicado en: /etc/vmware-tools/tools.conf
Si se agota el tiempo de espera de las herramientas de VMware o se registran errores, abra un caso de soporte con el soporte técnico de VMware para obtener ayuda.
NOTA: Se aumentaron los tiempos de FLR de vProxy para permitir que las herramientas de VMware tengan más tiempo a fin de completar las solicitudes de montaje de disco durante las recuperaciones de FLR.
ERROR 294105 vProxy Aumentar la tolerancia para el bloqueo de VM durante el montaje de FLR
Para NetWorker 9.1.x: vProxy versión 2.0.2-39 y superior
Para NetWorker 9.2.x: vProxy versión 2.1.1-44 y superior
Solución alternativa:
- Puede realizar una recuperación de disco virtual en otra máquina virtual y copiar manualmente los archivos necesarios en la máquina virtual de destino.
- Puede realizar una recuperación de máquina virtual y copiar los archivos de la VM recuperada a la VM de destino.
Affected Products
VMwareArticle Properties
Article Number: 000057457
Article Type: Solution
Last Modified: 23 Oct 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.