NVP-vProxy: Odzyskiwanie na poziomie plików kończy się niepowodzeniem z błędem: Nie można zamontować VMDK... Kod błędu serwera: Wystąpił ogólny błąd systemowy...
Summary: Odzyskiwanie na poziomie plików kończy się niepowodzeniem z błędem: Nie można zamontować VMDK... Kod błędu serwera: Wystąpił ogólny błąd systemowy: kody błędów vix = (3016, 0)
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Odzyskiwanie na poziomie plików oparte na vProxy kończy się niepowodzeniem z komunikatem o błędzie informującym, że co najmniej jeden dysk nie mógł zostać zamontowany na docelowej maszynie wirtualnej:
159373:nsrvproxy_flr: vProxy Log: 2017/07/19 14:54:17 ERROR: [@(#) Build number: 160] Could not mount VMDKs [[FLR TMP Datastore name] Source_vm-MoREF##-disk-key-####.vmdk onto VM 'FLR Target VM Name' (Target vm-MoREF#) filesystems: ListProcesses() failed: ServerFaultCode: A general system error occurred: vix error codes = (3016, 0).
Cause
Proces FLR nie może zainstalować wymienionych dysków, ponieważ nie może skontaktować się z narzędziami VMWare na docelowej maszynie wirtualnej. Zgodnie z przewodnikiem programowania VMWare Vixapi błąd 3016 wskazuje, że narzędzia VMWare nie są uruchomione:
https://www.vmware.com/support/developer/vix-api/vix17_reference/errors/errors.html
https://www.vmware.com/support/developer/vix-api/vix17_reference/errors/errors.html
3016 VIX_E_TOOLS_NOT_RUNNING Guest tools is not running.
Ten komunikat o błędzie może pojawić się z wielu powodów:
- Narzędzia VMware są zainstalowane, ale nie są obecnie uruchomione na docelowej maszynie wirtualnej.
- Narzędzia VMware są zainstalowane, ale są nieaktualne na docelowej maszynie wirtualnej.
- Narzędzia VMware przekraczają limit czasu na docelowej maszynie wirtualnej, co powoduje niepowodzenie instalacji.
- Narzędzia VMware zgłaszają błąd na docelowej maszynie wirtualnej i nie mogą ukończyć żądań instalacji.
Resolution
Aby zidentyfikować i rozwiązać problem, sprawdź następujące kwestie:
- Sprawdź docelową maszynę wirtualną, do której próbujesz odzyskać pliki, i sprawdź, czy dostępne są narzędzia VMware: Zainstalowane, aktualne i aktualnie uruchomione.
- Sprawdź dzienniki na docelowej maszynie wirtualnej pod kątem wystąpień błędów lub ostrzeżeń z narzędzi VMware:
- Na maszynach wirtualnych z systemem Windows narzędzia VMware będą logować się do dzienników
zdarzeń systemu Windows — na maszynach wirtualnych z systemem Linux można przejrzeć dziennik narzędzi pod kątem zgłoszonych problemów. Lokalizację logów można znaleźć w pliku tools.conf znajdującym się w: /etc/vmware-tools/tools.conf
zdarzeń systemu Windows — na maszynach wirtualnych z systemem Linux można przejrzeć dziennik narzędzi pod kątem zgłoszonych problemów. Lokalizację logów można znaleźć w pliku tools.conf znajdującym się w: /etc/vmware-tools/tools.conf
Jeśli narzędzie VMware przekracza limit czasu lub zgłasza błędy, otwórz zgłoszenie do pomocy technicznej VMware, aby uzyskać pomoc.
UWAGA: Czasy FLR vProxy zostały wydłużone, aby dać narzędziom VMware więcej czasu na ukończenie żądań instalacji dysku podczas odzyskiwania FLR.
BŁĄD 294105 vProxy: zwiększenie tolerancji na zawieszenie maszyny wirtualnej podczas instalacji FLR
W przypadku NetWorker 9.1.x — vProxy w wersji 2.0.2-39 i nowszych
W przypadku NetWorker 9.2.x — vProxy w wersji 2.1.1-44 i nowszych
Obejście problemu:
- Można przeprowadzić odzyskiwanie dysku wirtualnego na inną maszynę wirtualną i ręcznie skopiować wymagane pliki na docelową maszynę wirtualną.
- Możesz wykonać odzyskiwanie maszyny wirtualnej i skopiować pliki z odzyskanej maszyny wirtualnej na docelową maszynę wirtualną.
Affected Products
VMwareArticle Properties
Article Number: 000057457
Article Type: Solution
Last Modified: 23 Oct 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.