4.X - LDAP Grubu Eklenemiyor

Summary: 4.X - LDAP Grubu Eklenemiyor

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Sorun Açıklaması

PFxM kullanıcı arayüzünde LDAP grubu ekleme girişimi başarısız oluyor.

 

Belirtiler

SSO günlükleri, LDAP'de PF_Admins güvenlik grubunu bulamadığını gösteriyor:

2023-09-07T13:30:38.536385897-05:00 stdout F 2023-09-07 18:30:38.536  INFO 1 --- [nio-8083-exec-8] c.dell.sso.controllers.GroupsController  : Received add group request
2023-09-07T13:30:38.550680368-05:00 stdout F 2023-09-07 18:30:38.550 ERROR 1 --- [nio-8083-exec-8] c.dell.sso.controllers.GroupsController  : Failed to add group request: Failed to find request group PF_Admins 
2023-09-07T13:30:38.550719535-05:00 stdout F com.dell.sso.exceptions.KeycloakException: Failed to find request group PF_Admins

 

Active Directory yapılandırması, PF_Admins güvenlik grubunun var olduğunu gösterir.

 

Etki

LDAP grupları eklenemiyor.

 

Cause

Active Directory bilgilerinin yalnızca LDAP sunucusuna ilk bağlantı sırasında önbelleğe alındığı ve yalnızca 10 saniyelik bilgileri aldığı bir yazılım kodu sınırlaması vardır. Bir yönetici, PFxM kullanıcı arayüzüne bir LDAP grubu eklemeye çalıştığında ve LDAP sunucusundaki güvenlik grubu Active Directory sunucusuna ilk bağlantıdan sonra oluşturulduğunda, bu grup ilk önbellekte depolanmaz ve LDAP grubu ekleme işlemi başarısız olur. Yönetici LDAP grubunu eklemeye çalıştığında, yazılım bağlanmaz ve yeni bir Active Directory listesi çekmez; bunun yerine yalnızca ilk LDAP bağlantısındaki ilk önbelleği kullanır.

 

Resolution

Geçici Çözüm

PowerFlex Manager sürüm 4.5 ve altı aşağıdaki geçici çözümü yapmalıdır:

LDAP sunucu bağlantısını kaldırın ve ardından PFxM'yi LDAP sunucusuna yeniden bağlayın.
*Bazen LDAP grubunu düzgün bir şekilde bulmak için bu işlemin birden çok kez yapılması gerekir.

 

PowerFlex Manager 4.5.1 ve üzeri sürümler aşağıdaki geçici çözümü sağlayabilir:

PFMP'den sistem değişkenlerini ayarlamak için aşağıdakileri gerçekleştirin:

#SSO variable
SSO_IP=`kubectl get svc -A | grep "sso " | awk '{print $4}'`

#Platform Manager Token
PM_TOKEN=`curl -k --location --request POST "https://${SSO_IP}:8080/rest/auth/login" --header 'Accept: application/json' --header 'Content-Type: application/json' --data '{"username": "admin","password": "Scaleio123!" }' | jq -r .access_token`
#Change the password to the password used to login to the PFxM UI

#Ingress IP
INGRESS_IP=$(kubectl get svc -A | grep -i rke2-ingress-nginx-controller | awk 'NR==1{print $5}')

#LDAP ID
LDAP_ID=$(curl -k https://${INGRESS_IP}/rest/v1/directory-services --header 'Accept: application/json' --header 'Content-Type: application/json' --header "Authorization: Bearer ${PM_TOKEN}" | jq -r '.[0].id')

 

PFMP'den LDAP sunucusuna senkronizasyonu başlatın:

curl -k -X POST https://${INGRESS_IP}/rest/v1/directory-services/${LDAP_ID}/sync --header "Authorization: Bearer ${PM_TOKEN}" --header 'Accept: application/json' --header 'Content-Type: application/json'

 

Yukarıdaki komut başarılı olursa ekrana hiçbir şey döndürmemelidir.
15 dakika kadar bekleyin ve kullanıcı veya grup ekleme işlemini tekrar deneyin.

 

Etkilenen Sürümler

PowerFlex Manager 4.x

 

Düzeltildiği Sürüm

PowerFlex Manager 4.5.1

 

Article Properties
Article Number: 000218374
Article Type: Solution
Last Modified: 20 Feb 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.