4.X - Impossibile aggiungere un gruppo LDAP
Summary: 4.X - Impossibile aggiungere un gruppo LDAP
Symptoms
Descrizione del problema
Il tentativo di aggiungere un gruppo LDAP non riesce all'interno dell'interfaccia utente di PFxM.
Sintomi
I registri SSO mostrano che non è in grado di trovare il gruppo di sicurezza PF_Admins in LDAP:
2023-09-07T13:30:38.536385897-05:00 stdout F 2023-09-07 18:30:38.536 INFO 1 --- [nio-8083-exec-8] c.dell.sso.controllers.GroupsController : Received add group request 2023-09-07T13:30:38.550680368-05:00 stdout F 2023-09-07 18:30:38.550 ERROR 1 --- [nio-8083-exec-8] c.dell.sso.controllers.GroupsController : Failed to add group request: Failed to find request group PF_Admins 2023-09-07T13:30:38.550719535-05:00 stdout F com.dell.sso.exceptions.KeycloakException: Failed to find request group PF_Admins
La configurazione di Active Directory mostra che il gruppo di sicurezza PF_Admins esiste.
Impatto
Impossibile aggiungere gruppi LDAP.
Cause
Esiste una limitazione del codice software per cui le informazioni di Active Directory vengono memorizzate nella cache solo al momento della connessione iniziale al server LDAP ed estraggono solo 10 secondi di informazioni. Quando un amministratore tenta di aggiungere un gruppo LDAP nell'interfaccia utente PFxM e il gruppo di sicurezza sul server LDAP è stato creato dopo la connessione iniziale al server Active Directory, questo gruppo non verrà archiviato nella cache iniziale e l'aggiunta del gruppo LDAP avrà esito negativo. Quando l'amministratore tenta di aggiungere il gruppo LDAP, il software non si connette ed esegue il pull di un nuovo elenco Active Directory, ma utilizza solo la cache iniziale della prima connessione LDAP.
Resolution
Soluzione alternativa
PowerFlex Manager versione 4.5 e precedenti deve eseguire la seguente soluzione alternativa:
Rimuovere la connessione del server LDAP, quindi riconnettere il PFxM al server LDAP.
*A volte, questa operazione deve essere eseguita più volte per trovare correttamente il gruppo LDAP.
PowerFlex Manager versione 4.5.1 e successive possono eseguire la seguente soluzione alternativa:
Dal PFMP, effettuare le seguenti operazioni per impostare le variabili di sistema:
#SSO variable
SSO_IP=`kubectl get svc -A | grep "sso " | awk '{print $4}'`
#Platform Manager Token
PM_TOKEN=`curl -k --location --request POST "https://${SSO_IP}:8080/rest/auth/login" --header 'Accept: application/json' --header 'Content-Type: application/json' --data '{"username": "admin","password": "Scaleio123!" }' | jq -r .access_token`
#Change the password to the password used to login to the PFxM UI
#Ingress IP
INGRESS_IP=$(kubectl get svc -A | grep -i rke2-ingress-nginx-controller | awk 'NR==1{print $5}')
#LDAP ID
LDAP_ID=$(curl -k https://${INGRESS_IP}/rest/v1/directory-services --header 'Accept: application/json' --header 'Content-Type: application/json' --header "Authorization: Bearer ${PM_TOKEN}" | jq -r '.[0].id')
Avviare la sincronizzazione da PFMP al server LDAP:
curl -k -X POST https://${INGRESS_IP}/rest/v1/directory-services/${LDAP_ID}/sync --header "Authorization: Bearer ${PM_TOKEN}" --header 'Accept: application/json' --header 'Content-Type: application/json'
Se viene eseguito correttamente, il comando precedente non dovrebbe restituire nulla allo schermo.
Attendere fino a 15 minuti e provare nuovamente l'operazione di aggiunta di un utente o di un gruppo.
Versioni interessate
PowerFlex Manager 4. x
Risolto nella versione
PowerFlex Manager 4.5.1