PowerProtect: Løse analysefeil i addon.cfg-konfigurasjonsfil for planlagt Oracle-sikkerhetskopiering
Summary: For kunder som bruker Dell EMC PowerProtect Data Manager (PPDM) med sikkerhetskopiering av Oracle-database, har det blitt rapportert om problemer med planlagte sikkerhetskopieringer. Imidlertid fungerer ad-hoc manuelle sikkerhetskopier uten problemer. Rotårsaken er identifisert som en tom del i addon.cfg-filen ([]), som er et resultat av at getInstallOracleSidUser()-funksjonen ikke håndterer utdataene fra en bestemt commandco riktig. Dette problemet løses i den kommende 19.18-versjonen og den neste 19.17-oppdateringen. Kunder som ikke ønsker å oppgradere, kan be om en hurtigreparasjon for 19.16-versjonen. ...
Symptoms
* Oracle backup planlagt har problemer * Adhoc manuell sikkerhetskopiering kan fungere * Python kan ikke håndtere INI-format konfigurasjonsfil med tom seksjon, som "[]" * Tom seksjon lagt til i addon.cfg fil * Støyinformasjon lagt til i kartet forårsaker tom seksjon * Støyinformasjon kommer fra Imperva Cyber kommandolinje * Imperva Cyber discovery av Oracle-databasen forstyrrer sikkerhetskopieringsprosessen.
Vi kan se feilmeldingen nedenfor i loggen:
[2024-07-28 17:00:17,742 GMT| 2024-07-29 01:00:17,743555 +08| APPBACKUPASSETS_89AE63F6DB2D6224| PID-77095| TID-140512660902656| ERROR| TraceContext-TRACE_ID:89ae63f6db2d6224;EXEC_ID:a631207817a80e3d] /opt/dpsapps/agentsvc/tmp/_MEIng5l7D/AddOnManager/AddOnManager.pyc-getAllAddOnsMap()-Line 140- Exception Source contains parsing errors: '/opt/dpsapps/agentsvc/AddOns/D2B24128_9482_44D2_8723_6D211DB49BFB/addon.cfg' [line 26]: '[]\n' in getAllAddOnsMap.Traceback (most recent call last): File "AddOnManager/AddOnManager.py", line 126, in getAllAddOnsMap File "AddOnManager/AddOnManager.py", line 96, in __add2modules File "AddOnManager/AddOnManager.py", line 87, in instantiateMainClass File "nsr/AppAgentService/AddOns/D2B24128_9482_44D2_8723_6D211DB49BFB/AddOnMain.py", line 42, in get_instance File "nsr/AppAgentService/AddOns/D2B24128_9482_44D2_8723_6D211DB49BFB/AddOnMain.py", line 63, in __init__ File "nsr/AppAgentService/AddOns/D2B24128_9482_44D2_8723_6D211DB49BFB/AddOnBase.py", line 1319, in parseConfigFile File "configparser.py", line 713, in read File "configparser.py", line 1132, in _readconfigparser.ParsingError: Source contains parsing errors: '/opt/dpsapps/agentsvc/AddOns/D2B24128_9482_44D2_8723_6D211DB49BFB/addon.cfg' [line 26]: '[]\n'
Og vi kan se at det er [] i addon.cfg automatisk.
Cause
Python kan ikke håndtere INI-formatkonfigurasjonsfilen med tom seksjon, som "[]". Hvis konfigurasjonen er som det fulgte eksemplet, vil den ikke analysere:
[+APX1] agent_user = oragrid [ASMCR5R] agent_user = oracloud []
Så det vi kan vite er problemet kommer fra den tomme delen "[]" i addon.cfg filen.
Støyinformasjonen kommer fra Imperva Cyber som brukes av kunden. Når Imperva Cyber kjører med Application System Discovery samtidig, vil den tomme delen "[]" bli lagt til i addon.cfg-filen. Imperva Cyber-kommandolinjen ser slik ut:
sh -c /opt/imperva/ragent/bin/db-discovery.sh -d Oracle -f /opt/imperva/ragent/bin/ -r "tnslsnr" -i _pmon_ -e "false" -s "oracle+ASM[A-Za-z0-9]{0,}|asm_d[000-999]|ora_d[000-999]" -a "false" -p 9999 -o /opt/imperva/ragent/var/db_discovery_oracle.txt -ipc 2>>/opt/imperva/ragent/var/stderr_db_discovery.txt
/bin/bash /opt/imperva/ragent/bin/db-discovery.sh -d Oracle -f /opt/imperva/ragent/bin/ -r tnslsnr -i _pmon_ -s oracle+ASM[A-Za-z0-9]{0,}|asm_d[000-999]|ora_d[000-999] -a "false" -p 9999 -o /opt/imperva/ragent/var/db_discovery_oracle.txt -ipc
I utgangspunktet bruker Imperva Cyber samme måte å oppdage Oracle-databasen, men den setter nøkkelordet {}pmon_{_} i kommandolinjen, og vår funksjon håndterer ikke utdataene inneholder Imperva Cyber-kommandoer brønnen.
Resolution
Du kan løse problemet med den planlagte Oracle-sikkerhetskopieringen ved å utføre manuelle sikkerhetskopieringer som en midlertidig løsning. Dette problemet oppstår på grunn av Pythons manglende evne til å håndtere INI-formatkonfigurasjonsfilen med tomme deler, som "[]". Dette problemet kan spores tilbake til addon.cfg-filen, som inneholder en tom del. En løsning vil være tilgjengelig i 19.18-versjonen og den neste 19.17-oppdateringen. Hvis du bruker 19.16-versjonen og ikke har tenkt å oppgradere, kan du kontakte Dells kundestøtte for å få mer hjelp og for å be om en hurtigreparasjon.